diff --git a/README.md b/README.md
index f9225ed..f5f652b 100644
--- a/README.md
+++ b/README.md
@@ -1,2 +1,8 @@
# gparted
+GParted is an industrial-strength package for creating, destroying, resizing, checking and copying partitions, and the file systems on them.
+This is useful for creating space for new operating systems, reorganizing disk usage, copying data residing on hard disks and mirroring one partition with another (disk imaging).
+
+A hard disk is usually subdivided into one or more partitions.
+These partitions are normally not re-sizable (making one larger and the adjacent one smaller) The purpose of GParted is to allow the individual to take a hard disk and change the partition organization therein, while preserving the partition contents.
+
diff --git a/gparted-0.11.0-filedesktop_no_startupnotify.patch b/gparted-0.11.0-filedesktop_no_startupnotify.patch
new file mode 100644
index 0000000..153fca2
--- /dev/null
+++ b/gparted-0.11.0-filedesktop_no_startupnotify.patch
@@ -0,0 +1,9 @@
+diff -Nru gparted-0.11.0.orig/gparted.desktop.in.in gparted-0.11.0/gparted.desktop.in.in
+--- gparted-0.11.0.orig/gparted.desktop.in.in 2010-05-28 23:18:25.000000000 +0200
++++ gparted-0.11.0/gparted.desktop.in.in 2012-02-26 23:50:15.001119698 +0100
+@@ -8,4 +8,4 @@
+ Terminal=false
+ Type=Application
+ Categories=GNOME;System;Filesystem;
+-StartupNotify=true
++StartupNotify=false
diff --git a/gparted-0.14.1-desktop-use_gparted_pkexec.patch b/gparted-0.14.1-desktop-use_gparted_pkexec.patch
new file mode 100644
index 0000000..0cf00e3
--- /dev/null
+++ b/gparted-0.14.1-desktop-use_gparted_pkexec.patch
@@ -0,0 +1,24 @@
+diff -Nru gparted-0.13.0.orig/gparted.desktop gparted-0.13.0/gparted.desktop
+--- gparted-0.14.1.orig/gparted.desktop.orig 2012-12-15 12:13:44.617156912 +0100
++++ gparted-0.14.1/gparted.desktop 2012-12-15 12:14:08.697910276 +0100
+@@ -209,7 +209,7 @@
+ Comment[zh_CN]=创建、重新组织或删除分区
+ Comment[zh_HK]=建立、編輯或刪除分割區
+ Comment[zh_TW]=建立、編輯或刪除分割區
+-Exec=kdesudo /usr/local/sbin/gparted %f
++Exec=%{_bindir}/gparted-pkexec %f
+ Icon=gparted
+ Terminal=false
+ Type=Application
+diff -Nru gparted-0.13.0.orig/gparted.desktop.in.in gparted-0.13.0/gparted.desktop.in.in
+--- gparted-0.13.0.orig/gparted.desktop.in.in 2012-08-05 21:11:24.467479696 +0200
++++ gparted-0.13.0/gparted.desktop.in.in 2012-08-05 21:11:59.976122931 +0200
+@@ -3,7 +3,7 @@
+ _GenericName=Partition Editor
+ _X-GNOME-FullName=GParted Partition Editor
+ _Comment=Create, reorganize, and delete partitions
+-Exec=@gksuprog@ @installdir@/gparted %f
++Exec=/usr/bin/gparted-pkexec %f
+ Icon=gparted
+ Terminal=false
+ Type=Application
diff --git a/gparted-0.3.3-hal.patch b/gparted-0.3.3-hal.patch
new file mode 100644
index 0000000..3bddc66
--- /dev/null
+++ b/gparted-0.3.3-hal.patch
@@ -0,0 +1,33 @@
+--- src/GParted_Core.cc 2006-12-05 14:39:31.000000000 -0500
++++ src/GParted_Core.cc.new 2007-04-02 21:59:01.000000000 -0400
+@@ -54,21 +54,6 @@
+
+ ped_exception_set_handler( ped_exception_handler ) ;
+
+- //disable automount //FIXME: temporary hack, till i find a better solution...
+- std::ofstream fdi_file( "/usr/share/hal/fdi/policy/gparted-disable-automount.fdi" ) ;
+- if ( fdi_file )
+- {
+- fdi_file << "" ;
+- fdi_file << "" ;
+- fdi_file << "" ;
+- fdi_file << "true" ;
+- fdi_file << "" ;
+- fdi_file << "" ;
+- fdi_file << "" ;
+-
+- fdi_file .close() ;
+- }
+-
+ //get valid flags ...
+ for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast( NULL ) ) ;
+ flag ;
+@@ -2287,8 +2272,6 @@
+ if ( p_filesystem )
+ delete p_filesystem ;
+
+- //remove .fdi file..
+- remove( "/usr/share/hal/fdi/policy/gparted-disable-automount.fdi" ) ;
+ }
+
+ } //GParted
diff --git a/gparted-0.5.0-filedesktop.patch b/gparted-0.5.0-filedesktop.patch
new file mode 100644
index 0000000..77b6dd9
--- /dev/null
+++ b/gparted-0.5.0-filedesktop.patch
@@ -0,0 +1,11 @@
+diff -Nru gparted-0.5.0/gparted.desktop.in.in gparted-0.5.0.patched/gparted.desktop.in.in
+--- gparted-0.5.0/gparted.desktop.in.in 2009-11-02 21:43:38.000000000 +0100
++++ gparted-0.5.0.patched/gparted.desktop.in.in 2009-12-24 12:24:11.920980029 +0100
+@@ -9,3 +9,7 @@
+ Type=Application
+ Categories=GNOME;System;Filesystem;
+ StartupNotify=true
++X-KDE-RootOnly=true
++X-KDE-SubstituteUID=true
++X-KDE-Username=root
++
diff --git a/gparted-0.5.0-gtk_include.patch b/gparted-0.5.0-gtk_include.patch
new file mode 100644
index 0000000..85e6cc7
--- /dev/null
+++ b/gparted-0.5.0-gtk_include.patch
@@ -0,0 +1,11 @@
+diff -Nru gparted-0.5.0.orig/src/Win_GParted.cc gparted-0.5.0/src/Win_GParted.cc
+--- gparted-0.5.0.orig/src/Win_GParted.cc 2009-11-25 20:39:15.000000000 +0100
++++ gparted-0.5.0/src/Win_GParted.cc 2009-12-21 23:03:24.000000000 +0100
+@@ -38,6 +38,7 @@
+ #include
+ #include
+ #include
++#include
+
+ namespace GParted
+ {
diff --git a/gparted-pkexec b/gparted-pkexec
new file mode 100644
index 0000000..9d81cc1
--- /dev/null
+++ b/gparted-pkexec
@@ -0,0 +1,3 @@
+#!/bin/sh
+pkexec /usr/sbin/gparted $@
+
diff --git a/gparted-polkit b/gparted-polkit
new file mode 100644
index 0000000..a70661c
--- /dev/null
+++ b/gparted-polkit
@@ -0,0 +1,19 @@
+
+
+
+
+
+ Run GParted
+ Authentication is required to run GParted
+
+ no
+ no
+ auth_admin_keep
+
+ /usr/sbin/gparted
+ TRUE
+
+
+
diff --git a/gparted.spec b/gparted.spec
new file mode 100644
index 0000000..d5fe144
--- /dev/null
+++ b/gparted.spec
@@ -0,0 +1,281 @@
+Name: gparted
+Version: 0.18.0
+Release: 1mamba
+Summary: The Gnome Partition Editor application
+Group: Graphical Desktop/Applications/Administration
+Vendor: openmamba
+Distribution: openmamba
+Packager: Stefano Cotta Ramusino
+URL: http://gparted.sourceforge.net/
+Source: http://downloads.sourceforge.net/gparted/gparted-%{version}.tar.bz2
+Source1: gparted-polkit
+Source2: gparted-pkexec
+Patch1: %{name}-0.5.0-filedesktop.patch
+Patch2: %{name}-0.3.3-hal.patch
+Patch3: %{name}-0.5.0-gtk_include.patch
+Patch4: %{name}-0.11.0-filedesktop_no_startupnotify.patch
+Patch5: %{name}-0.14.1-desktop-use_gparted_pkexec.patch
+License: GPL
+## AUTOBUILDREQ-BEGIN
+BuildRequires: e2fsprogs
+BuildRequires: glibc-devel
+BuildRequires: hfstools
+BuildRequires: jfsutils
+BuildRequires: libatk-devel
+BuildRequires: libcairo-devel
+BuildRequires: libcairomm-devel
+BuildRequires: libfontconfig-devel
+BuildRequires: libfreetype-devel
+BuildRequires: libgcc
+BuildRequires: libglib-devel
+BuildRequires: libglibmm-devel
+BuildRequires: libgtk-devel
+BuildRequires: libgtkmm-devel
+BuildRequires: libpango-devel
+BuildRequires: libpangomm-devel
+BuildRequires: libparted-devel
+BuildRequires: libsigc++2-devel
+BuildRequires: libstdc++6-devel
+BuildRequires: libuuid-devel
+BuildRequires: mdadm
+BuildRequires: ntfsprogs
+BuildRequires: reiser4progs
+BuildRequires: reiserfsprogs
+BuildRequires: xfsprogs
+## AUTOBUILDREQ-END
+BuildRequires: libgtkmm2-devel
+BuildRequires: libreiserfs-devel >= 0.3.0.4
+BuildRequires: jfsutils >= 1.1.5
+Requires: ntfsprogs >= 1.9.0
+Requires: jfsutils >= 1.1.5
+Requires: xfsprogs >= 2.5.6
+Requires: e2fsprogs
+Requires: reiserfsprogs
+Requires: reiser4progs
+Requires: hfstools
+Requires: hfsutils
+Requires: mdadm
+Requires: btrfs-progs
+Requires: gpart
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
+
+%description
+GParted is an industrial-strength package for creating, destroying, resizing, checking and copying partitions, and the file systems on them.
+This is useful for creating space for new operating systems, reorganizing disk usage, copying data residing on hard disks and mirroring one partition with another (disk imaging).
+
+A hard disk is usually subdivided into one or more partitions.
+These partitions are normally not re-sizable (making one larger and the adjacent one smaller) The purpose of GParted is to allow the individual to take a hard disk and change the partition organization therein, while preserving the partition contents.
+
+%prep
+%setup -q
+#%patch1 -p1
+#%patch2
+#%patch3 -p1
+%patch4 -p1
+%patch5 -p1
+
+%build
+%configure --disable-scrollkeeper GKSUPROG=""
+%make
+
+%install
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+%makeinstall
+
+install -D -m 0644 %{SOURCE1} %{buildroot}%{_datadir}/polkit-1/actions/org.gparted.policy
+install -D -m 0755 %{SOURCE2} %{buildroot}%{_bindir}/gparted-pkexec
+
+%find_lang %{name}
+
+%clean
+[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
+
+%files -f %{name}.lang
+%defattr(-,root,root)
+%{_bindir}/gparted-pkexec
+%{_sbindir}/gparted
+%{_sbindir}/gpartedbin
+%{_datadir}/appdata/gparted.appdata.xml
+%{_datadir}/omf/gparted/gparted-*.omf
+%{_datadir}/polkit-1/actions/org.gparted.policy
+%{_datadir}/applications/%{name}.desktop
+%{_datadir}/icons/hicolor/*/apps/gparted.png
+%{_datadir}/icons/hicolor/scalable/apps/gparted.svg
+%dir %{_datadir}/gnome/help/gparted
+#%{_datadir}/gnome/help/gparted/*
+%{_datadir}/gnome/help/gparted/C
+%lang(cs) %{_datadir}/gnome/help/gparted/cs
+%lang(de) %{_datadir}/gnome/help/gparted/de
+%lang(el) %{_datadir}/gnome/help/gparted/el
+%lang(es) %{_datadir}/gnome/help/gparted/es
+%lang(fr) %{_datadir}/gnome/help/gparted/fr
+%lang(gd) %{_datadir}/gnome/help/gparted/gd
+%lang(it) %{_datadir}/gnome/help/gparted/it
+%lang(pt_BR) %{_datadir}/gnome/help/gparted/pt_BR
+%lang(ro) %{_datadir}/gnome/help/gparted/ro
+%lang(ru) %{_datadir}/gnome/help/gparted/ru
+%lang(sl) %{_datadir}/gnome/help/gparted/sl
+%lang(sr) %{_datadir}/gnome/help/gparted/sr
+%lang(sr@latin) %{_datadir}/gnome/help/gparted/sr@latin
+%lang(sv) %{_datadir}/gnome/help/gparted/sv
+%lang(te) %{_datadir}/gnome/help/gparted/te
+%lang(th) %{_datadir}/gnome/help/gparted/th
+%{_mandir}/man8/gparted.8*
+%doc AUTHORS COPYING
+#ChangeLog README
+
+%changelog
+* Thu Feb 20 2014 Automatic Build System 0.18.0-1mamba
+- automatic version update by autodist
+
+* Tue Dec 10 2013 Automatic Build System 0.17.0-1mamba
+- automatic version update by autodist
+
+* Thu Sep 19 2013 Automatic Build System 0.16.2-1mamba
+- automatic version update by autodist
+
+* Wed May 01 2013 Automatic Build System 0.16.1-1mamba
+- automatic version update by autodist
+
+* Wed Apr 24 2013 Automatic Build System 0.16.0-1mamba
+- automatic version update by autodist
+
+* Tue Mar 19 2013 Automatic Build System 0.15.0-1mamba
+- automatic version update by autodist
+
+* Sat Dec 15 2012 Automatic Build System 0.14.1-1mamba
+- automatic version update by autodist
+
+* Thu Oct 11 2012 Automatic Build System 0.14.0-1mamba
+- automatic version update by autodist
+
+* Thu Aug 09 2012 Automatic Build System 0.13.1-1mamba
+- automatic version update by autodist
+
+* Sun Aug 05 2012 Silvan Calarco 0.13.0-2mamba
+- added gparted-pkexec wrapper to workaround gnome menu not working with pkexec
+
+* Sat Jul 14 2012 Automatic Build System 0.13.0-1mamba
+- automatic version update by autodist
+
+* Tue Apr 10 2012 Automatic Build System 0.12.1-1mamba
+- automatic version update by autodist
+
+* Tue Mar 06 2012 Automatic Build System 0.12.0-1mamba
+- automatic version update by autodist
+
+* Sun Feb 26 2012 Silvan Calarco 0.11.0-3mamba
+- desktop file: remove KDE root execution in favour of using pkexec; disable startup notify
+
+* Sun Feb 26 2012 Silvan Calarco 0.11.0-2mamba
+- add polkit file and launch using pkexec
+
+* Wed Dec 14 2011 Automatic Build System 0.11.0-1mamba
+- automatic version update by autodist
+
+* Fri Dec 09 2011 Silvan Calarco 0.10.0-2mamba
+- rebuilt with glib 2.30
+
+* Wed Nov 02 2011 Automatic Build System 0.10.0-1mamba
+- automatic version update by autodist
+
+* Sun Oct 02 2011 Silvan Calarco 0.9.1-2mamba
+- added requirement for gksu and gpart
+
+* Wed Sep 28 2011 Automatic Build System 0.9.1-1mamba
+- automatic version update by autodist
+
+* Tue Jul 19 2011 Automatic Build System 0.9.0-1mamba
+- automatic update by autodist
+
+* Tue May 24 2011 Automatic Build System 0.8.1-1mamba
+- automatic update by autodist
+
+* Wed Feb 16 2011 Automatic Build System 0.8.0-1mamba
+- automatic update by autodist
+
+* Tue Dec 14 2010 Automatic Build System 0.7.1-1mamba
+- automatic update to 0.7.1 by autodist
+
+* Thu Nov 11 2010 Silvan Calarco 0.7.0-2mamba
+- added requirement for btrfs-progs
+
+* Mon Nov 08 2010 Automatic Build System 0.7.0-1mamba
+- automatic update to 0.7.0 by autodist
+
+* Sat Oct 02 2010 Automatic Build System 0.6.4-1mamba
+- automatic update to 0.6.4 by autodist
+
+* Fri Sep 24 2010 Automatic Build System 0.6.3-1mamba
+- automatic update to 0.6.3 by autodist
+
+* Mon Aug 02 2010 Automatic Build System 0.6.2-1mamba
+- automatic update to 0.6.2 by autodist
+
+* Fri Jul 09 2010 Automatic Build System 0.6.1-1mamba
+- automatic update to 0.6.1 by autodist
+
+* Sat Jun 19 2010 Automatic Build System 0.6.0-1mamba
+- automatic update to 0.6.0 by autodist
+
+* Sun Mar 14 2010 Automatic Build System 0.5.2-1mamba
+- automatic update to 0.5.2 by autodist
+
+* Wed Jan 27 2010 Automatic Build System 0.5.1-1mamba
+- automatic update to 0.5.1 by autodist
+
+* Thu Dec 24 2009 Silvan Calarco 0.5.0-2mamba
+- updated desktop entry patch
+
+* Tue Dec 22 2009 Automatic Build System 0.5.0-1mamba
+- automatic update to 0.5.0 by autodist
+
+* Tue Nov 03 2009 Automatic Build System 0.4.8-1mamba
+- automatic update to 0.4.8 by autodist
+
+* Sat Oct 10 2009 Automatic Build System 0.4.7-1mamba
+- automatic update to 0.4.7 by autodist
+
+* Thu Aug 06 2009 Automatic Build System 0.4.6-1mamba
+- automatic update to 0.4.6 by autodist
+
+* Sun Jul 26 2009 Automatic Build System 0.4.5-2mamba
+- automatic rebuild by autodist
+
+* Sat May 09 2009 Automatic Build System 0.4.5-1mamba
+- automatic update to 0.4.5 by autodist
+
+* Fri Apr 03 2009 Silvan Calarco 0.4.4-1mamba
+- automatic update to 0.4.4 by autodist
+
+* Fri Feb 13 2009 Silvan Calarco 0.4.3-1mamba
+- automatic update to 0.4.3 by autodist
+
+* Sun Feb 08 2009 Silvan Calarco 0.4.2-1mamba
+- automatic update to 0.4.2 by autodist
+
+* Tue Dec 02 2008 Silvan Calarco 0.4.1-1mamba
+- automatic update to 0.4.1 by autodist
+
+* Sat Sep 13 2008 gil 0.3.9-1mamba
+- update to 0.3.9
+- added disable-scrollkeeper configure option
+
+* Tue Jul 22 2008 gil 0.3.8-1mamba
+- update to 0.3.8
+- new builrequires: libcairomm
+
+* Wed Apr 30 2008 Silvan Calarco 0.3.7-1mamba
+- update to 0.3.7
+
+* Fri Mar 28 2008 Silvan Calarco 0.3.6-1mamba
+- update to 0.3.6
+
+* Tue Feb 05 2008 Silvan Calarco 0.3.5-1mamba
+- update to 0.3.5
+
+* Fri May 04 2007 Stefano Cotta Ramusino 0.3.3-1mamba
+- update to 0.3.3
+
+* Wed Feb 22 2006 Stefano Cotta Ramusino 0.2.1-1qilnx
+- package created by autospec