removed requirement for libreiserfs-devel [release 1.6.0-2mamba;Sat Nov 02 2024]
This commit is contained in:
parent
9cfde4726b
commit
4f3f10c661
@ -1,8 +0,0 @@
|
|||||||
--- gparted-0.21.0/gparted.desktop.in.in.orig 2015-01-28 17:34:26.894968149 +0100
|
|
||||||
+++ gparted-0.21.0/gparted.desktop.in.in 2015-01-28 21:41:38.925369165 +0100
|
|
||||||
@@ -9,4 +9,4 @@
|
|
||||||
Type=Application
|
|
||||||
Categories=GNOME;System;Filesystem;
|
|
||||||
_Keywords=Partition;
|
|
||||||
-StartupNotify=true
|
|
||||||
+StartupNotify=false
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -ru gparted-0.29.0.orig/gparted.desktop gparted-0.29.0/gparted.desktop
|
|
||||||
--- gparted-0.29.0.orig/gparted.desktop 2017-08-07 17:57:19.000000000 +0200
|
|
||||||
+++ gparted-0.29.0/gparted.desktop 2017-10-05 16:32:34.572568167 +0200
|
|
||||||
@@ -229,7 +229,7 @@
|
|
||||||
Comment[zh_CN]=创建、重新组织或删除分区
|
|
||||||
Comment[zh_HK]=建立、編輯或刪除分割區
|
|
||||||
Comment[zh_TW]=建立、編輯或刪除分割區
|
|
||||||
-Exec=gksudo /usr/local/sbin/gparted %f
|
|
||||||
+Exec=/usr/bin/gparted-pkexec %f
|
|
||||||
Icon=gparted
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
diff -ru gparted-0.29.0.orig/gparted.desktop.in.in gparted-0.29.0/gparted.desktop.in.in
|
|
||||||
--- gparted-0.29.0.orig/gparted.desktop.in.in 2015-10-14 19:42:48.000000000 +0200
|
|
||||||
+++ gparted-0.29.0/gparted.desktop.in.in 2017-10-05 16:31:44.879380000 +0200
|
|
||||||
@@ -3,7 +3,7 @@
|
|
||||||
_GenericName=Partition Editor
|
|
||||||
_X-GNOME-FullName=GParted Partition Editor
|
|
||||||
_Comment=Create, reorganize, and delete partitions
|
|
||||||
-Exec=@gksuprog@ @installdir@/gparted %f
|
|
||||||
+Exec=/usr/bin/gparted-pkexec %f
|
|
||||||
Icon=gparted
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
@ -1,33 +0,0 @@
|
|||||||
--- src/GParted_Core.cc 2006-12-05 14:39:31.000000000 -0500
|
|
||||||
+++ src/GParted_Core.cc.new 2007-04-02 21:59:01.000000000 -0400
|
|
||||||
@@ -54,21 +54,6 @@
|
|
||||||
|
|
||||||
ped_exception_set_handler( ped_exception_handler ) ;
|
|
||||||
|
|
||||||
- //disable automount //FIXME: temporary hack, till i find a better solution...
|
|
||||||
- std::ofstream fdi_file( "/usr/share/hal/fdi/policy/gparted-disable-automount.fdi" ) ;
|
|
||||||
- if ( fdi_file )
|
|
||||||
- {
|
|
||||||
- fdi_file << "<deviceinfo version='0.2'>" ;
|
|
||||||
- fdi_file << "<device>" ;
|
|
||||||
- fdi_file << "<match key='@block.storage_device:storage.hotpluggable' bool='true'>" ;
|
|
||||||
- fdi_file << "<merge key='volume.ignore' type='bool'>true</merge>" ;
|
|
||||||
- fdi_file << "</match>" ;
|
|
||||||
- fdi_file << "</device>" ;
|
|
||||||
- fdi_file << "</deviceinfo>" ;
|
|
||||||
-
|
|
||||||
- fdi_file .close() ;
|
|
||||||
- }
|
|
||||||
-
|
|
||||||
//get valid flags ...
|
|
||||||
for ( PedPartitionFlag flag = ped_partition_flag_next( static_cast<PedPartitionFlag>( NULL ) ) ;
|
|
||||||
flag ;
|
|
||||||
@@ -2287,8 +2272,6 @@
|
|
||||||
if ( p_filesystem )
|
|
||||||
delete p_filesystem ;
|
|
||||||
|
|
||||||
- //remove .fdi file..
|
|
||||||
- remove( "/usr/share/hal/fdi/policy/gparted-disable-automount.fdi" ) ;
|
|
||||||
}
|
|
||||||
|
|
||||||
} //GParted
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -Nru gparted-0.5.0/gparted.desktop.in.in gparted-0.5.0.patched/gparted.desktop.in.in
|
|
||||||
--- gparted-0.5.0/gparted.desktop.in.in 2009-11-02 21:43:38.000000000 +0100
|
|
||||||
+++ gparted-0.5.0.patched/gparted.desktop.in.in 2009-12-24 12:24:11.920980029 +0100
|
|
||||||
@@ -9,3 +9,7 @@
|
|
||||||
Type=Application
|
|
||||||
Categories=GNOME;System;Filesystem;
|
|
||||||
StartupNotify=true
|
|
||||||
+X-KDE-RootOnly=true
|
|
||||||
+X-KDE-SubstituteUID=true
|
|
||||||
+X-KDE-Username=root
|
|
||||||
+
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -Nru gparted-0.5.0.orig/src/Win_GParted.cc gparted-0.5.0/src/Win_GParted.cc
|
|
||||||
--- gparted-0.5.0.orig/src/Win_GParted.cc 2009-11-25 20:39:15.000000000 +0100
|
|
||||||
+++ gparted-0.5.0/src/Win_GParted.cc 2009-12-21 23:03:24.000000000 +0100
|
|
||||||
@@ -38,6 +38,7 @@
|
|
||||||
#include <gtkmm/messagedialog.h>
|
|
||||||
#include <gtkmm/radiobuttongroup.h>
|
|
||||||
#include <gtkmm/main.h>
|
|
||||||
+#include <gtk/gtk.h>
|
|
||||||
|
|
||||||
namespace GParted
|
|
||||||
{
|
|
19
gparted.spec
19
gparted.spec
@ -1,7 +1,7 @@
|
|||||||
### AUTOUPDATE-OFF: 2
|
### AUTOUPDATE-OFF: 2
|
||||||
Name: gparted
|
Name: gparted
|
||||||
Version: 1.6.0
|
Version: 1.6.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: The Gnome Partition Editor application
|
Summary: The Gnome Partition Editor application
|
||||||
Group: Graphical Desktop/Applications/Administration
|
Group: Graphical Desktop/Applications/Administration
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -11,11 +11,6 @@ URL: https://gparted.org/
|
|||||||
Source: http://downloads.sourceforge.net/project/gparted/gparted/gparted-%{version}/gparted-%{version}.tar.gz
|
Source: http://downloads.sourceforge.net/project/gparted/gparted/gparted-%{version}/gparted-%{version}.tar.gz
|
||||||
Source1: gparted-polkit
|
Source1: gparted-polkit
|
||||||
Source2: gparted-pkexec
|
Source2: gparted-pkexec
|
||||||
Patch1: %{name}-0.5.0-filedesktop.patch
|
|
||||||
Patch2: %{name}-0.3.3-hal.patch
|
|
||||||
Patch3: %{name}-0.5.0-gtk_include.patch
|
|
||||||
Patch4: %{name}-0.21.0-filedesktop_no_startupnotify.patch
|
|
||||||
Patch5: %{name}-0.29.0-desktop-use_gparted_pkexec.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -36,9 +31,8 @@ BuildRequires: libparted-devel
|
|||||||
BuildRequires: libsigc++2-devel
|
BuildRequires: libsigc++2-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libuuid-devel
|
BuildRequires: libuuid-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libgtkmm2-devel >= 2.24.4-2mamba
|
|
||||||
BuildRequires: libreiserfs-devel >= 0.3.0.4
|
|
||||||
BuildRequires: jfsutils >= 1.1.5
|
BuildRequires: jfsutils >= 1.1.5
|
||||||
BuildRequires: gnome-doc-utils
|
BuildRequires: gnome-doc-utils
|
||||||
Requires: ntfsprogs >= 1.9.0
|
Requires: ntfsprogs >= 1.9.0
|
||||||
@ -70,12 +64,6 @@ These partitions are normally not re-sizable (making one larger and the adjacent
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch1 -p1
|
|
||||||
#%patch2
|
|
||||||
#%patch3 -p1
|
|
||||||
#%patch4 -p1
|
|
||||||
#%patch5 -p1
|
|
||||||
#sed -i "s|Exec=.*|Exec=%{_bindir}/gparted-pkexec|" gparted.desktop gparted.desktop.in.in
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-scrollkeeper GKSUPROG=""
|
%configure --disable-scrollkeeper GKSUPROG=""
|
||||||
@ -106,6 +94,9 @@ These partitions are normally not re-sizable (making one larger and the adjacent
|
|||||||
#ChangeLog README
|
#ChangeLog README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.6.0-2mamba
|
||||||
|
- removed requirement for libreiserfs-devel
|
||||||
|
|
||||||
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 1.6.0-1mamba
|
* Wed Feb 28 2024 Automatic Build System <autodist@openmamba.org> 1.6.0-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user