added patch and build requirement for libpcre 8.30 [release 0.8.17-2mamba;Sat Aug 04 2012]
This commit is contained in:
parent
3d927a3598
commit
6d68ec4264
@ -1,2 +1,4 @@
|
|||||||
# goffice
|
# goffice
|
||||||
|
|
||||||
|
A library of document centric objects and utilities building on top of GLib and Gtk+.
|
||||||
|
|
||||||
|
13
goffice-0.8.17-pcre-8.30.patch
Normal file
13
goffice-0.8.17-pcre-8.30.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Index: goffice-0.8.17/goffice/utils/regutf8.c
|
||||||
|
===================================================================
|
||||||
|
--- goffice-0.8.17.orig/goffice/utils/regutf8.c
|
||||||
|
+++ goffice-0.8.17/goffice/utils/regutf8.c
|
||||||
|
@@ -155,7 +155,7 @@ go_regcomp (GORegexp *gor, const char *p
|
||||||
|
default: return GO_REG_BADPAT;
|
||||||
|
}
|
||||||
|
} else {
|
||||||
|
- gor->re_nsub = pcre_info (r, NULL, NULL);
|
||||||
|
+ gor->re_nsub = pcre_fullinfo (r, NULL, 0, NULL);
|
||||||
|
gor->nosub = (cflags & GO_REG_NOSUB) != 0;
|
||||||
|
return 0;
|
||||||
|
}
|
150
goffice.spec
Normal file
150
goffice.spec
Normal file
@ -0,0 +1,150 @@
|
|||||||
|
%define majver %(echo %version | cut -d. -f 1-2)
|
||||||
|
Name: goffice
|
||||||
|
Version: 0.8.17
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A library of document centric objects and utilities building on top of GLib and Gtk+
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.gnome.org
|
||||||
|
Source: ftp://ftp.gnome.org/pub/GNOME/sources/goffice/%{majver}/goffice-%{version}.tar.xz
|
||||||
|
Patch0: %{name}-0.8.17-pcre-8.30.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: GConf-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libdbus-glib-devel
|
||||||
|
BuildRequires: libelf-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libffi-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgsf-devel
|
||||||
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpcre-devel
|
||||||
|
BuildRequires: libpixman-devel
|
||||||
|
BuildRequires: libpng14-devel
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: libselinux-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXau-devel
|
||||||
|
BuildRequires: libxcb-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: ORBit2-devel
|
||||||
|
BuildRequires: pkg-config
|
||||||
|
BuildRequires: udev-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libpcre-devel >= 8.30
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
A library of document centric objects and utilities building on top of GLib and Gtk+.
|
||||||
|
|
||||||
|
%package -n libgoffice
|
||||||
|
Summary: A library of document centric objects and utilities building on top of GLib and Gtk+
|
||||||
|
Group: System/Libraries
|
||||||
|
|
||||||
|
%description -n libgoffice
|
||||||
|
A library of document centric objects and utilities building on top of GLib and Gtk+.
|
||||||
|
|
||||||
|
%package -n libgoffice-devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: libgoffice = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n libgoffice-devel
|
||||||
|
A library of document centric objects and utilities building on top of GLib and Gtk+.
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%find_lang %{name}-%{version}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -n libgoffice -f %{name}-%{version}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libgoffice-%{majver}.so.*
|
||||||
|
%dir %{_libdir}/goffice
|
||||||
|
%dir %{_libdir}/goffice/%{version}
|
||||||
|
%dir %{_libdir}/goffice/%{version}/plugins
|
||||||
|
%{_libdir}/goffice/%{version}/plugins/*
|
||||||
|
%dir %{_datadir}/goffice
|
||||||
|
%dir %{_datadir}/goffice/%{version}
|
||||||
|
%dir %{_datadir}/goffice/%{version}/ui
|
||||||
|
%{_datadir}/goffice/%{version}/ui/*
|
||||||
|
%dir %{_datadir}/goffice/%{version}/patterns
|
||||||
|
%{_datadir}/goffice/%{version}/patterns/svg-patterns.xml
|
||||||
|
%dir %{_datadir}/pixmaps/goffice
|
||||||
|
%dir %{_datadir}/pixmaps/goffice/%{version}
|
||||||
|
%{_datadir}/pixmaps/goffice/%{version}/*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files -n libgoffice-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/libgoffice-%{majver}
|
||||||
|
%dir %{_includedir}/libgoffice-%{majver}/goffice
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/goffice-features.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/goffice.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/app/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/canvas/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/component/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/data/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/drawing/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/graph/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/gtk/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/math/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/ms-compat/*.h
|
||||||
|
%{_includedir}/libgoffice-%{majver}/goffice/utils/*.h
|
||||||
|
#%{_includedir}/libgoffice-%{majver}/goffice/cut-n-paste/foocanvas/*.h
|
||||||
|
%{_libdir}/libgoffice-%{majver}.so
|
||||||
|
%{_libdir}/libgoffice-%{majver}.la
|
||||||
|
%{_libdir}/pkgconfig/*.pc
|
||||||
|
%{_datadir}/gtk-doc/html/goffice-%{majver}/*
|
||||||
|
%doc BUGS ChangeLog NEWS README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Aug 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.17-2mamba
|
||||||
|
- added patch and build requirement for libpcre 8.30
|
||||||
|
|
||||||
|
* Mon Jul 09 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.17-1mamba
|
||||||
|
- update to 0.8.17
|
||||||
|
|
||||||
|
* Thu Jul 15 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.6-3mamba
|
||||||
|
- rebuilt with libpng 1.4
|
||||||
|
|
||||||
|
* Sat May 23 2009 Automatic Build System <autodist@mambasoft.it> 0.6.6-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Wed Feb 04 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.6-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Oct 24 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.5-1mamba
|
||||||
|
- update to 0.6.5
|
||||||
|
|
||||||
|
* Sun Sep 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.3-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user