automatic version update by autodist [release 1.24.0-1mamba;Wed Feb 12 2025]

This commit is contained in:
Automatic Build System 2025-02-13 13:48:36 +01:00
parent 277b516f55
commit f4f201e8ec
2 changed files with 37 additions and 17 deletions

View File

@ -0,0 +1,29 @@
--- go-1.24.0/src/cmd/link/internal/ld/lib.go.orig 2025-02-13 11:37:56.817806763 +0100
+++ go-1.24.0/src/cmd/link/internal/ld/lib.go 2025-02-13 11:38:24.850919342 +0100
@@ -1671,26 +1671,6 @@
altLinker = "lld"
}
- if ctxt.Arch.InFamily(sys.ARM64) && buildcfg.GOOS == "linux" {
- // On ARM64, the GNU linker will fail with
- // -znocopyreloc if it thinks a COPY relocation is
- // required. Switch to gold.
- // https://sourceware.org/bugzilla/show_bug.cgi?id=19962
- // https://go.dev/issue/22040
- altLinker = "gold"
-
- // If gold is not installed, gcc will silently switch
- // back to ld.bfd. So we parse the version information
- // and provide a useful error if gold is missing.
- name, args := flagExtld[0], flagExtld[1:]
- args = append(args, "-fuse-ld=gold", "-Wl,--version")
- cmd := exec.Command(name, args...)
- if out, err := cmd.CombinedOutput(); err == nil {
- if !bytes.Contains(out, []byte("GNU gold")) {
- log.Fatalf("ARM64 external linker must be gold (issue #15696, 22040), but is not: %s", out)
- }
- }
- }
}
if ctxt.Arch.Family == sys.ARM64 && buildcfg.GOOS == "freebsd" {
// Switch to ld.bfd on freebsd/arm64.

25
go.spec
View File

@ -1,5 +1,5 @@
Name: go
Version: 1.23.6
Version: 1.24.0
Release: 1mamba
Summary: The Go programming language
Group: Applications/Development
@ -9,6 +9,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://go.dev/
Source: https://github.com/golang/go.git/go%{version}/go-%{version}.tar.bz2
Patch0: go-1.10.1-default-buildmode-pie.patch
Patch1: go-1.24.0-arm64-stop_forcing_binutils_gold.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -27,27 +28,14 @@ The Go programming language.
#% debug_package
%global __strip /bin/true
%global __requires_exclude_from ^%{_libdir}/go/src/.*$
%prep
%setup -q
#-D -T
#:<< _EOF
%define _use_internal_dependency_generator 0
%define __find_provides %{_builddir}/go-%{version}/find_provides.sh
cat > %{_builddir}/go-%{version}/find_provides.sh <<_EOF
#! /bin/sh
%{_prefix}/lib/rpm/find-provides %{buildroot} %{_target_cpu}
_EOF
chmod +x %{_builddir}/go-%{version}/find_provides.sh
%define __find_requires %{_builddir}/go-%{version}/find_requires.sh
cat > %{_builddir}/go-%{version}/find_requires.sh <<_EOF
#! /bin/sh
grep -v %{buildroot}%{_libdir}/go/src/ | \
%{_prefix}/lib/rpm/find-requires %{buildroot} %{_target_cpu} 2>/dev/null
_EOF
chmod +x %{_builddir}/go-%{version}/find_requires.sh
%patch 1 -p1
%build
#:<< _EOF
@ -125,6 +113,9 @@ fi
#%doc README.md
%changelog
* Wed Feb 12 2025 Automatic Build System <autodist@openmamba.org> 1.24.0-1mamba
- automatic version update by autodist
* Wed Feb 05 2025 Automatic Build System <autodist@openmamba.org> 1.23.6-1mamba
- automatic version update by autodist