package created using the webbuild interface [release 1.27.0-1mamba;Sat Jan 02 2021]

This commit is contained in:
Silvan Calarco 2024-01-05 23:18:13 +01:00
parent a11b964a83
commit 93959946b0
3 changed files with 318 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# gnustep-base
The GNUstep Base Library is a powerful fast library of general-purpose, non-graphical Objective C classes, inspired by the superb OpenStep API but implementing Apple and GNU additions to the API as well. It includes for example classes for unicode strings, arrays, dictionaries, sets, bytestreams, typed coders, invocations, notifications, notification dispatchers, scanners, tasks, files, networking, threading, remote object messaging support (distributed objects), event loops, loadable bundles, attributed unicode strings, xml, mime, user defaults. This package includes development headers too.

View File

@ -0,0 +1,185 @@
Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
GSICUString.m:71:18: error: use of undeclared identifier 'TRUE'
return TRUE;
^
GSICUString.m:80:18: error: use of undeclared identifier 'FALSE'
return FALSE;
^
GSICUString.m:104:18: error: use of undeclared identifier 'TRUE'
return TRUE;
^
GSICUString.m:113:18: error: use of undeclared identifier 'FALSE'
return FALSE;
^
GSICUString.m:135:10: error: use of undeclared identifier 'TRUE'
return TRUE;
^
GSICUString.m:170:66: error: use of undeclared identifier 'TRUE'
UTextNSStringAccess(ut, r.location + [replacement length] + 1, TRUE);
^
NSRegularExpression.m:185:29: error: use of undeclared identifier 'FALSE'
utext_clone(&str->txt, t, FALSE, TRUE, &s);
^
NSRegularExpression.m:185:36: error: use of undeclared identifier 'TRUE'
utext_clone(&str->txt, t, FALSE, TRUE, &s);
^
NSRegularExpression.m:842:34: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:842:40: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:876:34: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:876:40: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:914:34: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:914:40: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:291:14: error: use of undeclared identifier 'FALSE'
return FALSE;
^
NSRegularExpression.m:368:36: error: use of undeclared identifier 'FALSE'
uregex_useAnchoringBounds(r, FALSE, &s);
^
NSRegularExpression.m:372:38: error: use of undeclared identifier 'TRUE'
uregex_useTransparentBounds(r, TRUE, &s);
^
--- Source/GSICUString.m.orig 2019-01-06 22:33:45 UTC
+++ Source/GSICUString.m
@@ -68,7 +68,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* to match it.
*/
ut->chunkOffset = nativeIndex - nativeStart;
- return TRUE;
+ return true;
}
if (nativeIndex >= length && nativeLimit >= length)
@@ -77,7 +77,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* Limit it to point just after the last character.
*/
ut->chunkOffset = ut->chunkLength;
- return FALSE;
+ return false;
}
/* Set up to fill the chunk with characters from the string
@@ -101,7 +101,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* to match it.
*/
ut->chunkOffset = nativeIndex - nativeStart;
- return TRUE;
+ return true;
}
if (nativeIndex <= 0 && nativeStart <= 0)
@@ -110,7 +110,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* Limit it to position of the first character.
*/
ut->chunkOffset = 0;
- return FALSE;
+ return false;
}
nativeLimit = nativeIndex;
@@ -132,7 +132,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
ut->chunkNativeStart = nativeStart;
ut->nativeIndexingLimit = r.length;
ut->chunkLength = r.length;
- return TRUE;
+ return true;
}
/**
@@ -167,7 +167,7 @@ UTextNSMutableStringReplace(UText *ut,
// Setting the chunk length to 0 here forces UTextNSStringAccess to fetch
// the data from the string object.
ut->chunkLength = 0;
- UTextNSStringAccess(ut, r.location + [replacement length] + 1, TRUE);
+ UTextNSStringAccess(ut, r.location + [replacement length] + 1, true);
ut->chunkOffset++;
[replacement release];
--- Source/NSRegularExpression.m.orig 2019-01-06 22:33:45 UTC
+++ Source/NSRegularExpression.m
@@ -182,7 +182,7 @@ NSRegularExpressionOptionsToURegexpFlags(NSRegularExpr
return nil;
}
str = [GSUTextString new];
- utext_clone(&str->txt, t, FALSE, TRUE, &s);
+ utext_clone(&str->txt, t, false, true, &s);
return [str autorelease];
}
#else
@@ -288,7 +288,7 @@ callback(const void *context, int32_t steps)
if (NULL == context)
{
- return FALSE;
+ return false;
}
CALL_BLOCK(block, nil, NSMatchingProgress, &stop);
return stop;
@@ -365,11 +365,11 @@ setupRegex(URegularExpression *regex,
uregex_setRegion(r, range.location, range.location+range.length, &s);
if (options & NSMatchingWithoutAnchoringBounds)
{
- uregex_useAnchoringBounds(r, FALSE, &s);
+ uregex_useAnchoringBounds(r, false, &s);
}
if (options & NSMatchingWithTransparentBounds)
{
- uregex_useTransparentBounds(r, TRUE, &s);
+ uregex_useTransparentBounds(r, true, &s);
}
uregex_setTimeLimit(r, _workLimit, &s);
if (U_FAILURE(s))
@@ -401,11 +401,11 @@ setupRegex(URegularExpression *regex,
uregex_setRegion(r, range.location, range.location+range.length, &s);
if (options & NSMatchingWithoutAnchoringBounds)
{
- uregex_useAnchoringBounds(r, FALSE, &s);
+ uregex_useAnchoringBounds(r, false, &s);
}
if (options & NSMatchingWithTransparentBounds)
{
- uregex_useTransparentBounds(r, TRUE, &s);
+ uregex_useTransparentBounds(r, true, &s);
}
uregex_setTimeLimit(r, _workLimit, &s);
if (U_FAILURE(s))
@@ -839,7 +839,7 @@ prepareResult(NSRegularExpression *regex,
DESTROY(ret);
return 0;
}
- utext_clone(&ret->txt, output, TRUE, TRUE, &s);
+ utext_clone(&ret->txt, output, true, true, &s);
[string setString: ret];
[ret release];
uregex_close(r);
@@ -873,7 +873,7 @@ prepareResult(NSRegularExpression *regex,
DESTROY(ret);
return nil;
}
- utext_clone(&ret->txt, output, TRUE, TRUE, &s);
+ utext_clone(&ret->txt, output, true, true, &s);
uregex_close(r);
utext_close(&txt);
@@ -911,7 +911,7 @@ prepareResult(NSRegularExpression *regex,
DESTROY(ret);
return nil;
}
- utext_clone(&ret->txt, output, TRUE, TRUE, &s);
+ utext_clone(&ret->txt, output, true, true, &s);
uregex_close(r);
utext_close(&txt);

131
gnustep-base.spec Normal file
View File

@ -0,0 +1,131 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: gnustep-base
Version: 1.27.0
Release: 1mamba
Summary: GNUstep Base library package
Group: Development/Tools
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://gnustep.org/
Source: ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-base-%{version}.tar.gz
Patch0: gnustep-base-1.27.0-icu-68.patch
License: GPL, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: ldconfig
BuildRequires: libavahi-devel
BuildRequires: libffi-devel
BuildRequires: libgcc
BuildRequires: libgnutls-devel
BuildRequires: libicu-devel
BuildRequires: libobjc-devel
BuildRequires: libxml2-devel
BuildRequires: libxslt-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: gnustep-make
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
The GNUstep Base Library is a powerful fast library of general-purpose, non-graphical Objective C classes, inspired by the superb OpenStep API but implementing Apple and GNU additions to the API as well. It includes for example classes for unicode strings, arrays, dictionaries, sets, bytestreams, typed coders, invocations, notifications, notification dispatchers, scanners, tasks, files, networking, threading, remote object messaging support (distributed objects), event loops, loadable bundles, attributed unicode strings, xml, mime, user defaults. This package includes development headers too.
%package -n lib%{name}
Group: System/Libraries
Summary: Shared libraries for %{name}
%description -n lib%{name}
This package contains shared libraries for %{name}.
%package -n lib%{name}-devel
Group: Development/Libraries
Summary: Development files for %{name}
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
%description -n lib%{name}-devel
This package contains libraries and header files for developing applications that use %{name}.
%debug_package
%prep
%setup -q
%patch0 -p0
%build
ffi_include=$(pkg-config --cflags-only-I libffi | sed -e 's/^\-\I//')
export LDFLAGS="%{optflags} -Wl,--as-needed"
%gnustep_configure \
--disable-ffcall --with-ffi-include=$ffi_include
%gnustep_make -n
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%gnustep_install -n
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/HTMLLinker
%{_bindir}/autogsdoc
%{_bindir}/cvtenc
%{_bindir}/defaults
%{_bindir}/gdnc
%{_bindir}/gdomap
%{_bindir}/gspath
%{_bindir}/make_strings
%{_bindir}/pl
%{_bindir}/pl2link
%{_bindir}/pldes
%{_bindir}/plget
%{_bindir}/plmerge
%{_bindir}/plparse
%{_bindir}/plser
%{_bindir}/sfparse
%{_bindir}/xmlparse
%{_mandir}/man1/HTMLLinker.1*
%{_mandir}/man1/autogsdoc.1*
%{_mandir}/man1/cvtenc.1*
%{_mandir}/man1/defaults.1*
%{_mandir}/man1/gdnc.1*
%{_mandir}/man1/gspath.1*
%{_mandir}/man1/make_strings.1*
%{_mandir}/man1/pldes.1*
%{_mandir}/man1/sfparse.1*
%{_mandir}/man1/xmlparse.1*
%{_mandir}/man8/gdomap.8*
%files -n lib%{name}
%defattr(-,root,root)
%{_libdir}/libgnustep-base.so.*
%dir %{_libdir}/GNUstep
%dir %{_libdir}/GNUstep/Libraries
%dir %{_libdir}/GNUstep/Libraries/gnustep-base
%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions
%dir %{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{majver}
%{_libdir}/GNUstep/Libraries/gnustep-base/Versions/%{majver}/*
%dir %{_libdir}/GNUstep/DTDs
%{_libdir}/GNUstep/DTDs/*
%doc COPYING COPYING.LIB
%files -n lib%{name}-devel
%defattr(-,root,root)
%{_libdir}/libgnustep-base.so
%dir %{_includedir}/Foundation
%{_includedir}/Foundation/*
%dir %{_includedir}/GNUstepBase
%{_includedir}/GNUstepBase/*
%dir %{_libdir}/GNUstep/Makefiles/Additional
%{_libdir}/GNUstep/Makefiles/Additional/base.make
%doc ChangeLog ChangeLog.1 ChangeLog.2 NEWS README README.initialize
%changelog
* Sat Jan 02 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.27.0-1mamba
- package created using the webbuild interface