automatic version update by autodist [release 1.30.0-1mamba;Tue Jun 25 2024]

This commit is contained in:
Automatic Build System 2025-01-05 18:26:05 +01:00
parent ea38b49c1b
commit 8576a4fbf8
2 changed files with 5 additions and 188 deletions

View File

@ -1,185 +0,0 @@
Regressed by https://github.com/unicode-org/icu/commit/c3fe7e09d844
GSICUString.m:71:18: error: use of undeclared identifier 'TRUE'
return TRUE;
^
GSICUString.m:80:18: error: use of undeclared identifier 'FALSE'
return FALSE;
^
GSICUString.m:104:18: error: use of undeclared identifier 'TRUE'
return TRUE;
^
GSICUString.m:113:18: error: use of undeclared identifier 'FALSE'
return FALSE;
^
GSICUString.m:135:10: error: use of undeclared identifier 'TRUE'
return TRUE;
^
GSICUString.m:170:66: error: use of undeclared identifier 'TRUE'
UTextNSStringAccess(ut, r.location + [replacement length] + 1, TRUE);
^
NSRegularExpression.m:185:29: error: use of undeclared identifier 'FALSE'
utext_clone(&str->txt, t, FALSE, TRUE, &s);
^
NSRegularExpression.m:185:36: error: use of undeclared identifier 'TRUE'
utext_clone(&str->txt, t, FALSE, TRUE, &s);
^
NSRegularExpression.m:842:34: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:842:40: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:876:34: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:876:40: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:914:34: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:914:40: error: use of undeclared identifier 'TRUE'
utext_clone(&ret->txt, output, TRUE, TRUE, &s);
^
NSRegularExpression.m:291:14: error: use of undeclared identifier 'FALSE'
return FALSE;
^
NSRegularExpression.m:368:36: error: use of undeclared identifier 'FALSE'
uregex_useAnchoringBounds(r, FALSE, &s);
^
NSRegularExpression.m:372:38: error: use of undeclared identifier 'TRUE'
uregex_useTransparentBounds(r, TRUE, &s);
^
--- Source/GSICUString.m.orig 2019-01-06 22:33:45 UTC
+++ Source/GSICUString.m
@@ -68,7 +68,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* to match it.
*/
ut->chunkOffset = nativeIndex - nativeStart;
- return TRUE;
+ return true;
}
if (nativeIndex >= length && nativeLimit >= length)
@@ -77,7 +77,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* Limit it to point just after the last character.
*/
ut->chunkOffset = ut->chunkLength;
- return FALSE;
+ return false;
}
/* Set up to fill the chunk with characters from the string
@@ -101,7 +101,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* to match it.
*/
ut->chunkOffset = nativeIndex - nativeStart;
- return TRUE;
+ return true;
}
if (nativeIndex <= 0 && nativeStart <= 0)
@@ -110,7 +110,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
* Limit it to position of the first character.
*/
ut->chunkOffset = 0;
- return FALSE;
+ return false;
}
nativeLimit = nativeIndex;
@@ -132,7 +132,7 @@ UTextNSStringAccess(UText *ut, int64_t nativeIndex, UB
ut->chunkNativeStart = nativeStart;
ut->nativeIndexingLimit = r.length;
ut->chunkLength = r.length;
- return TRUE;
+ return true;
}
/**
@@ -167,7 +167,7 @@ UTextNSMutableStringReplace(UText *ut,
// Setting the chunk length to 0 here forces UTextNSStringAccess to fetch
// the data from the string object.
ut->chunkLength = 0;
- UTextNSStringAccess(ut, r.location + [replacement length] + 1, TRUE);
+ UTextNSStringAccess(ut, r.location + [replacement length] + 1, true);
ut->chunkOffset++;
[replacement release];
--- Source/NSRegularExpression.m.orig 2019-01-06 22:33:45 UTC
+++ Source/NSRegularExpression.m
@@ -182,7 +182,7 @@ NSRegularExpressionOptionsToURegexpFlags(NSRegularExpr
return nil;
}
str = [GSUTextString new];
- utext_clone(&str->txt, t, FALSE, TRUE, &s);
+ utext_clone(&str->txt, t, false, true, &s);
return [str autorelease];
}
#else
@@ -288,7 +288,7 @@ callback(const void *context, int32_t steps)
if (NULL == context)
{
- return FALSE;
+ return false;
}
CALL_BLOCK(block, nil, NSMatchingProgress, &stop);
return stop;
@@ -365,11 +365,11 @@ setupRegex(URegularExpression *regex,
uregex_setRegion(r, range.location, range.location+range.length, &s);
if (options & NSMatchingWithoutAnchoringBounds)
{
- uregex_useAnchoringBounds(r, FALSE, &s);
+ uregex_useAnchoringBounds(r, false, &s);
}
if (options & NSMatchingWithTransparentBounds)
{
- uregex_useTransparentBounds(r, TRUE, &s);
+ uregex_useTransparentBounds(r, true, &s);
}
uregex_setTimeLimit(r, _workLimit, &s);
if (U_FAILURE(s))
@@ -401,11 +401,11 @@ setupRegex(URegularExpression *regex,
uregex_setRegion(r, range.location, range.location+range.length, &s);
if (options & NSMatchingWithoutAnchoringBounds)
{
- uregex_useAnchoringBounds(r, FALSE, &s);
+ uregex_useAnchoringBounds(r, false, &s);
}
if (options & NSMatchingWithTransparentBounds)
{
- uregex_useTransparentBounds(r, TRUE, &s);
+ uregex_useTransparentBounds(r, true, &s);
}
uregex_setTimeLimit(r, _workLimit, &s);
if (U_FAILURE(s))
@@ -839,7 +839,7 @@ prepareResult(NSRegularExpression *regex,
DESTROY(ret);
return 0;
}
- utext_clone(&ret->txt, output, TRUE, TRUE, &s);
+ utext_clone(&ret->txt, output, true, true, &s);
[string setString: ret];
[ret release];
uregex_close(r);
@@ -873,7 +873,7 @@ prepareResult(NSRegularExpression *regex,
DESTROY(ret);
return nil;
}
- utext_clone(&ret->txt, output, TRUE, TRUE, &s);
+ utext_clone(&ret->txt, output, true, true, &s);
uregex_close(r);
utext_close(&txt);
@@ -911,7 +911,7 @@ prepareResult(NSRegularExpression *regex,
DESTROY(ret);
return nil;
}
- utext_clone(&ret->txt, output, TRUE, TRUE, &s);
+ utext_clone(&ret->txt, output, true, true, &s);
uregex_close(r);
utext_close(&txt);

View File

@ -1,7 +1,7 @@
%define majver %(echo %version | cut -d. -f1-2)
%define gitver %(echo %version | tr . _)
Name: gnustep-base
Version: 1.29.0
Version: 1.30.0
Release: 1mamba
Summary: GNUstep Base library package
Group: Development/Tools
@ -10,7 +10,6 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://gnustep.github.io/
Source: https://github.com/gnustep/libs-base.git/base-%{gitver}/libs-base-%{version}.tar.bz2
Patch0: gnustep-base-1.27.0-icu-68.patch
License: GPL, LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -50,7 +49,6 @@ This package contains libraries and header files for developing applications tha
%prep
%setup -q -n libs-base-%{version}
%patch0 -p0
%build
ffi_include=$(pkg-config --cflags-only-I libffi | sed -e 's/^\-\I//')
@ -98,9 +96,13 @@ export LDFLAGS="%{optflags} -Wl,--as-needed"
%{_includedir}/GNUstepBase/*
%dir %{_libdir}/GNUstep/Makefiles/Additional
%{_libdir}/GNUstep/Makefiles/Additional/base.make
%{_libdir}/pkgconfig/gnustep-base.pc
%doc ChangeLog ChangeLog.1 ChangeLog.2 NEWS README.initialize
%changelog
* Tue Jun 25 2024 Automatic Build System <autodist@openmamba.org> 1.30.0-1mamba
- automatic version update by autodist
* Mon Jan 09 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.29.0-1mamba
- update to 1.29.0