update to 3.23.4 [release 3.23.4-1mamba;Sat Aug 20 2022]

This commit is contained in:
Silvan Calarco 2024-01-05 23:18:08 +01:00
parent 1fb2b4c8ab
commit ba48767ac0
5 changed files with 114 additions and 20 deletions

View File

@ -2,4 +2,3 @@
GNU Solfege is a computer program written to help you practice ear training.
It can be useful when practicing the simple and mechanical exercises.

View File

@ -0,0 +1,41 @@
Author: Reiner Herrmann <reiner@reiner-h.de>
Description: Fixes deprecation warnings with recent GTK+ versions
Forwarded: https://savannah.gnu.org/bugs/index.php?53107
--- a/solfege.css
+++ b/solfege.css
@@ -4,25 +4,25 @@
*/
-#ProgressionNameLabel, #Feedback { font: "Sans 18" }
-#ProgressionLabelNumber { font: "Sans 12" }
-#BoldText { font: Bold }
+#ProgressionNameLabel, #Feedback { font: 18px Sans }
+#ProgressionLabelNumber { font: 12px Sans }
+#BoldText { font: 12px Sans Bold }
-#StatisticsH1, #Heading1 { font: Sans 18 }
-#StatisticsH2, #Heading2 { font: Sans 14 }
+#StatisticsH1, #Heading1 { font: 18px Sans }
+#StatisticsH2, #Heading2 { font: 14px Sans }
-#BpmInactiveLabel { font: Sans 12 }
-#BpmActiveLabel { font: Sans Bold 12 }
+#BpmInactiveLabel { font: 12px Sans }
+#BpmActiveLabel { font: 12px Sans Bold }
#DIALOGWARNING2 { background: red; }
#DIALOGWARNING { background: yellow; }
#DEBUGWARNING {
background: red;
- font: Sans Bold 24;
+ font: 24px Sans Bold;
}
-#FlashBarLabel { font: Sans 16 }
+#FlashBarLabel { font: 16px Sans }
#IntervalButtonsWidget GtkButton
{

View File

@ -0,0 +1,20 @@
Author: Francois Mazen <francois@mzf.fr>
Description: Fix the mismatch of intermediate eps filename when generating theory-intervals-seconds.png and theory-intervals-seconds-1.png in parallel. This issue lead to reproducible issue and sometimes wrong generation of png files.
--- a/help/Makefile
+++ b/help/Makefile
@@ -153,7 +153,12 @@
ifeq "$(LILYPOND_VERSION)" "2.10"
$(LILYPOND) -I ../../C/ly --png -b eps -dno-gs-load-fonts -dinclude-eps-fonts -o $(basename $@) $<
else
- $(LILYPOND) -I ../../C/ly --png -d backend=eps -o $(basename $@) $<
+ # Generate the file in a unique temporary folder, in order to avoid mismatch of eps filenames.
+ mkdir $(basename $@)-tempdir
+ $(LILYPOND) -I ../../../C/ly --png -d backend=eps -o $(basename $@)-tempdir/temp_output $<
+ cp $(basename $@)-tempdir/temp_output.png $(basename $@).png
+ rm $(basename $@)-tempdir/*
+ rmdir $(basename $@)-tempdir
endif
stupid-step1:

View File

@ -0,0 +1,16 @@
Author: Reiner Herrmann <reiner@reiner-h.de>
Description: with recent gtk+ versions, the menubar text is not visibile
As a workaround another container (HBox) is used.
Bug: https://savannah.gnu.org/bugs/index.php?53109
--- a/solfege/mainwin.py
+++ b/solfege/mainwin.py
@@ -267,7 +267,7 @@
self.g_ui_manager.add_ui_from_file("ui.xml")
self.add_accel_group(self.g_ui_manager.get_accel_group())
- hdlbox = Gtk.HandleBox()
+ hdlbox = Gtk.HBox()
hdlbox.show()
hdlbox.add(self.g_ui_manager.get_widget('/Menubar'))
self._vbox.pack_start(hdlbox, False, False, 0)

View File

@ -1,49 +1,63 @@
Name: gnusolfege
Version: 3.22.2
Version: 3.23.4
Release: 1mamba
Summary: GNU Solfege is a computer program written to help you practice ear training
Group: Graphical Desktop/Applications/Educational
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.solfege.org/
Source: http://downloads.sourceforge.net/sourceforge/solfege/solfege-%{version}.tar.gz
URL: https://www.solfege.org/
Source: https://git.savannah.gnu.org/git/solfege.git/%{version}/solfege-%{version}.tar.bz2
Patch: %{name}-3.16.2-use_mktemp.patch
Patch1: gnusolfege-3.23.4-fix_css.patch
Patch2: gnusolfege-3.23.4-fix_lilypond_eps_file_mismatch.patch
Patch3: gnusolfege-3.23.4-hidden_menubar.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: alsa-utils
BuildRequires: liblame-devel
BuildRequires: mpg123
BuildRequires: pygtk-devel
BuildRequires: pyorbit-devel
BuildRequires: python-gnome-extras-devel
BuildRequires: timidity
BuildRequires: vorbis-tools
## AUTOBUILDREQ-END
BuildRequires: python
BuildRequires: lilypond
BuildRequires: python3
BuildRequires: libpython-devel
BuildRequires: swig
BuildRequires: gettext-devel
Requires: pygtk
Requires: python-gnome-extras
Requires: pyorbit
Requires: pygobject-py3
Requires: pycairo-py3
Requires: lilypond
Requires: timidity
Requires: liblame
Requires: vorbis-tools
Requires: alsa-utils
Requires: mpg123
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
GNU Solfege is a computer program written to help you practice ear training.
It can be useful when practicing the simple and mechanical exercises.
#% debug_package
%prep
%setup -q -n solfege-%{version}
#-D -T
#:<< _EOF
%patch -p1
%patch1 -p1 -b .fix_css
%patch2 -p1 -b .fix_lilypond_eps_file_mismatch
%patch3 -p1 -b .hidden_menubar
sed -E 's|(PYTHON_INCLUDES=).+|\1"$(pkg-config --cflags-only-I python3)"|g' \
-i acinclude.m4
# fix early access of webbrowser module internal, leading to AttributeError:
# https://bugs.archlinux.org/task/63703
sed -e '28i\ \ \ \ webbrowser.register_standard_browsers()' -i solfege/mainwin.py
./autogen.sh
%build
%configure
#:<< _EOF
%configure \
PYTHON=%{__python3}
%make
%install
@ -68,9 +82,13 @@ sed -i -e 's|%{buildroot}||' %{buildroot}%{_datadir}/solfege/*/*.py
%attr(755,root,root) %{_libdir}/solfege/*.so
%{_sysconfdir}/*
%{_mandir}/man1/*
%doc AUTHORS COPYING ChangeLog README
%doc AUTHORS COPYING
#ChangeLog README
%changelog
* Sat Aug 20 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 3.23.4-1mamba
- update to 3.23.4
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 3.22.2-1mamba
- automatic update by autodist
@ -114,7 +132,7 @@ sed -i -e 's|%{buildroot}||' %{buildroot}%{_datadir}/solfege/*/*.py
- several specfile fixes
- create secure temporary files in `csound-play-harmonic-interval.sh'
* Thu Jul 18 2005 Massimo Pintore <massimo.pintore@qilinux.it> 2.4.0-2qilnx
* Mon Jul 18 2005 Massimo Pintore <massimo.pintore@qilinux.it> 2.4.0-2qilnx
- added gnome-python-extras as requirement
* Mon Jul 18 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.4.0-1qilnx