update to 2013.04.23 [release 2013.04.23-1mamba;Sat Apr 05 2014]
This commit is contained in:
parent
682770304c
commit
f59074ceec
@ -1,2 +1,6 @@
|
||||
# gnucap
|
||||
|
||||
Gnucap is a general purpose circuit simulator.
|
||||
It performs nonlinear dc and transient analyses, fourier analysis, and ac analysis. It can also be run in batch mode or as a server.
|
||||
In batch mode it is mostly Spice compatible, so it is often possible to use the same file for both Gnucap and Spice.
|
||||
|
||||
|
24
gnucap-0.34-install.patch
Normal file
24
gnucap-0.34-install.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ur gnucap-2006-01-17/src/Makefile.in gnucap-2006-01-17-qilnx/src/Makefile.in
|
||||
--- gnucap-2006-01-17/src/Makefile.in 2006-01-18 03:52:29.000000000 +0100
|
||||
+++ gnucap-2006-01-17-qilnx/src/Makefile.in 2006-03-20 13:23:08.000000000 +0100
|
||||
@@ -128,15 +128,15 @@
|
||||
#-----------------------------------------------------------------------------
|
||||
# Note that the /usr/local directory is overwritten by configure.
|
||||
install: nothing
|
||||
- if test -d /usr/local/bin; then \
|
||||
- cp O/gnucap /usr/local/bin/gnucap; \
|
||||
+ if test -d ${DESTDIR}/usr/local/bin; then \
|
||||
+ cp O/gnucap ${DESTDIR}/usr/local/bin/gnucap; \
|
||||
else \
|
||||
- mkdir -p /usr/local/bin && \
|
||||
- cp O/gnucap /usr/local/bin/gnucap; \
|
||||
+ mkdir -p ${DESTDIR}/usr/local/bin && \
|
||||
+ cp O/gnucap ${DESTDIR}/usr/local/bin/gnucap; \
|
||||
fi
|
||||
#-----------------------------------------------------------------------------
|
||||
uninstall: clean
|
||||
- -rm /usr/local/bin/gnucap
|
||||
+ -rm ${DESTDIR}/usr/local/bin/gnucap
|
||||
#-----------------------------------------------------------------------------
|
||||
unconfig:
|
||||
rm -f Makefile
|
16
gnucap-0.34-libtermcap.patch
Normal file
16
gnucap-0.34-libtermcap.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- gnucap-2006-01-17/src/configure 2005-09-06 21:08:39.000000000 +0200
|
||||
+++ gnucap-2006-01-17-qilnx/src/configure 2006-03-20 18:28:06.000000000 +0100
|
||||
@@ -9,11 +9,11 @@
|
||||
(cd O; rm -f gnucap-modelgen; ln -s ../../modelgen/O/gnucap-modelgen gnucap-modelgen)
|
||||
|
||||
rm -f a.out
|
||||
-g++ -lreadline -ltermcap test_readline.cc
|
||||
+g++ -lreadline -lcurses test_readline.cc
|
||||
if [ -f a.out ] ; then
|
||||
echo "using readline"
|
||||
echo "-DHAS_READLINE \\" >>Make.ccflags
|
||||
- echo "-lreadline -ltermcap \\" >>Make.libs
|
||||
+ echo "-lreadline -lcurses \\" >>Make.libs
|
||||
else
|
||||
echo "either libtermcap or libreadline is missing - not using readline"
|
||||
fi
|
11
gnucap-2013.04.23-gcc-4.3.patch
Normal file
11
gnucap-2013.04.23-gcc-4.3.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- gnucap-2013-04-23/lib/configure.orig 2014-04-05 10:46:47.517570093 +0000
|
||||
+++ gnucap-2013-04-23/lib/configure 2014-04-05 10:42:39.067893604 +0000
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
#----------------------------------------------------------------
|
||||
echo "CCFLAGS = -fPIC \\" >Make.ccflags
|
||||
-echo "LIBS = \\" >Make.libs
|
||||
+echo "LIBS = -ldl \\" >Make.libs
|
||||
|
||||
rm -f a.out
|
||||
g++ -lreadline -ltermcap test_readline.cc
|
16
gnucap-2013.04.23-readline.patch
Normal file
16
gnucap-2013.04.23-readline.patch
Normal file
@ -0,0 +1,16 @@
|
||||
--- gnucap-2013-04-23/lib/test_readline.cc.orig 2014-04-05 10:45:16.980417375 +0000
|
||||
+++ gnucap-2013-04-23/lib/test_readline.cc 2014-04-05 10:44:39.072771938 +0000
|
||||
@@ -1,4 +1,5 @@
|
||||
//testing=trivial 2006.07.17
|
||||
+#include <stdio.h>
|
||||
#include <readline/readline.h>
|
||||
#include <readline/history.h>
|
||||
int main()
|
||||
--- gnucap-2013-04-23/apps/test_readline.cc.orig 2014-04-05 10:49:52.475837269 +0000
|
||||
+++ gnucap-2013-04-23/apps/test_readline.cc 2014-04-05 10:50:00.569761383 +0000
|
||||
@@ -1,4 +1,5 @@
|
||||
//testing=trivial 2006.07.17
|
||||
+#include <stdio.h>
|
||||
#include <readline/readline.h>
|
||||
#include <readline/history.h>
|
||||
int main()
|
97
gnucap.spec
Normal file
97
gnucap.spec
Normal file
@ -0,0 +1,97 @@
|
||||
%define pckver %(echo %version | tr . -)
|
||||
Name: gnucap
|
||||
Epoch: 1
|
||||
Version: 2013.04.23
|
||||
Release: 1mamba
|
||||
Summary: A general purpose circuit simulator
|
||||
Group: Applications/Scientific
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gnucap.org/dokuwiki/doku.php?id=gnucap:start
|
||||
Source: http://gnucap.org/devel/gnucap-%{pckver}.tar.gz
|
||||
Patch0: %{name}-0.34-install.patch
|
||||
Patch1: %{name}-0.34-libtermcap.patch
|
||||
Patch2: gnucap-2013.04.23-readline.patch
|
||||
Patch3: gnucap-2013.04.23-gcc-4.3.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtermcap-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gcc-c++
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
# patches http://www.redhat.com/archives/fedora-extras-commits/2006-April/msg02132.html
|
||||
|
||||
%description
|
||||
Gnucap is a general purpose circuit simulator.
|
||||
It performs nonlinear dc and transient analyses, fourier analysis, and ac analysis. It can also be run in batch mode or as a server.
|
||||
In batch mode it is mostly Spice compatible, so it is often possible to use the same file for both Gnucap and Spice.
|
||||
|
||||
%package devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n gnucap-%{pckver}
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
%configure --prefix=%{_prefix}
|
||||
|
||||
#export CCFLAGS="%{optflags}"
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall PREFIX=%{buildroot}%{_prefix}
|
||||
|
||||
%ifarch x86_64
|
||||
mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir}
|
||||
%endif
|
||||
|
||||
#install -D -m644 doc/gnucap.1 \
|
||||
# %{buildroot}%{_mandir}/man1/gnucap.1
|
||||
#install -D -m644 doc/gnucap-ibis.1 \
|
||||
# %{buildroot}%{_mandir}/man1/gnucap-ibis.1
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gnucap
|
||||
%{_bindir}/gnucap-modelgen
|
||||
%{_libdir}/libgnucap-default-plugins.so
|
||||
%{_libdir}/libgnucap.so
|
||||
%doc AUTHORS COPYING
|
||||
#%doc examples/*
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/gnucap
|
||||
%{_includedir}/gnucap/*.h
|
||||
%{_includedir}/gnucap/spice-wrapper.cc
|
||||
%doc NEWS README
|
||||
|
||||
%changelog
|
||||
* Sat Apr 05 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2013.04.23-1mamba
|
||||
- update to 2013.04.23
|
||||
|
||||
* Thu Jan 31 2013 Automatic Build System <autodist@mambasoft.it> 20091207-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jul 20 2008 gil <puntogil@libero.it> 2008-05-27-1mamba
|
||||
- update to 2008-05-27
|
||||
- removed patches
|
||||
|
||||
* Mon Mar 20 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2006-01-17-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user