rebuilt with mono 2.8.2 [release 2.24.2-2mamba;Tue Jan 11 2011]

This commit is contained in:
Silvan Calarco 2024-01-05 23:14:38 +01:00
parent a489ab14fb
commit 0e2e975c1b
3 changed files with 170 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# gnome-sharp
Gnome#, a GUI Toolkit, is a set of .NET bindings for the GNOME (http://www.gnome.org/) libraries.

View File

@ -0,0 +1,23 @@
--- gnome-sharp-2.16.1.orig/configure.in 2008-01-24 22:57:23.000000000 +0100
+++ gnome-sharp-2.16.1/configure.in 2009-01-06 15:55:26.000000000 +0100
@@ -195,6 +195,12 @@
PKG_CHECK_MODULES(RSVG_DEPENDENCIES, librsvg-2.0 >= $RSVG_REQUIRED_VERSION, enable_rsvg=yes, enable_rsvg=no)
if test "x$enable_gnome" = "xyes"; then
+GTKHTML_REQUIRED_VERSION=3.14.0
+PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.14 >= $GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
+if test "x$enable_gtkhtml" = "xyes"; then
+GTKHTML_VERSION=3.14
+GTKHTML_SOVERSION=19
+else
GTKHTML_REQUIRED_VERSION=3.8.0
PKG_CHECK_MODULES(GTKHTML_DEPENDENCIES, libgtkhtml-3.8 >= $GTKHTML_REQUIRED_VERSION, enable_gtkhtml=yes, enable_gtkhtml=no)
if test "x$enable_gtkhtml" = "xyes"; then
@@ -225,6 +231,7 @@
fi
fi
fi
+fi
AC_SUBST(GTKHTML_VERSION)
AC_SUBST(GTKHTML_SOVERSION)
else

145
gnome-sharp.spec Normal file
View File

@ -0,0 +1,145 @@
%define majversion %(echo %version | cut -d. -f 1-2)
Name: gnome-sharp
Version: 2.24.2
Release: 2mamba
Summary: A set of .NET bindings for the GNOME libraries
Group: Development/Languages
Vendor: openmamba
Distribution: openmamba
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
URL: http://www.mono-project.com/GtkSharp
Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-sharp/%{majversion}/gnome-sharp-%{version}.tar.bz2
Patch0: %{name}-2.16.1-gtkhtml-3.14.patch
License: LGPL
Requires: mono-core
## AUTOBUILDREQ-BEGIN
BuildRequires: GConf-devel
BuildRequires: glibc-devel
BuildRequires: libart_lgpl-devel
BuildRequires: libatk-devel
BuildRequires: libaudiofile-devel
BuildRequires: libavahi-devel
BuildRequires: libbonobo-devel
BuildRequires: libbonoboui-devel
BuildRequires: libcairo-devel
BuildRequires: libdbus-devel
BuildRequires: libdbus-glib-devel
BuildRequires: libe2fs-devel
BuildRequires: libesound-devel
BuildRequires: libexpat-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libglib-devel
BuildRequires: libglitz-devel
BuildRequires: libgnomecanvas-devel
BuildRequires: libgnome-devel
BuildRequires: libgnome-keyring-devel
BuildRequires: libgnomeui-devel
BuildRequires: libgnome-vfs-devel
BuildRequires: libgtk-devel
BuildRequires: libICE-devel
BuildRequires: libopenssl-devel
BuildRequires: libpango-devel
BuildRequires: libpixman-devel
BuildRequires: libpng-devel
BuildRequires: libpopt-devel
BuildRequires: libselinux-devel
BuildRequires: libSM-devel
BuildRequires: libssp-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libxcb-util-devel
BuildRequires: libXcomposite-devel
BuildRequires: libXcursor-devel
BuildRequires: libXdamage-devel
BuildRequires: libXdmcp-devel
BuildRequires: libXext-devel
BuildRequires: libXfixes-devel
BuildRequires: libXinerama-devel
BuildRequires: libxml2-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libz-devel
BuildRequires: mono-core
BuildRequires: ORBit2-devel
## AUTOBUILDREQ-END
BuildRequires: mono-devel
BuildRequires: gtk-sharp-devel
BuildRequires: librsvg-devel
BuildRequires: libgtkhtml3-devel
BuildRequires: libvte-devel
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
Gnome#, a GUI Toolkit, is a set of .NET bindings for the GNOME (http://www.gnome.org/) libraries.
%package devel
Summary: Static libraries and headers for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
Gnome#, a GUI Toolkit, is a set of .NET bindings for the GNOME (http://www.gnome.org/) libraries.
This package contains static libraries and header files need for development.
%prep
%setup -q
#%patch0 -p1
aclocal
autoconf
libtoolize
%build
%configure
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/*.so
%{_prefix}/lib/mono/*/*art-sharp*
%{_prefix}/lib/mono/*/*gconf-sharp*
%{_prefix}/lib/mono/*/*gnome-sharp*
%{_prefix}/lib/mono/*/*gnome-vfs-sharp*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%{_bindir}/gconfsharp*
%{_prefix}/lib/gtk-sharp-?.?/gconfsharp*
%{_libdir}/*.a
%{_libdir}/*.la
%{_datadir}/gapi-?.?/*.xml
%{_libdir}/pkgconfig/*.pc
%doc ChangeLog NEWS README
%changelog
* Tue Jan 11 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.2-2mamba
- rebuilt with mono 2.8.2
* Sun Oct 10 2010 Automatic Build System <autodist@mambasoft.it> 2.24.2-1mamba
- automatic update to 2.24.2 by autodist
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 2.24.1-2mamba
- automatic rebuild by autodist
* Sun Mar 22 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.24.1-1mamba
- update to 2.24.1
* Tue Jan 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.16.1-1mamba
- automatic update by autodist
* Sun Jul 01 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.16.0-1mamba
- package created by autospec