automatic version update by autodist [release 3.11.2-1mamba;Tue Nov 05 2013]
This commit is contained in:
parent
64503dc3f4
commit
68a1d8606c
@ -1,2 +1,4 @@
|
||||
# gnome-power-manager
|
||||
|
||||
A session daemon for the GNOME desktop environment that makes it easy to manage your laptop or desktop system.
|
||||
|
||||
|
30
gnome-power-manager-2.32.0-libnotify-0.7.patch
Normal file
30
gnome-power-manager-2.32.0-libnotify-0.7.patch
Normal file
@ -0,0 +1,30 @@
|
||||
--- src/gpm-manager.c
|
||||
+++ src/gpm-manager.c
|
||||
@@ -43,6 +43,10 @@
|
||||
#include <libupower-glib/upower.h>
|
||||
#include <libnotify/notify.h>
|
||||
|
||||
+#ifndef NOTIFY_CHECK_VERSION
|
||||
+#define NOTIFY_CHECK_VERSION(x,y,z) 0
|
||||
+#endif
|
||||
+
|
||||
#include "egg-debug.h"
|
||||
#include "egg-console-kit.h"
|
||||
|
||||
@@ -480,12 +484,16 @@
|
||||
/* close any existing notification of this class */
|
||||
gpm_manager_notify_close (manager, *notification_class);
|
||||
|
||||
+#if NOTIFY_CHECK_VERSION (0, 7, 0)
|
||||
+ notification = notify_notification_new (title, message, icon);
|
||||
+#else
|
||||
/* if the status icon is hidden, don't point at it */
|
||||
if (manager->priv->status_icon != NULL &&
|
||||
gtk_status_icon_is_embedded (manager->priv->status_icon))
|
||||
notification = notify_notification_new_with_status_icon (title, message, icon, manager->priv->status_icon);
|
||||
else
|
||||
notification = notify_notification_new (title, message, icon, NULL);
|
||||
+#endif
|
||||
notify_notification_set_timeout (notification, timeout);
|
||||
notify_notification_set_urgency (notification, urgency);
|
||||
g_signal_connect (notification, "closed", G_CALLBACK (gpm_manager_notification_closed_cb), notification_class);
|
168
gnome-power-manager.spec
Normal file
168
gnome-power-manager.spec
Normal file
@ -0,0 +1,168 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: gnome-power-manager
|
||||
Version: 3.11.2
|
||||
Release: 1mamba
|
||||
Summary: A session daemon for the GNOME desktop environment that makes it easy to manage your laptop or desktop system
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://projects.gnome.org/gnome-power-manager/
|
||||
Source: ftp://ftp.gnome.org/pub/gnome/sources/gnome-power-manager/%{majver}/gnome-power-manager-%{version}.tar.xz
|
||||
Patch0: %{name}-2.32.0-libnotify-0.7.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: GConf-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libart_lgpl-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libavahi-devel
|
||||
BuildRequires: libavahi-glib-devel
|
||||
BuildRequires: libbonobo-devel
|
||||
BuildRequires: libbonoboui-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcanberra-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglitz-devel
|
||||
BuildRequires: libgnomecanvas-devel
|
||||
BuildRequires: libgnome-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libgnome-vfs-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libnotify-devel
|
||||
BuildRequires: libopenssl-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpixman-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libpthread-stubs-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libssp-devel
|
||||
BuildRequires: libstartup-notification-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libunique-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libwnck2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxcb-util-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXfixes-devel
|
||||
BuildRequires: libXinerama-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXres-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: ORBit2-devel
|
||||
BuildRequires: udev-devel
|
||||
BuildRequires: upower-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
A session daemon for the GNOME desktop environment that makes it easy to manage your laptop or desktop system.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p0
|
||||
|
||||
%build
|
||||
%configure --disable-scrollkeeper
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
if [ $1 -ge 1 ]; then
|
||||
GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
|
||||
gconftool-2 --makefile-install-rule \
|
||||
/etc/gconf/schemas/gnome-power-manager.schemas &> /dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/HighContrast &>/dev/null
|
||||
fi
|
||||
:
|
||||
|
||||
%postun
|
||||
if [ $1 -eq 0 ]; then
|
||||
GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
|
||||
gconftool-2 --makefile-uninstall-rule \
|
||||
/etc/gconf/schemas/gnome-power-manager.schemas &> /dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/HighContrast &>/dev/null
|
||||
fi
|
||||
:
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/gnome-power-statistics
|
||||
%{_datadir}/applications/gnome-power-statistics.desktop
|
||||
%{_datadir}/appdata/gnome-power-statistics.appdata.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.power-manager.gschema.xml
|
||||
%{_datadir}/icons/hicolor/*/apps/gnome*.png
|
||||
%{_datadir}/icons/hicolor/scalable/apps/gnome*.svg
|
||||
%{_datadir}/icons/HighContrast/*/apps/gnome-power-statistics.png
|
||||
%{_mandir}/man1/gnome-power-statistics.1*
|
||||
%doc AUTHORS COPYING
|
||||
#ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Tue Nov 05 2013 Automatic Build System <autodist@mambasoft.it> 3.11.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Nov 05 2013 Automatic Build System <autodist@mambasoft.it> 3.11.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Oct 29 2013 Automatic Build System <autodist@mambasoft.it> 3.10.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue May 14 2013 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 15 2013 Automatic Build System <autodist@mambasoft.it> 3.8.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 26 2012 Automatic Build System <autodist@mambasoft.it> 3.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Apr 01 2012 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||||
- update to 3.4.0
|
||||
|
||||
* Wed Oct 19 2011 Automatic Build System <autodist@mambasoft.it> 3.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 28 2011 Automatic Build System <autodist@mambasoft.it> 3.2.0-1mamba
|
||||
- update to 3.2.0
|
||||
|
||||
* Sun Sep 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.0-2mamba
|
||||
- install gconf schema
|
||||
|
||||
* Sun Sep 25 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user