automatic version update by autodist [release 3.10.0-1mamba;Tue Oct 29 2013]
This commit is contained in:
parent
bc0032e583
commit
545d256fa8
@ -1,2 +1,5 @@
|
|||||||
# gnome-disk-utility
|
# gnome-disk-utility
|
||||||
|
|
||||||
|
This package contains the Palimpsest disk management application.
|
||||||
|
Palimpsest supports partitioning, file system creation, encryption, RAID, SMART monitoring, etc.
|
||||||
|
|
||||||
|
97
gnome-disk-utility-3.8.2-gcc-4.8.patch
Normal file
97
gnome-disk-utility-3.8.2-gcc-4.8.patch
Normal file
@ -0,0 +1,97 @@
|
|||||||
|
diff -u -r gnome-disk-utility-3.8.2/src/disks/gducreatediskimagedialog.c gnome-disk-utility-3.8.2-typefixes/src/disks/gducreatediskimagedialog.c
|
||||||
|
--- gnome-disk-utility-3.8.2/src/disks/gducreatediskimagedialog.c 2013-05-14 07:15:48.000000000 +0200
|
||||||
|
+++ gnome-disk-utility-3.8.2-typefixes/src/disks/gducreatediskimagedialog.c 2013-05-29 03:17:37.201963964 +0200
|
||||||
|
@@ -610,7 +610,7 @@
|
||||||
|
error))
|
||||||
|
{
|
||||||
|
g_prefix_error (error,
|
||||||
|
- "Error writing %" G_GUINT64_FORMAT " bytes to offset %" G_GUINT64_FORMAT ": ",
|
||||||
|
+ "Error writing %" G_GSIZE_FORMAT " bytes to offset %" G_GUINT64_FORMAT ": ",
|
||||||
|
num_bytes_to_write,
|
||||||
|
offset);
|
||||||
|
goto out;
|
||||||
|
diff -u -r gnome-disk-utility-3.8.2/src/disks/gducreatefilesystemwidget.c gnome-disk-utility-3.8.2-typefixes/src/disks/gducreatefilesystemwidget.c
|
||||||
|
--- gnome-disk-utility-3.8.2/src/disks/gducreatefilesystemwidget.c 2013-05-14 07:15:48.000000000 +0200
|
||||||
|
+++ gnome-disk-utility-3.8.2-typefixes/src/disks/gducreatefilesystemwidget.c 2013-05-29 03:18:30.224935009 +0200
|
||||||
|
@@ -429,7 +429,7 @@
|
||||||
|
if (widget->drive != NULL && udisks_drive_get_removable (widget->drive))
|
||||||
|
{
|
||||||
|
/* default FAT for flash and disks/media smaller than 20G (assumed to be flash cards) */
|
||||||
|
- if (is_flash (widget->drive) || udisks_drive_get_size (widget->drive) < 20L * 1000L*1000L*1000L)
|
||||||
|
+ if (is_flash (widget->drive) || udisks_drive_get_size (widget->drive) < (guint64)(20ULL * 1000ULL*1000ULL*1000ULL))
|
||||||
|
{
|
||||||
|
gtk_combo_box_set_active_id (GTK_COMBO_BOX (widget->type_combobox), "vfat");
|
||||||
|
}
|
||||||
|
diff -u -r gnome-disk-utility-3.8.2/src/disks/gduformatdiskdialog.c gnome-disk-utility-3.8.2-typefixes/src/disks/gduformatdiskdialog.c
|
||||||
|
--- gnome-disk-utility-3.8.2/src/disks/gduformatdiskdialog.c 2013-05-14 07:15:48.000000000 +0200
|
||||||
|
+++ gnome-disk-utility-3.8.2-typefixes/src/disks/gduformatdiskdialog.c 2013-05-29 03:17:37.338629696 +0200
|
||||||
|
@@ -293,7 +293,7 @@
|
||||||
|
/* Default to MBR for removable drives < 2TB... GPT otherwise */
|
||||||
|
if (data->drive != NULL &&
|
||||||
|
udisks_drive_get_removable (data->drive) &&
|
||||||
|
- udisks_drive_get_size (data->drive) < 2 * 1000L*1000L*1000L*1000L)
|
||||||
|
+ udisks_drive_get_size (data->drive) < (guint64)(2ULL * 1000ULL*1000ULL*1000ULL*1000ULL))
|
||||||
|
{
|
||||||
|
gtk_combo_box_set_active_id (GTK_COMBO_BOX (data->type_combobox), "dos");
|
||||||
|
}
|
||||||
|
diff -u -r gnome-disk-utility-3.8.2/src/disks/gdupartitiondialog.c gnome-disk-utility-3.8.2-typefixes/src/disks/gdupartitiondialog.c
|
||||||
|
--- gnome-disk-utility-3.8.2/src/disks/gdupartitiondialog.c 2013-05-14 07:15:48.000000000 +0200
|
||||||
|
+++ gnome-disk-utility-3.8.2-typefixes/src/disks/gdupartitiondialog.c 2013-05-29 03:17:37.338629696 +0200
|
||||||
|
@@ -91,11 +91,11 @@
|
||||||
|
if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (data->bootable_checkbutton)))
|
||||||
|
flags |= (1UL<<2);
|
||||||
|
if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (data->readonly_checkbutton)))
|
||||||
|
- flags |= (1UL<<60);
|
||||||
|
+ flags |= (1ULL<<60);
|
||||||
|
if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (data->hidden_checkbutton)))
|
||||||
|
- flags |= (1UL<<62);
|
||||||
|
+ flags |= (1ULL<<62);
|
||||||
|
if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (data->do_not_automount_checkbutton)))
|
||||||
|
- flags |= (1UL<<63);
|
||||||
|
+ flags |= (1ULL<<63);
|
||||||
|
}
|
||||||
|
else if (g_strcmp0 (data->partition_table_type, "dos") == 0)
|
||||||
|
{
|
||||||
|
@@ -245,9 +245,9 @@
|
||||||
|
flags = udisks_partition_get_flags (data->partition);
|
||||||
|
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->system_checkbutton), (flags & (1UL<< 0)) != 0);
|
||||||
|
gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->bootable_checkbutton), (flags & (1UL<< 2)) != 0);
|
||||||
|
- gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->readonly_checkbutton), (flags & (1UL<<60)) != 0);
|
||||||
|
- gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->hidden_checkbutton), (flags & (1UL<<62)) != 0);
|
||||||
|
- gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->do_not_automount_checkbutton), (flags & (1UL<<63)) != 0);
|
||||||
|
+ gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->readonly_checkbutton), (flags & (1ULL<<60)) != 0);
|
||||||
|
+ gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->hidden_checkbutton), (flags & (1ULL<<62)) != 0);
|
||||||
|
+ gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (data->do_not_automount_checkbutton), (flags & (1ULL<<63)) != 0);
|
||||||
|
}
|
||||||
|
else if (g_strcmp0 (data->partition_table_type, "dos") == 0)
|
||||||
|
{
|
||||||
|
diff -u -r gnome-disk-utility-3.8.2/src/disks/gdurestorediskimagedialog.c gnome-disk-utility-3.8.2-typefixes/src/disks/gdurestorediskimagedialog.c
|
||||||
|
--- gnome-disk-utility-3.8.2/src/disks/gdurestorediskimagedialog.c 2013-05-14 07:15:48.000000000 +0200
|
||||||
|
+++ gnome-disk-utility-3.8.2-typefixes/src/disks/gdurestorediskimagedialog.c 2013-05-29 03:17:37.485295361 +0200
|
||||||
|
@@ -587,7 +587,7 @@
|
||||||
|
&error))
|
||||||
|
{
|
||||||
|
g_prefix_error (&error,
|
||||||
|
- "Error reading %" G_GUINT64_FORMAT " bytes from offset %" G_GUINT64_FORMAT ": ",
|
||||||
|
+ "Error reading %" G_GSIZE_FORMAT " bytes from offset %" G_GUINT64_FORMAT ": ",
|
||||||
|
num_bytes_to_read,
|
||||||
|
num_bytes_completed);
|
||||||
|
goto out;
|
||||||
|
@@ -595,7 +595,7 @@
|
||||||
|
if (num_bytes_read != num_bytes_to_read)
|
||||||
|
{
|
||||||
|
g_set_error (&error, G_IO_ERROR, G_IO_ERROR_FAILED,
|
||||||
|
- "Requested %" G_GUINT64_FORMAT " bytes from offset %" G_GUINT64_FORMAT " but only read %" G_GUINT64_FORMAT " bytes",
|
||||||
|
+ "Requested %" G_GSIZE_FORMAT " bytes from offset %" G_GUINT64_FORMAT " but only read %" G_GSIZE_FORMAT " bytes",
|
||||||
|
num_bytes_read,
|
||||||
|
num_bytes_completed,
|
||||||
|
num_bytes_to_read);
|
||||||
|
@@ -610,7 +610,7 @@
|
||||||
|
goto copy_write_again;
|
||||||
|
|
||||||
|
g_set_error (&error, G_IO_ERROR, G_IO_ERROR_FAILED,
|
||||||
|
- "Error writing %" G_GUINT64_FORMAT " bytes to offset %" G_GUINT64_FORMAT ": %m",
|
||||||
|
+ "Error writing %" G_GSIZE_FORMAT " bytes to offset %" G_GUINT64_FORMAT ": %m",
|
||||||
|
num_bytes_read,
|
||||||
|
num_bytes_completed);
|
||||||
|
goto out;
|
197
gnome-disk-utility.spec
Normal file
197
gnome-disk-utility.spec
Normal file
@ -0,0 +1,197 @@
|
|||||||
|
%define majver %(echo %version | cut -d. -f 1-2)
|
||||||
|
|
||||||
|
Name: gnome-disk-utility
|
||||||
|
Version: 3.10.0
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GNOME disk management application
|
||||||
|
Group: System/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://git.gnome.org/browse/gnome-disk-utility
|
||||||
|
Source: http://ftp.acc.umu.se/pub/GNOME/sources/gnome-disk-utility/%{majver}/gnome-disk-utility-%{version}.tar.xz
|
||||||
|
Patch0: gnome-disk-utility-3.8.2-gcc-4.8.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libbzip2-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libffi-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libGL-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpixman-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libpthread-stubs-devel
|
||||||
|
BuildRequires: libselinux-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXau-devel
|
||||||
|
BuildRequires: libxcb-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
|
BuildRequires: libXrender-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: udev-devel
|
||||||
|
BuildRequires: udisks2-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: gettext
|
||||||
|
BuildRequires: gnome-doc-utils
|
||||||
|
BuildRequires: gnome-keyring-devel
|
||||||
|
BuildRequires: gtk-doc
|
||||||
|
BuildRequires: intltool
|
||||||
|
#BuildRequires: librarian-compat
|
||||||
|
BuildRequires: libavahi-gtk3-devel
|
||||||
|
BuildRequires: libsecret-devel
|
||||||
|
BuildRequires: libpwquality-devel
|
||||||
|
Obsoletes: libgnome-disk-utility
|
||||||
|
Obsoletes: libgnome-disk-utility-devel
|
||||||
|
Obsoletes: gnome-disk-utility-nautilus
|
||||||
|
#Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
This package contains the Palimpsest disk management application.
|
||||||
|
Palimpsest supports partitioning, file system creation, encryption, RAID, SMART monitoring, etc.
|
||||||
|
|
||||||
|
%package -n lib%{name}
|
||||||
|
Summary: Shared libraries used by Palimpsest
|
||||||
|
Group: System/Libraries
|
||||||
|
Requires: udisks
|
||||||
|
|
||||||
|
%description -n lib%{name}
|
||||||
|
GNOME disk management application.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package -n lib%{name}-devel
|
||||||
|
Summary: Devel package for lib%{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n lib%{name}-devel
|
||||||
|
GNOME disk management application.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package nautilus
|
||||||
|
Summary: %{name} Nautilus extension
|
||||||
|
Group: System/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description nautilus
|
||||||
|
GNOME disk management application.
|
||||||
|
|
||||||
|
This package contains a Nautilus extension providing formatting functionality.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --disable-scrollkeeper
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
#echo " " > HACKING
|
||||||
|
#
|
||||||
|
#desktop-file-install --delete-original --dir %{buildroot}%{_datadir}/applications \
|
||||||
|
# %{buildroot}%{_datadir}/applications/palimpsest.desktop
|
||||||
|
#
|
||||||
|
#desktop-file-install --delete-original --dir %{buildroot}%{_sysconfdir}/xdg/autostart \
|
||||||
|
# %{buildroot}%{_sysconfdir}/xdg/autostart/gdu-notification-daemon.desktop
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_libdir}/*.*a
|
||||||
|
rm -f %{buildroot}%{_libdir}/nautilus/extensions-*.*/*.*a
|
||||||
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post
|
||||||
|
update-desktop-database %{_datadir}/applications &> /dev/null
|
||||||
|
|
||||||
|
%postun
|
||||||
|
update-desktop-database %{_datadir}/applications &> /dev/null
|
||||||
|
|
||||||
|
|
||||||
|
%post -n lib%{name}
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor
|
||||||
|
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
||||||
|
fi
|
||||||
|
/sbin/ldconfig
|
||||||
|
|
||||||
|
%postun -n lib%{name}
|
||||||
|
touch --no-create %{_datadir}/icons/hicolor
|
||||||
|
if [ -x /usr/bin/gtk-update-icon-cache ]; then
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor
|
||||||
|
fi
|
||||||
|
/sbin/ldconfig
|
||||||
|
|
||||||
|
%posttrans -n lib%{name}
|
||||||
|
gtk-update-icon-cache -q %{_datadir}/icons/hicolor || :
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/gnome-disk-image-mounter
|
||||||
|
%{_bindir}/gnome-disks
|
||||||
|
%{_libdir}/gnome-settings-daemon-*/gdu-sd-plugin.gnome-settings-plugin
|
||||||
|
%{_libdir}/gnome-settings-daemon-*/libgdu-sd.a
|
||||||
|
%{_libdir}/gnome-settings-daemon-*/libgdu-sd.la
|
||||||
|
%{_libdir}/gnome-settings-daemon-*/libgdu-sd.so
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.settings-daemon.plugins.gdu-sd.gschema.xml
|
||||||
|
%dir %{_datadir}/gnome-disk-utility
|
||||||
|
%{_datadir}/gnome-disk-utility/*.ui
|
||||||
|
%{_datadir}/applications/gnome-disk-image-mounter.desktop
|
||||||
|
%{_datadir}/applications/gnome-disk-image-writer.desktop
|
||||||
|
%{_datadir}/applications/gnome-disks.desktop
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.Disks.gschema.xml
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/gnome-disks-state-standby-symbolic.svg
|
||||||
|
%{_mandir}/man1/gnome-disk-image-mounter.1.gz
|
||||||
|
%{_mandir}/man1/gnome-disks.1.gz
|
||||||
|
%{_datadir}/icons/hicolor/*x*/apps/*.png
|
||||||
|
%{_datadir}/icons/HighContrast/*/apps/gnome-disks.png
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
#NEWS README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Oct 29 2013 Automatic Build System <autodist@mambasoft.it> 3.10.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Jun 04 2013 Automatic Build System <autodist@mambasoft.it> 3.8.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Apr 07 2013 Automatic Build System <autodist@mambasoft.it> 3.8.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Tue Oct 09 2012 Automatic Build System <autodist@mambasoft.it> 3.6.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 20 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 3.4.1-2mamba
|
||||||
|
- obsolete libgnome-disk-utility, libgnome-disk-utility-devel and gnome-disk-utility-nautilus
|
||||||
|
|
||||||
|
* Sat Apr 21 2012 Automatic Build System <autodist@mambasoft.it> 3.4.1-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Apr 04 2012 Automatic Build System <autodist@mambasoft.it> 3.4.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 24 2011 Automatic Build System <autodist@mambasoft.it> 3.0.2-1mamba
|
||||||
|
- update to 3.0.2
|
||||||
|
|
||||||
|
* Tue Aug 23 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.32.1-2mamba
|
||||||
|
- rebuilt in devel
|
||||||
|
|
||||||
|
* Thu Mar 03 2011 gil <puntogil@libero.it> 2.32.1-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user