package created using the webbuild interface [release 46.1-1mamba;Tue Aug 27 2024]
This commit is contained in:
parent
2204be980b
commit
45300212cd
@ -1,2 +1,3 @@
|
|||||||
# gnome-boxes
|
# gnome-boxes
|
||||||
|
|
||||||
|
A simple GNOME application to access virtual machines.
|
||||||
|
28
gnome-boxes-46.1-gcc-14.patch
Normal file
28
gnome-boxes-46.1-gcc-14.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 00183fd26a7b51905c179a427a38bfa18d9eb2d3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: sid <sidtosh4@gmail.com>
|
||||||
|
Date: Wed, 22 May 2024 19:32:06 +0100
|
||||||
|
Subject: [PATCH] libvirt-broker: Check when broker is not valid
|
||||||
|
|
||||||
|
Related: #863
|
||||||
|
---
|
||||||
|
src/libvirt-broker.vala | 7 ++++---
|
||||||
|
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/libvirt-broker.vala b/src/libvirt-broker.vala
|
||||||
|
index 655a8c56..140e09c8 100644
|
||||||
|
--- a/src/libvirt-broker.vala
|
||||||
|
+++ b/src/libvirt-broker.vala
|
||||||
|
@@ -24,9 +24,10 @@ private class Boxes.LibvirtBroker : Boxes.Broker {
|
||||||
|
return broker.connections.get (name);
|
||||||
|
}
|
||||||
|
|
||||||
|
- public async LibvirtMachine add_domain (CollectionSource source, GVir.Connection connection, GVir.Domain domain)
|
||||||
|
- throws GLib.Error {
|
||||||
|
- return_val_if_fail (broker != null, null);
|
||||||
|
+ public async LibvirtMachine? add_domain (CollectionSource source, GVir.Connection connection, GVir.Domain domain)
|
||||||
|
+ throws GLib.Error {
|
||||||
|
+ if (broker == null)
|
||||||
|
+ return null;
|
||||||
|
|
||||||
|
if (pending_domains.find (domain) != null) {
|
||||||
|
// Already being added asychronously
|
84
gnome-boxes.spec
Normal file
84
gnome-boxes.spec
Normal file
@ -0,0 +1,84 @@
|
|||||||
|
Name: gnome-boxes
|
||||||
|
Version: 46.1
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A simple GNOME application to access virtual machines
|
||||||
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://apps.gnome.org/app/org.gnome.Boxes/
|
||||||
|
Source: https://gitlab.gnome.org/GNOME/gnome-boxes.git/%{version}/gnome-boxes-%{version}.tar.bz2
|
||||||
|
Patch0: gnome-boxes-46.1-gcc-14.patch
|
||||||
|
License: LGPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libarchive-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk3-devel
|
||||||
|
BuildRequires: libgudev-devel
|
||||||
|
BuildRequires: libhandy-devel
|
||||||
|
BuildRequires: libosinfo-devel
|
||||||
|
BuildRequires: libportal-devel
|
||||||
|
BuildRequires: libsoup-devel
|
||||||
|
BuildRequires: libspice-gtk-devel
|
||||||
|
BuildRequires: libusb-devel
|
||||||
|
BuildRequires: libvirt-glib-devel
|
||||||
|
BuildRequires: libwebkit2gtk-4.1-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: meson
|
||||||
|
|
||||||
|
%description
|
||||||
|
A simple GNOME application to access virtual machines.
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch 0 -p1 -b .gcc-14
|
||||||
|
|
||||||
|
%build
|
||||||
|
%meson
|
||||||
|
%meson_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%meson_install
|
||||||
|
|
||||||
|
%find_lang %{name} --with-gnome || touch %{name}.lang
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/gnome-boxes
|
||||||
|
%{_datadir}/applications/org.gnome.Boxes.desktop
|
||||||
|
%{_metainfodir}/org.gnome.Boxes.appdata.xml
|
||||||
|
%{_libdir}/gnome-boxes/girepository-1.0/Govf-0.1.typelib
|
||||||
|
%{_libdir}/gnome-boxes/libgovf-0.1.so
|
||||||
|
%{_libdir}/gnome-boxes/pkgconfig/govf-0.1.pc
|
||||||
|
%{_libexecdir}/gnome-boxes-search-provider
|
||||||
|
%{_datadir}/dbus-1/services/org.gnome.Boxes.SearchProvider.service
|
||||||
|
%{_datadir}/dbus-1/services/org.gnome.Boxes.service
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.boxes.gschema.xml
|
||||||
|
%dir %{_datadir}/gnome-boxes
|
||||||
|
%{_datadir}/gnome-boxes/gir-1.0/Govf-0.1.gir
|
||||||
|
%dir %{_datadir}/gnome-boxes/osinfo
|
||||||
|
%{_datadir}/gnome-boxes/osinfo/*
|
||||||
|
%{_datadir}/gnome-boxes/sources/QEMU_Session
|
||||||
|
%{_datadir}/gnome-boxes/unattended/disk.img
|
||||||
|
%{_datadir}/gnome-boxes/vapi/govf-0.1.deps
|
||||||
|
%{_datadir}/gnome-boxes/vapi/govf-0.1.vapi
|
||||||
|
%{_datadir}/gnome-shell/search-providers/org.gnome.Boxes.SearchProvider.ini
|
||||||
|
%dir %{_includedir}/gnome-boxes
|
||||||
|
%dir %{_includedir}/gnome-boxes/govf
|
||||||
|
%{_includedir}/gnome-boxes/govf/*
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/org.gnome.Boxes.svg
|
||||||
|
%{_datadir}/icons/hicolor/symbolic/apps/org.gnome.Boxes-symbolic.svg
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 27 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 46.1-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user