88 lines
2.3 KiB
RPMSpec
88 lines
2.3 KiB
RPMSpec
%define commit_ver %(echo %version | cut -d. -f3)
|
|
Name: gn
|
|
Epoch: 1
|
|
Version: 0.2175.b2afae1
|
|
Release: 1mamba
|
|
Summary: A meta-build system that generates build files for Ninja
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://gn.googlesource.com/gn/+/main/README.md
|
|
Source: https://gn.googlesource.com/gn.git/master@%{commit_ver}/gn-%{version}.tar.bz2
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgcc
|
|
## AUTOBUILDREQ-END
|
|
|
|
%description
|
|
GN is a meta-build system that generates build files for Ninja.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
cat > src/last_commit_position.h << _EOF
|
|
// Generated by build/gen.py.
|
|
|
|
#ifndef OUT_LAST_COMMIT_POSITION_H_
|
|
#define OUT_LAST_COMMIT_POSITION_H_
|
|
|
|
#define LAST_COMMIT_POSITION "0 (0)"
|
|
#define LAST_COMMIT_POSITION_NUM 0
|
|
|
|
#endif // OUT_LAST_COMMIT_POSITION_H_
|
|
_EOF
|
|
|
|
%build
|
|
CC=cc CXX=c++ AR=ar \
|
|
CFLAGS="%{optflags} -pthread" \
|
|
CXXFLAGS="%{optflags} -pthread" \
|
|
LDFLAGS="%{optflags} -pthread" \
|
|
python3 build/gen.py \
|
|
--no-last-commit-position \
|
|
--no-strip
|
|
|
|
# --use-lto
|
|
|
|
ninja -C out
|
|
|
|
%check
|
|
out/gn_unittests
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
install -D -m0755 out/gn %{buildroot}%{_bindir}/gn
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/gn
|
|
%doc AUTHORS LICENSE
|
|
|
|
%changelog
|
|
* Sun Jul 28 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2175.b2afae1-1mamba
|
|
- update to 0.2175.b2afae1
|
|
|
|
* Tue Nov 21 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2124.92e6327-1mamba
|
|
- update to 0.2124.92e6327
|
|
|
|
* Sat Dec 12 2020 Automatic Build System <autodist@mambasoft.it> 0.1831.e002e68a-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Nov 11 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1819.e327ffdc-1mamba
|
|
- update to 0.1819.e327ffdc
|
|
|
|
* Mon Nov 09 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20201109git-1mamba
|
|
- update to 0.20201109git
|
|
|
|
* Thu May 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20200521git-1mamba
|
|
- update to 0.20200521git
|
|
|
|
* Fri Mar 01 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20190301git-1mamba
|
|
- package created using the webbuild interface
|