update to 0.20200521git [release 0.20200521git-1mamba;Thu May 21 2020]
This commit is contained in:
parent
f531bbee6c
commit
1b79c47054
18
gn-0.20200521git-gcc-support.patch
Normal file
18
gn-0.20200521git-gcc-support.patch
Normal file
@ -0,0 +1,18 @@
|
||||
diff --git a/build/gen.py b/build/gen.py
|
||||
index d2305c8f..811c2e95 100755
|
||||
--- a/build/gen.py
|
||||
+++ b/build/gen.py
|
||||
@@ -324,8 +324,11 @@ def WriteGNNinja(path, platform, host, options):
|
||||
ldflags.append('-Wl,--icf=all')
|
||||
|
||||
if options.use_lto:
|
||||
- cflags.extend(['-flto', '-fwhole-program-vtables'])
|
||||
- ldflags.extend(['-flto', '-fwhole-program-vtables'])
|
||||
+ cflags.append('-flto')
|
||||
+ ldflags.append('-flto')
|
||||
+ if "clang" in cxx:
|
||||
+ cflags.append('-fwhole-program-vtables')
|
||||
+ ldflags.append('-fwhole-program-vtables')
|
||||
|
||||
cflags.extend([
|
||||
'-D_FILE_OFFSET_BITS=64',
|
21
gn.spec
21
gn.spec
@ -1,5 +1,5 @@
|
||||
Name: gn
|
||||
Version: 0.20190301git
|
||||
Version: 0.20200521git
|
||||
Release: 1mamba
|
||||
Summary: A meta-build system that generates build files for Ninja
|
||||
Group: Development/Tools
|
||||
@ -9,6 +9,7 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://gn.googlesource.com/gn/+/master/README.md
|
||||
## GITSOURCE https://gn.googlesource.com/gn.git master
|
||||
Source: https://gn.googlesource.com/gn.git/master/gn-%{version}.tar.bz2
|
||||
Patch0: gn-0.20200521git-gcc-support.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -23,20 +24,31 @@ GN is a meta-build system that generates build files for Ninja.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
cat > tools/gn/last_commit_position.h << _EOF
|
||||
cat > src/last_commit_position.h << _EOF
|
||||
// Generated by build/gen.py.
|
||||
|
||||
#ifndef OUT_LAST_COMMIT_POSITION_H_
|
||||
#define OUT_LAST_COMMIT_POSITION_H_
|
||||
|
||||
#define LAST_COMMIT_POSITION "0 (0)"
|
||||
#define LAST_COMMIT_POSITION_NUM 0
|
||||
|
||||
#endif // OUT_LAST_COMMIT_POSITION_H_
|
||||
_EOF
|
||||
|
||||
%build
|
||||
python build/gen.py --no-last-commit-position
|
||||
CC=cc CXX=c++ AR=ar \
|
||||
CFLAGS="%{optflags} -pthread" \
|
||||
CXXFLAGS="%{optflags} -pthread" \
|
||||
LDFLAGS="%{optflags} -pthread" \
|
||||
python3 build/gen.py \
|
||||
--no-last-commit-position \
|
||||
--no-strip
|
||||
|
||||
# --use-lto
|
||||
|
||||
ninja -C out
|
||||
|
||||
%check
|
||||
@ -55,5 +67,8 @@ install -D -m0755 out/gn %{buildroot}%{_bindir}/gn
|
||||
%doc AUTHORS LICENSE
|
||||
|
||||
%changelog
|
||||
* Thu May 21 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20200521git-1mamba
|
||||
- update to 0.20200521git
|
||||
|
||||
* Fri Mar 01 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20190301git-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user