63 lines
2.0 KiB
RPMSpec
63 lines
2.0 KiB
RPMSpec
Name: glide
|
|
Version: 0.13.3
|
|
Release: 3mamba
|
|
Summary: Package Management for Golang
|
|
Group: Applications/Development
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://glide.sh/
|
|
Source: https://github.com/Masterminds/glide.git/v%{version}/glide-%{version}.tar.bz2
|
|
License: MIT
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: glibc-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: libgo-devel >= 11.1.0-1mamba
|
|
|
|
%description
|
|
Package Management for Golang.
|
|
|
|
%debug_package
|
|
|
|
%prep
|
|
%setup -q -c -a0
|
|
|
|
mkdir -p build/go && cd build/go
|
|
for f in %{_libdir}/go/*; do ln -s "$f"; done
|
|
mkdir pkg && cd pkg
|
|
for f in %{_libdir}/go/pkg/*; do ln -s "$f"; done
|
|
mkdir -p %{_builddir}/%{name}-%{version}/build/src/github.com/Masterminds/glide
|
|
mv %{_builddir}/%{name}-%{version}/%{name}-%{version}/* %{_builddir}/%{name}-%{version}/build/src/github.com/Masterminds/glide
|
|
|
|
%build
|
|
export GOPATH="%{_builddir}/%{name}-%{version}/build"
|
|
export GOROOT="$GOPATH/go"
|
|
cd %{_builddir}/%{name}-%{version}/build/src/github.com/Masterminds/glide
|
|
go build -o glide -ldflags "-X main.version=%{version}" glide.go
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
cd %{_builddir}/%{name}-%{version}/build/src/github.com/Masterminds/glide
|
|
install -Dm755 glide %{buildroot}%{_bindir}/glide
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/glide
|
|
%doc build/src/github.com/Masterminds/glide/LICENSE
|
|
|
|
%changelog
|
|
* Tue May 04 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.3-3mamba
|
|
- rebuilt with libgo 11.1.0
|
|
|
|
* Thu May 14 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.3-2mamba
|
|
- rebuilt by autoport with build requirements: libgo-devel>=10.1.0-1mamba
|
|
|
|
* Wed Aug 28 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.3-1mamba
|
|
- update to 0.13.3
|
|
|
|
* Fri Aug 17 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 0.2.0-1mamba
|
|
- package created using the webbuild interface
|