rebuilt with ldc 1.35.0 [release 2.4.2-2mamba;Mon Nov 06 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 23:08:16 +01:00
parent 7e6bdd4dca
commit f2c98e1da9
5 changed files with 29 additions and 132 deletions

View File

@ -1,59 +0,0 @@
From b22a87ee6f42806aff5f9173a24cd05995db6cb0 Mon Sep 17 00:00:00 2001
From: Mike Wey <mike@mikewey.eu>
Date: Sat, 3 Apr 2021 14:37:12 +0200
Subject: [PATCH] Fix building for GLib 2.68 / Fedora 34
See Also: #11
---
src/APILookupGLib.txt | 6 ++++--
src/APILookupGio.txt | 6 ++++++
2 files changed, 10 insertions(+), 2 deletions(-)
diff --git a/src/APILookupGLib.txt b/src/APILookupGLib.txt
index 6e10e20..d0d0bfc 100644
--- a/src/APILookupGLib.txt
+++ b/src/APILookupGLib.txt
@@ -320,7 +320,7 @@ code: start
if ( date is null )
return false;
- return equal(this, date) != 0;
+ return g_date_time_compare(gDateTime, date.getDateTimeStruct()) != 0;
}
/** */
@@ -331,7 +331,7 @@ code: start
if ( date is null )
return int.min;
- return compare(this, date);
+ return g_date_time_compare(gDateTime, date.getDateTimeStruct());
}
/** */
@@ -1489,6 +1489,8 @@ code: end
struct: TimeZone
noCode: new_local
noCode: new_utc
+#TODO: Proper solution
+version 2.68: noCode: new_identifier
struct: Tree
class: BBTree
diff --git a/src/APILookupGio.txt b/src/APILookupGio.txt
index 8b285f2..87c6780 100644
--- a/src/APILookupGio.txt
+++ b/src/APILookupGio.txt
@@ -401,6 +401,12 @@ array: set_environ env
struct: ThemedIcon
noCode: new
+version 2.68: start
+ struct: TlsCertificate
+ #TODO: Proper solution
+ noCode: new_from_pkcs11_uris
+version: end
+
struct: TlsPassword
out: get_value length
array: get_value Return length

View File

@ -1,29 +0,0 @@
From 31cc330d1502084f25b207ba0f6c9a26126b5f20 Mon Sep 17 00:00:00 2001
From: Mike Wey <mike@mikewey.eu>
Date: Sun, 31 Oct 2021 21:53:17 +0100
Subject: [PATCH] Make sure GlibD builds for Glib 2.70.
Fixes #12
---
src/APILookupGLib.txt | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)
diff --git a/src/APILookupGLib.txt b/src/APILookupGLib.txt
index d0d0bfc..36e1cb2 100644
--- a/src/APILookupGLib.txt
+++ b/src/APILookupGLib.txt
@@ -1985,9 +1985,11 @@ version: end
version 2.60: move: strv_equal Str
-move: string_new String
-move: string_new_len String
-move: string_sized_new String
+version <2.70: start
+ move: string_new String
+ move: string_new_len String
+ move: string_sized_new String
+version: end
move: bit_lock Thread
move: bit_trylock Thread

View File

@ -1,36 +0,0 @@
From ff1daa7c1206c632ef4cba1dc92f35e4c4fdc440 Mon Sep 17 00:00:00 2001
From: Mike Wey <mike@mikewey.eu>
Date: Wed, 23 Mar 2022 23:32:30 +0100
Subject: [PATCH] Glib 2.72
---
meson.build | 3 ++-
src/APILookupGio.txt | 1 +
2 files changed, 3 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index e199722..8d494a5 100644
--- a/meson.build
+++ b/meson.build
@@ -32,7 +32,8 @@ message('Generating D interfaces from GIR...')
girtod_gen = run_command(gir_to_d_prog,
'-i', gir_wrap_dir,
'-o', gir_d_intf_dir,
- '--print-files', 'relative,' + source_root)
+ '--print-files', 'relative,' + source_root,
+ check: true)
if girtod_gen.returncode() != 0
error('Unable to build D intefaces from GIR:\n' + girtod_gen.stderr())
endif
diff --git a/src/APILookupGio.txt b/src/APILookupGio.txt
index 87c6780..d0a989f 100644
--- a/src/APILookupGio.txt
+++ b/src/APILookupGio.txt
@@ -405,6 +405,7 @@ version 2.68: start
struct: TlsCertificate
#TODO: Proper solution
noCode: new_from_pkcs11_uris
+ version 2.72: noCode: new_from_file_with_password
version: end
struct: TlsPassword

View File

@ -0,0 +1,22 @@
From ef3b70be9de8e1c798db47b627b465b0a257e693 Mon Sep 17 00:00:00 2001
From: Jan Beich <jbeich@FreeBSD.org>
Date: Thu, 21 Sep 2023 20:56:50 +0200
Subject: [PATCH] Trivial fix for GLib 2.78
generated/glib/StringG.d(137): Error: constructor `glib.StringG.StringG.this(string init)` conflicts with previous declaration at generated/glib/StringG.d(78)
---
src/APILookupGLib.txt | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/APILookupGLib.txt b/src/APILookupGLib.txt
index d037f7a..f66969d 100644
--- a/src/APILookupGLib.txt
+++ b/src/APILookupGLib.txt
@@ -1313,6 +1313,7 @@ code: end
struct: String
class: StringG
+version 2.78: noCode: new_take
struct: Thread
noCode: new

View File

@ -1,6 +1,6 @@
Name: glibd
Version: 2.4.2
Release: 1mamba
Release: 2mamba
Summary: D bindings for the GLib C Utility Library
Group: System/Libraries
Vendor: openmamba
@ -8,9 +8,7 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://github.com/gtkd-developers/GlibD
Source: https://github.com/gtkd-developers/GlibD.git/v%{version}/GlibD-%{version}.tar.bz2
Patch0: glibd-2.3.0-glib-2.68.patch
Patch1: glibd-2.3.0-glib-2.70.patch
Patch2: glibd-2.3.0-glib-2.72.patch
Patch0: glibd-2.4.2-glib-2.78.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -18,7 +16,7 @@ BuildRequires: libgcc
BuildRequires: libglib-devel
BuildRequires: libldc-devel
## AUTOBUILDREQ-END
BuildRequires: libldc-devel >= 0:1.32.2-1mamba
BuildRequires: libldc-devel >= 0:1.35.0
BuildRequires: girtod
BuildRequires: ldc
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
@ -48,9 +46,7 @@ This package contains libraries and header files for developing applications tha
%prep
%setup -q -n GlibD-%{version}
#%patch0 -p1 -b .glib-2.68
#%patch1 -p1 -b .glib-2.70
#%patch2 -p1 -b .glib-2.72
%patch 0 -p1 -b .glib-2.68
%build
%meson
@ -94,6 +90,9 @@ This package contains libraries and header files for developing applications tha
%doc README.md
%changelog
* Mon Nov 06 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-2mamba
- rebuilt with ldc 1.35.0
* Mon May 29 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1mamba
- update to 2.4.2
- rebuilt by autoport with build requirements: libldc-devel>=0:1.32.2-1mamba