update to 2.3.0 [release 2.3.0-1mamba;Wed Nov 03 2021]
This commit is contained in:
parent
601c43b17f
commit
5a174dd3ec
59
glibd-2.3.0-glib-2.68.patch
Normal file
59
glibd-2.3.0-glib-2.68.patch
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
From b22a87ee6f42806aff5f9173a24cd05995db6cb0 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mike Wey <mike@mikewey.eu>
|
||||||
|
Date: Sat, 3 Apr 2021 14:37:12 +0200
|
||||||
|
Subject: [PATCH] Fix building for GLib 2.68 / Fedora 34
|
||||||
|
|
||||||
|
See Also: #11
|
||||||
|
---
|
||||||
|
src/APILookupGLib.txt | 6 ++++--
|
||||||
|
src/APILookupGio.txt | 6 ++++++
|
||||||
|
2 files changed, 10 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/APILookupGLib.txt b/src/APILookupGLib.txt
|
||||||
|
index 6e10e20..d0d0bfc 100644
|
||||||
|
--- a/src/APILookupGLib.txt
|
||||||
|
+++ b/src/APILookupGLib.txt
|
||||||
|
@@ -320,7 +320,7 @@ code: start
|
||||||
|
if ( date is null )
|
||||||
|
return false;
|
||||||
|
|
||||||
|
- return equal(this, date) != 0;
|
||||||
|
+ return g_date_time_compare(gDateTime, date.getDateTimeStruct()) != 0;
|
||||||
|
}
|
||||||
|
|
||||||
|
/** */
|
||||||
|
@@ -331,7 +331,7 @@ code: start
|
||||||
|
if ( date is null )
|
||||||
|
return int.min;
|
||||||
|
|
||||||
|
- return compare(this, date);
|
||||||
|
+ return g_date_time_compare(gDateTime, date.getDateTimeStruct());
|
||||||
|
}
|
||||||
|
|
||||||
|
/** */
|
||||||
|
@@ -1489,6 +1489,8 @@ code: end
|
||||||
|
struct: TimeZone
|
||||||
|
noCode: new_local
|
||||||
|
noCode: new_utc
|
||||||
|
+#TODO: Proper solution
|
||||||
|
+version 2.68: noCode: new_identifier
|
||||||
|
|
||||||
|
struct: Tree
|
||||||
|
class: BBTree
|
||||||
|
diff --git a/src/APILookupGio.txt b/src/APILookupGio.txt
|
||||||
|
index 8b285f2..87c6780 100644
|
||||||
|
--- a/src/APILookupGio.txt
|
||||||
|
+++ b/src/APILookupGio.txt
|
||||||
|
@@ -401,6 +401,12 @@ array: set_environ env
|
||||||
|
struct: ThemedIcon
|
||||||
|
noCode: new
|
||||||
|
|
||||||
|
+version 2.68: start
|
||||||
|
+ struct: TlsCertificate
|
||||||
|
+ #TODO: Proper solution
|
||||||
|
+ noCode: new_from_pkcs11_uris
|
||||||
|
+version: end
|
||||||
|
+
|
||||||
|
struct: TlsPassword
|
||||||
|
out: get_value length
|
||||||
|
array: get_value Return length
|
29
glibd-2.3.0-glib-2.70.patch
Normal file
29
glibd-2.3.0-glib-2.70.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From 31cc330d1502084f25b207ba0f6c9a26126b5f20 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mike Wey <mike@mikewey.eu>
|
||||||
|
Date: Sun, 31 Oct 2021 21:53:17 +0100
|
||||||
|
Subject: [PATCH] Make sure GlibD builds for Glib 2.70.
|
||||||
|
|
||||||
|
Fixes #12
|
||||||
|
---
|
||||||
|
src/APILookupGLib.txt | 8 +++++---
|
||||||
|
1 file changed, 5 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/APILookupGLib.txt b/src/APILookupGLib.txt
|
||||||
|
index d0d0bfc..36e1cb2 100644
|
||||||
|
--- a/src/APILookupGLib.txt
|
||||||
|
+++ b/src/APILookupGLib.txt
|
||||||
|
@@ -1985,9 +1985,11 @@ version: end
|
||||||
|
|
||||||
|
version 2.60: move: strv_equal Str
|
||||||
|
|
||||||
|
-move: string_new String
|
||||||
|
-move: string_new_len String
|
||||||
|
-move: string_sized_new String
|
||||||
|
+version <2.70: start
|
||||||
|
+ move: string_new String
|
||||||
|
+ move: string_new_len String
|
||||||
|
+ move: string_sized_new String
|
||||||
|
+version: end
|
||||||
|
|
||||||
|
move: bit_lock Thread
|
||||||
|
move: bit_trylock Thread
|
15
glibd.spec
15
glibd.spec
@ -1,6 +1,6 @@
|
|||||||
Name: glibd
|
Name: glibd
|
||||||
Version: 2.2.0
|
Version: 2.3.0
|
||||||
Release: 3mamba
|
Release: 1mamba
|
||||||
Summary: D bindings for the GLib C Utility Library
|
Summary: D bindings for the GLib C Utility Library
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -8,19 +8,19 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://github.com/gtkd-developers/GlibD
|
URL: https://github.com/gtkd-developers/GlibD
|
||||||
Source: https://github.com/gtkd-developers/GlibD.git/v%{version}/GlibD-%{version}.tar.bz2
|
Source: https://github.com/gtkd-developers/GlibD.git/v%{version}/GlibD-%{version}.tar.bz2
|
||||||
|
Patch0: glibd-2.3.0-glib-2.68.patch
|
||||||
|
Patch1: glibd-2.3.0-glib-2.70.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: ldconfig
|
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libldc-devel
|
BuildRequires: libldc-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libldc-devel >= 1.23.0
|
BuildRequires: libldc-devel >= 1.28.0
|
||||||
BuildRequires: girtod
|
BuildRequires: girtod
|
||||||
BuildRequires: ldc
|
BuildRequires: ldc
|
||||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
D bindings for the GLib C Utility Library.
|
D bindings for the GLib C Utility Library.
|
||||||
@ -47,6 +47,8 @@ This package contains libraries and header files for developing applications tha
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n GlibD-%{version}
|
%setup -q -n GlibD-%{version}
|
||||||
|
%patch0 -p1 -b .glib-2.68
|
||||||
|
%patch1 -p1 -b .glib-2.70
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson
|
%meson
|
||||||
@ -90,6 +92,9 @@ This package contains libraries and header files for developing applications tha
|
|||||||
%doc README.md
|
%doc README.md
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 03 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3.0-1mamba
|
||||||
|
- update to 2.3.0
|
||||||
|
|
||||||
* Thu Oct 22 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-3mamba
|
* Thu Oct 22 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.0-3mamba
|
||||||
- rebuilt with ldc 1.23.0
|
- rebuilt with ldc 1.23.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user