57 lines
2.3 KiB
Diff
57 lines
2.3 KiB
Diff
--- glibc-2.14/nis/Makefile
|
|
+++ glibc-2.14-2/nis/Makefile
|
|
@@ -23,9 +23,9 @@ subdir := nis
|
|
|
|
aux := nis_hash
|
|
|
|
+headers := $(wildcard rpcsvc/*.[hx])
|
|
distribute := nss-nis.h nss-nisplus.h nis_intern.h Banner \
|
|
- nisplus-parser.h nis_xdr.h nss \
|
|
- $(wildcard rpcsvc/*.[hx])
|
|
+ nisplus-parser.h nis_xdr.h nss
|
|
|
|
# These are the databases available for the nis (and perhaps later nisplus)
|
|
# service. This must be a superset of the services in nss.
|
|
@@ -69,6 +69,8 @@ libnss_nisplus-inhibit-o = $(filter-out .os,$(object-suffixes))
|
|
|
|
include ../Rules
|
|
|
|
+CFLAGS-nis_findserv.c += -fno-strict-aliasing
|
|
+CFLAGS-ypclnt.c += -fno-strict-aliasing
|
|
|
|
$(objpfx)libnss_compat.so: $(objpfx)libnsl.so$(libnsl.so-version)
|
|
$(objpfx)libnss_nis.so: $(objpfx)libnsl.so$(libnsl.so-version) \
|
|
--- glibc-2.14/sunrpc/Makefile
|
|
+++ glibc-2.14-2/sunrpc/Makefile
|
|
@@ -53,7 +53,7 @@ headers-in-tirpc = $(addprefix rpc/,auth.h auth_unix.h clnt.h pmap_clnt.h \
|
|
des_crypt.h)
|
|
headers-not-in-tirpc = $(addprefix rpc/,key_prot.h rpc_des.h) \
|
|
$(rpcsvc:%=rpcsvc/%) rpcsvc/bootparam.h
|
|
-headers = rpc/netdb.h
|
|
+headers = rpc/netdb.h $(headers-in-tirpc) $(headers-not-in-tirpc)
|
|
install-others = $(inst_sysconfdir)/rpc
|
|
generated = $(rpcsvc:%.x=rpcsvc/%.h) $(rpcsvc:%.x=x%.c) $(rpcsvc:%.x=x%.stmp) \
|
|
$(rpcsvc:%.x=rpcsvc/%.stmp) rpcgen
|
|
@@ -152,6 +152,10 @@ CFLAGS-openchild.c = -fexceptions
|
|
|
|
CPPFLAGS += -D_RPC_THREAD_SAFE_
|
|
|
|
+CFLAGS-clnt_tcp.c += -fno-strict-aliasing
|
|
+CFLAGS-clnt_udp.c += -fno-strict-aliasing
|
|
+CFLAGS-clnt_unix.c += -fno-strict-aliasing
|
|
+
|
|
$(objpfx)tst-getmyaddr: $(common-objpfx)linkobj/libc.so
|
|
$(objpfx)tst-xdrmem: $(common-objpfx)linkobj/libc.so
|
|
$(objpfx)tst-xdrmem2: $(common-objpfx)linkobj/libc.so
|
|
--- a/include/libc-symbols.h
|
|
+++ b/include/libc-symbols.h
|
|
@@ -635,7 +635,7 @@ for linking")
|
|
# define libc_hidden_proto(name, attrs...) hidden_proto (name, ##attrs)
|
|
# define libc_hidden_def(name) hidden_def (name)
|
|
# define libc_hidden_weak(name) hidden_weak (name)
|
|
-# define libc_hidden_nolink(name, version) hidden_nolink (name, libc, version)
|
|
+# define libc_hidden_nolink(name, version) hidden_def (name)
|
|
# define libc_hidden_ver(local, name) hidden_ver (local, name)
|
|
# define libc_hidden_data_def(name) hidden_data_def (name)
|
|
# define libc_hidden_data_weak(name) hidden_data_weak (name)
|