20 lines
579 B
Diff
20 lines
579 B
Diff
commit 2d80bda39073a35af4b904d27fa1511cd309b26f
|
|
Author: Nathan Sidwell <nathan@codesourcery.com>
|
|
Date: Fri Jan 6 20:14:44 2012 +0000
|
|
|
|
Add ARM dependency of libmemusage.so on libc_nonshared.a.
|
|
|
|
diff --git a/sysdeps/arm/Makefile b/sysdeps/arm/Makefile
|
|
index 5651161..1a88430 100644
|
|
--- a/ports/sysdeps/arm/Makefile
|
|
+++ b/ports/sysdeps/arm/Makefile
|
|
@@ -7,3 +7,8 @@ endif
|
|
ifeq ($(subdir),csu)
|
|
gen-as-const-headers += tlsdesc.sym
|
|
endif
|
|
+
|
|
+# to pull in __aeabi_read_tp, needed for tls
|
|
+ifeq ($(subdir),malloc)
|
|
+$(objpfx)libmemusage.so: $(common-objpfx)libc_nonshared.a
|
|
+endif
|