patch to fix unexported function in libresolv breaking runtime and buildtime things [release 2.25-2mamba;Sun Jul 23 2017]
This commit is contained in:
parent
a7b1505009
commit
582de0627d
66
glibc-2.25-resolv-no-compat.patch
Normal file
66
glibc-2.25-resolv-no-compat.patch
Normal file
@ -0,0 +1,66 @@
|
||||
--- glibc-2.25/resolv/compat-gethnamaddr.c.orig 2017-07-23 16:16:44.843366630 +0200
|
||||
+++ glibc-2.25/resolv/compat-gethnamaddr.c 2017-07-23 16:17:41.948589454 +0200
|
||||
@@ -441,7 +441,6 @@
|
||||
}
|
||||
return (res_gethostbyname2(name, AF_INET));
|
||||
}
|
||||
-compat_symbol (libresolv, res_gethostbyname, res_gethostbyname, GLIBC_2_0);
|
||||
|
||||
struct hostent *
|
||||
res_gethostbyname2 (const char *name, int af)
|
||||
@@ -573,7 +572,6 @@
|
||||
return ret;
|
||||
}
|
||||
libresolv_hidden_def (res_gethostbyname2)
|
||||
-compat_symbol (libresolv, res_gethostbyname2, res_gethostbyname2, GLIBC_2_0);
|
||||
|
||||
struct hostent *
|
||||
res_gethostbyaddr (const void *addr, socklen_t len, int af)
|
||||
@@ -673,7 +671,6 @@
|
||||
__set_h_errno (NETDB_SUCCESS);
|
||||
return (hp);
|
||||
}
|
||||
-compat_symbol (libresolv, res_gethostbyaddr, res_gethostbyaddr, GLIBC_2_0);
|
||||
|
||||
void
|
||||
_sethtent (int f)
|
||||
@@ -685,7 +682,6 @@
|
||||
stayopen = f;
|
||||
}
|
||||
libresolv_hidden_def (_sethtent)
|
||||
-compat_symbol (libresolv, _sethtent, _sethtent, GLIBC_2_0);
|
||||
|
||||
static void
|
||||
_endhtent (void)
|
||||
@@ -761,7 +757,6 @@
|
||||
return (&host);
|
||||
}
|
||||
libresolv_hidden_def (_gethtent)
|
||||
-compat_symbol (libresolv, _gethtent, _gethtent, GLIBC_2_0);
|
||||
|
||||
struct hostent *
|
||||
_gethtbyname (const char *name)
|
||||
@@ -775,7 +770,6 @@
|
||||
}
|
||||
return (_gethtbyname2(name, AF_INET));
|
||||
}
|
||||
-compat_symbol (libresolv, _gethtbyname, _gethtbyname, GLIBC_2_0);
|
||||
|
||||
struct hostent *
|
||||
_gethtbyname2 (const char *name, int af)
|
||||
@@ -798,7 +792,6 @@
|
||||
return (p);
|
||||
}
|
||||
libresolv_hidden_def (_gethtbyname2)
|
||||
-compat_symbol (libresolv, _gethtbyname2, _gethtbyname2, GLIBC_2_0);
|
||||
|
||||
struct hostent *
|
||||
_gethtbyaddr (const char *addr, size_t len, int af)
|
||||
@@ -813,7 +806,6 @@
|
||||
return (p);
|
||||
}
|
||||
libresolv_hidden_def (_gethtbyaddr)
|
||||
-compat_symbol (libresolv, _gethtbyaddr, _gethtbyaddr, GLIBC_2_0);
|
||||
|
||||
static void
|
||||
map_v4v6_address (const char *src, char *dst)
|
18
glibc.spec
18
glibc.spec
@ -107,8 +107,8 @@
|
||||
%endif
|
||||
|
||||
Name: glibc
|
||||
Version: 2.24
|
||||
Release: 1mamba
|
||||
Version: 2.25
|
||||
Release: 2mamba
|
||||
Summary: The GNU libc libraries
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -145,6 +145,7 @@ Patch14: %{name}-2.14-rpc_nis_headers_restore.patch
|
||||
Patch15: glibc-ports-2.15-arm-libmemusage-libc_nonshared.patch
|
||||
Patch16: glibc-2.16.0-tetex-3.0.patch
|
||||
Patch17: glibc-2.21-prevent-ehaustion-of-tls-slots.patch
|
||||
Patch18: glibc-2.25-resolv-no-compat.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libcap-devel
|
||||
@ -332,6 +333,7 @@ Cross Platform glibc for %{_target_platform}.
|
||||
#:<< ___EOF
|
||||
%patch5 -p1
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
|
||||
#cd glibc-ports-%{version}
|
||||
#%patch15 -p2
|
||||
@ -534,9 +536,9 @@ function build_glibc() {
|
||||
|
||||
%if "%{?stage2}"
|
||||
# hack, diable nptl for bootstrap gcc
|
||||
opt_tls="--enable-addons --with-tls --disable-sanity-checks"
|
||||
opt_tls="--enable-add-ons --with-tls --disable-sanity-checks"
|
||||
%else
|
||||
opt_tls="--enable-addons --with-tls --enable-obsolete-rpc"
|
||||
opt_tls="--enable-add-ons --with-tls --enable-obsolete-rpc"
|
||||
%endif
|
||||
|
||||
%if %{build_selinux}
|
||||
@ -831,7 +833,7 @@ exit 0
|
||||
%endif
|
||||
%{_infodir}/*
|
||||
%doc BUGS ChangeLog CONFORMANCE NAMESPACE
|
||||
%doc NEWS PROJECTS README*
|
||||
%doc NEWS README*
|
||||
|
||||
%if %{build_doc}
|
||||
%files %{?multilib:multilib-}apidocs
|
||||
@ -924,6 +926,12 @@ exit 0
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sun Jul 23 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.25-2mamba
|
||||
- patch to fix unexported function in libresolv breaking runtime and buildtime things
|
||||
|
||||
* Fri Jul 21 2017 Automatic Build System <autodist@mambasoft.it> 2.25-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 05 2016 Automatic Build System <autodist@mambasoft.it> 2.24-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user