patch to prevent exhaustion of tls slots (vlc), see https://bugzilla.redhat.com/show_bug.cgi?id=1124987 [release 2.21-2mamba;Thu Mar 26 2015]
This commit is contained in:
parent
e3eed2b8fb
commit
31a49ad4d6
11
glibc-2.21-prevent-ehaustion-of-tls-slots.patch
Normal file
11
glibc-2.21-prevent-ehaustion-of-tls-slots.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- glibc-2.21/sysdeps/generic/ldsodefs.h.orig 2015-03-26 00:26:10.892301905 +0100
|
||||||
|
+++ glibc-2.21/sysdeps/generic/ldsodefs.h 2015-03-26 00:26:18.401301799 +0100
|
||||||
|
@@ -389,7 +389,7 @@
|
||||||
|
#define TLS_SLOTINFO_SURPLUS (62)
|
||||||
|
|
||||||
|
/* Number of additional slots in the dtv allocated. */
|
||||||
|
-#define DTV_SURPLUS (14)
|
||||||
|
+#define DTV_SURPLUS (32)
|
||||||
|
|
||||||
|
/* Initial dtv of the main thread, not allocated with normal malloc. */
|
||||||
|
EXTERN void *_dl_initial_dtv;
|
18
glibc.spec
18
glibc.spec
@ -108,7 +108,7 @@
|
|||||||
|
|
||||||
Name: glibc
|
Name: glibc
|
||||||
Version: 2.21
|
Version: 2.21
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: The GNU libc libraries
|
Summary: The GNU libc libraries
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -144,6 +144,7 @@ Patch13: %{name}-2.14-fix-resolver-crash-typo.patch
|
|||||||
Patch14: %{name}-2.14-rpc_nis_headers_restore.patch
|
Patch14: %{name}-2.14-rpc_nis_headers_restore.patch
|
||||||
Patch15: glibc-ports-2.15-arm-libmemusage-libc_nonshared.patch
|
Patch15: glibc-ports-2.15-arm-libmemusage-libc_nonshared.patch
|
||||||
Patch16: glibc-2.16.0-tetex-3.0.patch
|
Patch16: glibc-2.16.0-tetex-3.0.patch
|
||||||
|
Patch17: glibc-2.21-prevent-ehaustion-of-tls-slots.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: libcap-devel
|
BuildRequires: libcap-devel
|
||||||
@ -330,11 +331,7 @@ Cross Platform glibc for %{_target_platform}.
|
|||||||
# -D -T
|
# -D -T
|
||||||
#:<< ___EOF
|
#:<< ___EOF
|
||||||
%patch5 -p1
|
%patch5 -p1
|
||||||
#%patch10 -p1
|
%patch17 -p1
|
||||||
#% patch11 -p
|
|
||||||
#%patch12 -p1
|
|
||||||
#%patch13 -p1
|
|
||||||
#%patch14 -p1
|
|
||||||
|
|
||||||
#cd glibc-ports-%{version}
|
#cd glibc-ports-%{version}
|
||||||
#%patch15 -p2
|
#%patch15 -p2
|
||||||
@ -595,7 +592,9 @@ install -D -m644 %{SOURCE4} %{buildroot}%{_sysconfdir}/logrotate.d/nscd
|
|||||||
install -D -m644 %{SOURCE5} %{buildroot}%{_sysconfdir}/nscd.conf
|
install -D -m644 %{SOURCE5} %{buildroot}%{_sysconfdir}/nscd.conf
|
||||||
install -D -m755 %{SOURCE6} %{buildroot}%{_initrddir}/nscd
|
install -D -m755 %{SOURCE6} %{buildroot}%{_initrddir}/nscd
|
||||||
# work around to avoid stripping libthread_db-1.0.so for debugging
|
# work around to avoid stripping libthread_db-1.0.so for debugging
|
||||||
|
%if "%{?stage1}" != "1"
|
||||||
chmod -x %{buildroot}/%{slibdir}/libthread_db-1.0.so
|
chmod -x %{buildroot}/%{slibdir}/libthread_db-1.0.so
|
||||||
|
%endif
|
||||||
%else
|
%else
|
||||||
rm -rf %{buildroot}%{_sysconfdir}
|
rm -rf %{buildroot}%{_sysconfdir}
|
||||||
rm -rf %{buildroot}%{_infodir}
|
rm -rf %{buildroot}%{_infodir}
|
||||||
@ -604,8 +603,10 @@ rm -f %{buildroot}%{_prefix}/%{_target_platform}/%{_sysconfdir}/localtime
|
|||||||
rm -f %{buildroot}%{_localstatedir}/db/Makefile
|
rm -f %{buildroot}%{_localstatedir}/db/Makefile
|
||||||
rm -f %{buildroot}%{_prefix}/%{_target_platform}/%{_sysconfdir}/ld.so.cache
|
rm -f %{buildroot}%{_prefix}/%{_target_platform}/%{_sysconfdir}/ld.so.cache
|
||||||
# work around to avoid stripping libthread_db-1.0.so for debugging
|
# work around to avoid stripping libthread_db-1.0.so for debugging
|
||||||
|
%if "%{?stage1}" != "1"
|
||||||
chmod -x %{buildroot}/%{glibc_libdir}/libthread_db-1.0.so
|
chmod -x %{buildroot}/%{glibc_libdir}/libthread_db-1.0.so
|
||||||
%endif
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
%if "%{multilib}" == "1"
|
%if "%{multilib}" == "1"
|
||||||
cp %{buildroot}%{glibc_includedir}/gnu/stubs-32.h %{buildroot}/
|
cp %{buildroot}%{glibc_includedir}/gnu/stubs-32.h %{buildroot}/
|
||||||
@ -898,12 +899,15 @@ exit 0
|
|||||||
%{glibc_prefix}/sbin/*
|
%{glibc_prefix}/sbin/*
|
||||||
%{glibc_libdir}/*
|
%{glibc_libdir}/*
|
||||||
%{glibc_prefix}/share/*
|
%{glibc_prefix}/share/*
|
||||||
|
%{glibc_prefix}/%{_localstatedir}/db/Makefile
|
||||||
%endif
|
%endif
|
||||||
%{glibc_includedir}/*
|
%{glibc_includedir}/*
|
||||||
%{glibc_prefix}/%{_localstatedir}/db/Makefile
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Mar 26 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.21-2mamba
|
||||||
|
- patch to prevent exhaustion of tls slots (vlc), see https://bugzilla.redhat.com/show_bug.cgi?id=1124987
|
||||||
|
|
||||||
* Mon Feb 09 2015 Automatic Build System <autodist@mambasoft.it> 2.21-1mamba
|
* Mon Feb 09 2015 Automatic Build System <autodist@mambasoft.it> 2.21-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user