automatic version update by autodist [release 2.68.2-1mamba;Sat Jun 05 2021]
This commit is contained in:
parent
f6405fe443
commit
82a6107eb0
24
glib-2.68.2-noisy-glib-compile-schemas.patch
Normal file
24
glib-2.68.2-noisy-glib-compile-schemas.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff --git i/gio/glib-compile-schemas.c w/gio/glib-compile-schemas.c
|
||||
index cfea042f8..1b2afe457 100644
|
||||
--- i/gio/glib-compile-schemas.c
|
||||
+++ w/gio/glib-compile-schemas.c
|
||||
@@ -1232,19 +1232,6 @@ parse_state_start_schema (ParseState *state,
|
||||
return;
|
||||
}
|
||||
|
||||
- if (path && (g_str_has_prefix (path, "/apps/") ||
|
||||
- g_str_has_prefix (path, "/desktop/") ||
|
||||
- g_str_has_prefix (path, "/system/")))
|
||||
- {
|
||||
- gchar *message = NULL;
|
||||
- message = g_strdup_printf (_("Warning: Schema “%s” has path “%s”. "
|
||||
- "Paths starting with "
|
||||
- "“/apps/”, “/desktop/” or “/system/” are deprecated."),
|
||||
- id, path);
|
||||
- g_printerr ("%s\n", message);
|
||||
- g_free (message);
|
||||
- }
|
||||
-
|
||||
state->schema_state = schema_state_new (path, gettext_domain,
|
||||
extends, extends_name, list_of);
|
||||
|
94
glib.spec
94
glib.spec
@ -5,7 +5,7 @@
|
||||
%endif
|
||||
%define majver %(echo %version | cut -d. -f 1-2)
|
||||
Name: glib
|
||||
Version: 2.68.1
|
||||
Version: 2.68.2
|
||||
Release: 1mamba
|
||||
Epoch: 2
|
||||
Summary: A handy library of utility functions
|
||||
@ -19,15 +19,16 @@ Source0: https://download.gnome.org/sources/glib/%{majver}/glib-%{version}
|
||||
Source1: glib.sh
|
||||
Source2: glib.csh
|
||||
Patch0: glib-2.36.1-fix-skype.patch
|
||||
Patch1: glib-2.68.2-noisy-glib-compile-schemas.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libelf-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libmount-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsysprof-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%if "%{stage1}" != "1"
|
||||
@ -58,7 +59,7 @@ Summary: GIMP Toolkit and GIMP Drawing Kit tools
|
||||
Group: System/Libraries
|
||||
Requires: libglib = %{epoch}:%{version}-%{release}
|
||||
Provides: glib-dconf
|
||||
Obsoletes: glib-dconf
|
||||
Obsoletes: glib-dconf < 2:2.68.2
|
||||
|
||||
%description tools
|
||||
Glib is a handy library of utility functions.
|
||||
@ -136,36 +137,27 @@ Requires: gtk-doc
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
#autoconf
|
||||
#sed -i "s|python3|python3.6|" meson.build
|
||||
|
||||
%patch1 -p1
|
||||
|
||||
# No surprise bundled libraries
|
||||
rm -rf glib/pcre
|
||||
rm -rf subprojects
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%meson \
|
||||
--default-library=both \
|
||||
-Dman=true \
|
||||
-Dgtk_doc=true \
|
||||
-Ddtrace=true \
|
||||
-Dsysprof=enabled \
|
||||
-Dglib_debug=disabled \
|
||||
-Dgtk_doc=true \
|
||||
%if "%{with_systemtap}" == "1"
|
||||
-Dsystemtap=true
|
||||
%endif
|
||||
|
||||
%meson_build
|
||||
# --default-library=both \
|
||||
|
||||
#% configure \
|
||||
#%if "%{with_systemtap}" == "1"
|
||||
# --enable-systemtap \
|
||||
#%else
|
||||
# --disable-systemtap \
|
||||
# --disable-dtrace \
|
||||
#%endif
|
||||
# --enable-static \
|
||||
#%if "%{stage1}" == "1"
|
||||
# %{LIBFFI_CFLAGS} \
|
||||
#%endif
|
||||
#%if "%{_build}" != "%{_host}"
|
||||
# --cache-file=config.cache
|
||||
#%endif
|
||||
%meson_build
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -181,30 +173,24 @@ rm -rf %{buildroot}%{_libdir}/gio/modules/*.a
|
||||
|
||||
%find_lang %{name}20
|
||||
|
||||
%ifarch x86_64_disabled
|
||||
# x86_64 lib64 support
|
||||
make clean
|
||||
export PKG_CONFIG_LIBDIR=%{_prefix}/lib/pkgconfig
|
||||
CC=%{_target_platform}-gcc \
|
||||
CFLAGS="%{optflags} -m32" \
|
||||
CXXLAGS="%{optflags} -m32" \
|
||||
%configure --prefix=%{_prefix} --libdir=%{_prefix}/lib
|
||||
make
|
||||
make install DESTDIR=`pwd`/lib32
|
||||
cp -a lib32/%{_prefix}/lib %{buildroot}%{_prefix}/
|
||||
%endif
|
||||
|
||||
install -d -m0755 %{buildroot}%{_sysconfdir}/prelink.conf.d
|
||||
cat > %{buildroot}%{_sysconfdir}/prelink.conf.d/glib.conf << _EOF
|
||||
-b %{_bindir}/glib-compile-resources
|
||||
_EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n libglib -p /sbin/ldconfig
|
||||
%postun -n libglib -p /sbin/ldconfig
|
||||
|
||||
%transfiletriggerin -n glib-tools -- %{_libdir}/gio/modules
|
||||
gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules &> /dev/null || :
|
||||
|
||||
%transfiletriggerpostun -n glib-tools -- %{_libdir}/gio/modules
|
||||
gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules &> /dev/null || :
|
||||
|
||||
%transfiletriggerin -n glib-tools -- %{_datadir}/glib-2.0/schemas
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
|
||||
%transfiletriggerpostun -n glib-tools -- %{_datadir}/glib-2.0/schemas
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
||||
|
||||
%files gettextize
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/%{name}-gettextize
|
||||
@ -215,12 +201,12 @@ _EOF
|
||||
%files tools
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/profile.d/glib.*sh
|
||||
#%{_sysconfdir}/prelink.conf.d/glib.conf
|
||||
%{_bindir}/gdbus
|
||||
%{_bindir}/gsettings
|
||||
%{_bindir}/gapplication
|
||||
%{_bindir}/gio
|
||||
#%{_bindir}/gio-launch-desktop
|
||||
%{_bindir}/glib-compile-resources
|
||||
%{_bindir}/gio-querymodules
|
||||
%{_bindir}/gresource
|
||||
%{_bindir}/gtester
|
||||
%{_bindir}/gtester-report
|
||||
@ -228,13 +214,16 @@ _EOF
|
||||
%{_bindir}/%{name}-mkenums
|
||||
%{_bindir}/gobject-query
|
||||
%{_bindir}/gdbus-codegen
|
||||
%{_bindir}/glib-compile-resources
|
||||
%{_bindir}/glib-compile-schemas
|
||||
%dir %{_datadir}/glib-2.0
|
||||
%dir %{_datadir}/glib-2.0/schemas
|
||||
%{_datadir}/glib-2.0/schemas/gschema.dtd
|
||||
%{_datadir}/bash-completion/completions/gdbus
|
||||
%{_datadir}/bash-completion/completions/gsettings
|
||||
|
||||
%files -n libglib -f %{name}20.lang
|
||||
%defattr(-,root,root)
|
||||
%{_sysconfdir}/prelink.conf.d/glib.conf
|
||||
%{_bindir}/gio-querymodules
|
||||
%{_libdir}/libglib-2.0.so.*
|
||||
%{_libdir}/libgmodule-2.0.so.*
|
||||
%{_libdir}/libgobject-2.0.so.*
|
||||
@ -244,10 +233,6 @@ _EOF
|
||||
#%{_libdir}/gio/modules/libgiofam.la
|
||||
#%{_libdir}/gio/modules/libgiofam.so
|
||||
#%endif
|
||||
%{_bindir}/glib-compile-schemas
|
||||
%dir %{_datadir}/glib-2.0
|
||||
%dir %{_datadir}/glib-2.0/schemas
|
||||
%{_datadir}/glib-2.0/schemas/gschema.dtd
|
||||
|
||||
%files -n libglib-devel
|
||||
%defattr(-,root,root)
|
||||
@ -273,9 +258,9 @@ _EOF
|
||||
%{_libdir}/pkgconfig/*
|
||||
%{_mandir}/man1/*
|
||||
|
||||
%files -n libglib-static
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libg*.a
|
||||
#%files -n libglib-static
|
||||
#%defattr(-,root,root)
|
||||
#%{_libdir}/libg*.a
|
||||
|
||||
%files -n python-glib
|
||||
%defattr(-,root,root)
|
||||
@ -296,6 +281,9 @@ _EOF
|
||||
%{_datadir}/gtk-doc/html/gobject/*
|
||||
|
||||
%changelog
|
||||
* Sat Jun 05 2021 Automatic Build System <autodist@mambasoft.it> 2.68.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Apr 09 2021 Automatic Build System <autodist@mambasoft.it> 2.68.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
@ -613,7 +601,7 @@ _EOF
|
||||
* Mon Oct 27 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.3-1qilnx
|
||||
- new version rebuild
|
||||
|
||||
* Wed May 5 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.2.1-3qilnx
|
||||
* Mon May 5 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.2.1-3qilnx
|
||||
- fixed ldconfig execution (post -n libxxx instead of a generic post)
|
||||
|
||||
* Wed Apr 16 2003 Mirko Cortillaro <mirko.cortillaro@qinet.it>
|
||||
|
Loading…
Reference in New Issue
Block a user