integrate python-glib into glib-tools [release 2.80.0-2mamba;Sun Apr 07 2024]
This commit is contained in:
parent
0bff03aab5
commit
7780328aa0
@ -1,16 +0,0 @@
|
|||||||
--- a/configure.ac 2013-04-23 10:59:21.284914117 +0100
|
|
||||||
+++ b/configure.ac 2013-04-23 10:58:59.891664217 +0100
|
|
||||||
@@ -528,6 +528,13 @@
|
|
||||||
m4_ifdef([LT_OUTPUT], [LT_OUTPUT])
|
|
||||||
|
|
||||||
|
|
||||||
+if test "x$GCC" = "xyes"; then
|
|
||||||
+ case " $CFLAGS " in
|
|
||||||
+ *[[\ \ ]]-Wall[[\ \ ]]*) ;;
|
|
||||||
+ *) CFLAGS="$CFLAGS -Wall" ;;
|
|
||||||
+ esac
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
AS_IF([test "$glib_native_win32" = "yes"], [
|
|
||||||
if test x$enable_static = xyes -a x$enable_shared = xyes; then
|
|
||||||
AC_MSG_ERROR([Can not build both shared and static at the same time on Windows.])
|
|
78
glib.spec
78
glib.spec
@ -5,8 +5,8 @@
|
|||||||
%endif
|
%endif
|
||||||
%define majver %(echo %version | cut -d. -f 1-2)
|
%define majver %(echo %version | cut -d. -f 1-2)
|
||||||
Name: glib
|
Name: glib
|
||||||
Version: 2.78.4
|
Version: 2.80.0
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Summary: A handy library of utility functions
|
Summary: A handy library of utility functions
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
@ -17,7 +17,6 @@ URL: https://www.gnome.org
|
|||||||
Source0: https://download.gnome.org/sources/glib/%{majver}/glib-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/glib/%{majver}/glib-%{version}.tar.xz
|
||||||
Source1: glib.sh
|
Source1: glib.sh
|
||||||
Source2: glib.csh
|
Source2: glib.csh
|
||||||
Patch0: glib-2.36.1-fix-skype.patch
|
|
||||||
Patch1: glib-2.68.2-noisy-glib-compile-schemas.patch
|
Patch1: glib-2.68.2-noisy-glib-compile-schemas.patch
|
||||||
Patch2: glib-2.74.4-include_errno.patch
|
Patch2: glib-2.74.4-include_errno.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
@ -60,6 +59,7 @@ Group: System/Libraries
|
|||||||
Requires: libglib = %{epoch}:%{version}-%{release}
|
Requires: libglib = %{epoch}:%{version}-%{release}
|
||||||
Provides: glib-dconf
|
Provides: glib-dconf
|
||||||
Obsoletes: glib-dconf < 2:2.68.2
|
Obsoletes: glib-dconf < 2:2.68.2
|
||||||
|
Obsoletes: python-glib <= 2:2.80.0-1mamba
|
||||||
|
|
||||||
%description tools
|
%description tools
|
||||||
Glib is a handy library of utility functions.
|
Glib is a handy library of utility functions.
|
||||||
@ -100,17 +100,6 @@ Requires: libglib-devel = %{epoch}:%{version}-%{release}
|
|||||||
Static libraries for the support library for the GIMP's X libraries, which are available as public libraries.
|
Static libraries for the support library for the GIMP's X libraries, which are available as public libraries.
|
||||||
GLIB includes generally useful data structures.
|
GLIB includes generally useful data structures.
|
||||||
|
|
||||||
%package -n python-glib
|
|
||||||
Summary: Python bindings for glib
|
|
||||||
Group: System/Libraries
|
|
||||||
Requires: libglib = %{epoch}:%{version}-%{release}
|
|
||||||
|
|
||||||
%description -n python-glib
|
|
||||||
Glib is a handy library of utility functions.
|
|
||||||
This C library is designed to solve some portability problems and provide other useful functionality which most programs require.
|
|
||||||
|
|
||||||
This package contains the python bindings.
|
|
||||||
|
|
||||||
%package gettextize
|
%package gettextize
|
||||||
Summary: Gettextize replacement
|
Summary: Gettextize replacement
|
||||||
Group: Development/Tools
|
Group: Development/Tools
|
||||||
@ -136,7 +125,6 @@ Requires: gtk-doc
|
|||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
#%patch0 -p1
|
|
||||||
%patch 1 -p1
|
%patch 1 -p1
|
||||||
%patch 2 -p1
|
%patch 2 -p1
|
||||||
|
|
||||||
@ -167,8 +155,6 @@ mkdir -p %{buildroot}%{_sysconfdir}/profile.d
|
|||||||
install -pm 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d
|
install -pm 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/profile.d
|
||||||
install -pm 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d
|
install -pm 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/profile.d
|
||||||
|
|
||||||
#chmod 644 %{buildroot}%{_sysconfdir}/bash_completion.d/*.sh
|
|
||||||
|
|
||||||
rm -rf %{buildroot}%{_libdir}/gio/modules/*.a
|
rm -rf %{buildroot}%{_libdir}/gio/modules/*.a
|
||||||
|
|
||||||
%find_lang %{name}20
|
%find_lang %{name}20
|
||||||
@ -219,7 +205,17 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%dir %{_datadir}/glib-2.0
|
%dir %{_datadir}/glib-2.0
|
||||||
%dir %{_datadir}/glib-2.0/schemas
|
%dir %{_datadir}/glib-2.0/schemas
|
||||||
%{_datadir}/glib-2.0/schemas/gschema.dtd
|
%{_datadir}/glib-2.0/schemas/gschema.dtd
|
||||||
|
%{_datadir}/gdb/auto-load/usr/%{_lib}/libglib-2.0.so.*.py
|
||||||
|
%{_datadir}/gdb/auto-load/usr/%{_lib}/libgobject-2.0.so.*.py
|
||||||
|
%dir %{_datadir}/glib-2.0/gdb
|
||||||
|
%{_datadir}/glib-2.0/gdb/glib_gdb.py
|
||||||
|
%{_datadir}/glib-2.0/gdb/gobject_gdb.py
|
||||||
|
%dir %{_datadir}/glib-2.0/codegen
|
||||||
|
%{_datadir}/glib-2.0/codegen/*.py*
|
||||||
|
%{_datadir}/bash-completion/completions/gapplication
|
||||||
%{_datadir}/bash-completion/completions/gdbus
|
%{_datadir}/bash-completion/completions/gdbus
|
||||||
|
%{_datadir}/bash-completion/completions/gio
|
||||||
|
%{_datadir}/bash-completion/completions/gresource
|
||||||
%{_datadir}/bash-completion/completions/gsettings
|
%{_datadir}/bash-completion/completions/gsettings
|
||||||
|
|
||||||
%files -n libglib -f %{name}20.lang
|
%files -n libglib -f %{name}20.lang
|
||||||
@ -230,25 +226,38 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%{_libdir}/libgthread-2.0.so.*
|
%{_libdir}/libgthread-2.0.so.*
|
||||||
%{_libdir}/libgio-2.0.so.*
|
%{_libdir}/libgio-2.0.so.*
|
||||||
%{_libexecdir}/gio-launch-desktop
|
%{_libexecdir}/gio-launch-desktop
|
||||||
#%if "%{stage1}" != "1"
|
%{_libdir}/girepository-1.0/GIRepository-3.0.typelib
|
||||||
#%{_libdir}/gio/modules/libgiofam.la
|
%{_libdir}/girepository-1.0/GLib-2.0.typelib
|
||||||
#%{_libdir}/gio/modules/libgiofam.so
|
%{_libdir}/girepository-1.0/GLibUnix-2.0.typelib
|
||||||
#%endif
|
%{_libdir}/girepository-1.0/GModule-2.0.typelib
|
||||||
|
%{_libdir}/girepository-1.0/GObject-2.0.typelib
|
||||||
|
%{_libdir}/girepository-1.0/Gio-2.0.typelib
|
||||||
|
%{_libdir}/girepository-1.0/GioUnix-2.0.typelib
|
||||||
|
%{_libdir}/libgirepository-2.0.so.*
|
||||||
|
%doc LICENSES
|
||||||
|
|
||||||
%files -n libglib-devel
|
%files -n libglib-devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_includedir}/%{name}-?.?
|
%dir %{_includedir}/%{name}-?.?
|
||||||
%{_includedir}/%{name}-?.?/*
|
%{_includedir}/%{name}-?.?/*
|
||||||
%{_includedir}/gio-unix-?.?/*gio/*.h
|
%{_includedir}/gio-unix-?.?/*gio/*.h
|
||||||
|
%{_bindir}/gi-compile-repository
|
||||||
|
%{_bindir}/gi-decompile-typelib
|
||||||
|
%{_bindir}/gi-inspect-typelib
|
||||||
%{_libdir}/%{name}-?.?/include/%{name}config.h
|
%{_libdir}/%{name}-?.?/include/%{name}config.h
|
||||||
%{_libdir}/libglib-2.0.so
|
%{_libdir}/libglib-2.0.so
|
||||||
%{_libdir}/libgmodule-2.0.so
|
%{_libdir}/libgmodule-2.0.so
|
||||||
%{_libdir}/libgobject-2.0.so
|
%{_libdir}/libgobject-2.0.so
|
||||||
%{_libdir}/libgthread-2.0.so
|
%{_libdir}/libgthread-2.0.so
|
||||||
%{_libdir}/libgio-2.0.so
|
%{_libdir}/libgio-2.0.so
|
||||||
%{_datadir}/bash-completion/completions/gapplication
|
%{_libdir}/libgirepository-2.0.so
|
||||||
%{_datadir}/bash-completion/completions/gresource
|
%{_datadir}/gir-1.0/GIRepository-3.0.gir
|
||||||
%{_datadir}/bash-completion/completions/gio
|
%{_datadir}/gir-1.0/GLib-2.0.gir
|
||||||
|
%{_datadir}/gir-1.0/GLibUnix-2.0.gir
|
||||||
|
%{_datadir}/gir-1.0/GModule-2.0.gir
|
||||||
|
%{_datadir}/gir-1.0/GObject-2.0.gir
|
||||||
|
%{_datadir}/gir-1.0/Gio-2.0.gir
|
||||||
|
%{_datadir}/gir-1.0/GioUnix-2.0.gir
|
||||||
%{_datadir}/gettext/its/gschema.*
|
%{_datadir}/gettext/its/gschema.*
|
||||||
%{_datadir}/aclocal/glib-?.?.m4
|
%{_datadir}/aclocal/glib-?.?.m4
|
||||||
%{_datadir}/aclocal/gsettings.m4
|
%{_datadir}/aclocal/gsettings.m4
|
||||||
@ -264,27 +273,18 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_libdir}/libg*.a
|
%{_libdir}/libg*.a
|
||||||
|
|
||||||
%files -n python-glib
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_datadir}/gdb/auto-load/usr/%{_lib}/libglib-2.0.so.*.py
|
|
||||||
%{_datadir}/gdb/auto-load/usr/%{_lib}/libgobject-2.0.so.*.py
|
|
||||||
%dir %{_datadir}/glib-2.0/gdb
|
|
||||||
%{_datadir}/glib-2.0/gdb/glib_gdb.py
|
|
||||||
%{_datadir}/glib-2.0/gdb/gobject_gdb.py
|
|
||||||
%dir %{_datadir}/glib-2.0/codegen
|
|
||||||
%{_datadir}/glib-2.0/codegen/*.py*
|
|
||||||
|
|
||||||
%files apidocs
|
%files apidocs
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%dir %{_datadir}/gtk-doc/html/glib
|
|
||||||
%{_datadir}/gtk-doc/html/glib/*
|
|
||||||
%{_datadir}/gtk-doc/html/gio/*
|
|
||||||
%dir %{_datadir}/gtk-doc/html/gobject
|
|
||||||
%{_datadir}/gtk-doc/html/gobject/*
|
|
||||||
%dir %{_docdir}/glib-2.0
|
%dir %{_docdir}/glib-2.0
|
||||||
%{_docdir}/glib-2.0/*
|
%{_docdir}/glib-2.0/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Apr 07 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.80.0-2mamba
|
||||||
|
- integrate python-glib into glib-tools
|
||||||
|
|
||||||
|
* Fri Mar 08 2024 Automatic Build System <autodist@openmamba.org> 2.80.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Mon Jan 22 2024 Automatic Build System <autodist@openmamba.org> 2.78.4-1mamba
|
* Mon Jan 22 2024 Automatic Build System <autodist@openmamba.org> 2.78.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user