rebuilt with python3 3.11 [release 0.5.80-2mamba;Thu Feb 13 2025]
This commit is contained in:
parent
e52b15973f
commit
5c03bd26d6
@ -1,39 +0,0 @@
|
|||||||
--- glaxnimate-0.5.1/external/Qt-Color-Widgets/cmake/install.cmake.orig 2022-09-12 19:28:44.100673084 +0200
|
|
||||||
+++ glaxnimate-0.5.1/external/Qt-Color-Widgets/cmake/install.cmake 2022-09-12 19:29:15.798465804 +0200
|
|
||||||
@@ -11,8 +11,8 @@
|
|
||||||
EXPORT ${i_target_name}
|
|
||||||
RUNTIME DESTINATION bin
|
|
||||||
INCLUDES DESTINATION include
|
|
||||||
- ARCHIVE DESTINATION lib
|
|
||||||
- LIBRARY DESTINATION lib)
|
|
||||||
+ ARCHIVE DESTINATION lib64
|
|
||||||
+ LIBRARY DESTINATION lib64)
|
|
||||||
|
|
||||||
install (DIRECTORY include/
|
|
||||||
DESTINATION include
|
|
||||||
@@ -30,7 +30,7 @@
|
|
||||||
|
|
||||||
install(
|
|
||||||
EXPORT ${i_target_name}
|
|
||||||
- DESTINATION lib/cmake/${i_target_name}${i_target_output_suffix}
|
|
||||||
+ DESTINATION lib64/cmake/${i_target_name}${i_target_output_suffix}
|
|
||||||
FILE "${i_target_name}${i_target_output_suffix}.cmake"
|
|
||||||
COMPONENT Devel)
|
|
||||||
|
|
||||||
@@ -55,7 +55,7 @@
|
|
||||||
@ONLY
|
|
||||||
)
|
|
||||||
|
|
||||||
- set(ConfigPackageLocation "lib/cmake/${i_target_name}${i_target_output_suffix}")
|
|
||||||
+ set(ConfigPackageLocation "lib64/cmake/${i_target_name}${i_target_output_suffix}")
|
|
||||||
install(EXPORT ${i_target_name}
|
|
||||||
FILE
|
|
||||||
"${CMAKE_BASE_FILE_NAME}${CMAKE_FILE_OUTPUT_SUFFIX}-targets.cmake"
|
|
||||||
@@ -83,6 +83,6 @@
|
|
||||||
install(FILES
|
|
||||||
${CMAKE_CURRENT_BINARY_DIR}/${i_target_name}${i_target_output_suffix}.pc
|
|
||||||
DESTINATION
|
|
||||||
- lib/pkgconfig
|
|
||||||
+ lib64/pkgconfig
|
|
||||||
)
|
|
||||||
endfunction (install_project)
|
|
@ -1,13 +0,0 @@
|
|||||||
--- glaxnimate-0.5.1/CMakeLists.txt.orig 2022-09-12 12:28:42.619124097 +0200
|
|
||||||
+++ glaxnimate-0.5.1/CMakeLists.txt 2022-09-12 12:28:49.835089027 +0200
|
|
||||||
@@ -89,8 +89,8 @@
|
|
||||||
|
|
||||||
# Qt
|
|
||||||
#find_package(Qt5Qml QUIET)
|
|
||||||
-set(QT_VERSION_MAJOR 5)
|
|
||||||
-find_package(QT NAMES Qt5 Qt6 COMPONENTS Core QUIET)
|
|
||||||
+set(QT_VERSION_MAJOR 6)
|
|
||||||
+find_package(QT NAMES Qt6 COMPONENTS Core QUIET)
|
|
||||||
find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Widgets Xml UiTools Concurrent Network Svg REQUIRED)
|
|
||||||
message(STATUS "Using Qt ${QT_VERSION_MAJOR}")
|
|
||||||
|
|
111
glaxnimate.spec
111
glaxnimate.spec
@ -1,109 +1,100 @@
|
|||||||
Name: glaxnimate
|
Name: glaxnimate
|
||||||
Version: 0.5.4
|
Version: 0.5.80
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A simple vector graphics animation program
|
Summary: A simple vector graphics animation program
|
||||||
Group: Graphical Desktop/Applications/Graphics
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://glaxnimate.mattbas.org/
|
URL: https://apps.kde.org/it/glaxnimate/
|
||||||
Source: https://gitlab.com/mattbas/glaxnimate.git/%{version}/glaxnimate-%{version}.tar.bz2
|
Source: https://invent.kde.org/graphics/glaxnimate.git/v%{version}/glaxnimate-%{version}.tar.bz2
|
||||||
Patch0: glaxnimate-0.5.1-qt6.patch
|
|
||||||
Patch1: glaxnimate-0.5.1-cmake-install-libdir.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libQt5Svg-devel
|
BuildRequires: libQt6Concurrent
|
||||||
|
BuildRequires: libQt6Core
|
||||||
|
BuildRequires: libQt6DBus
|
||||||
|
BuildRequires: libQt6Gui
|
||||||
|
BuildRequires: libQt6Network
|
||||||
|
BuildRequires: libQt6OpenGL
|
||||||
|
BuildRequires: libQt6Widgets
|
||||||
|
BuildRequires: libQt6Xml
|
||||||
BuildRequires: libarchive-devel
|
BuildRequires: libarchive-devel
|
||||||
BuildRequires: libavcodec-ffmpeg-devel
|
BuildRequires: libavcodec-devel
|
||||||
BuildRequires: libavformat-ffmpeg-devel
|
BuildRequires: libavformat-devel
|
||||||
BuildRequires: libavutil-ffmpeg-devel
|
BuildRequires: libavutil-devel
|
||||||
BuildRequires: libgcc
|
BuildRequires: libgcc
|
||||||
BuildRequires: libglvnd-devel
|
BuildRequires: libglvnd-devel
|
||||||
|
BuildRequires: libkf6-breeze-icons-devel
|
||||||
|
BuildRequires: libkf6-karchive-devel
|
||||||
|
BuildRequires: libkf6-kcolorscheme-devel
|
||||||
|
BuildRequires: libkf6-kcompletion-devel
|
||||||
|
BuildRequires: libkf6-kconfig-devel
|
||||||
|
BuildRequires: libkf6-kconfigwidgets-devel
|
||||||
|
BuildRequires: libkf6-kcoreaddons-devel
|
||||||
|
BuildRequires: libkf6-kcrash-devel
|
||||||
|
BuildRequires: libkf6-ki18n-devel
|
||||||
|
BuildRequires: libkf6-kiconthemes-devel
|
||||||
|
BuildRequires: libkf6-kwidgetsaddons-devel
|
||||||
|
BuildRequires: libkf6-kxmlgui-devel
|
||||||
BuildRequires: libpotrace-devel
|
BuildRequires: libpotrace-devel
|
||||||
BuildRequires: libpython310-devel
|
BuildRequires: libpython3-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libswscale-ffmpeg-devel
|
BuildRequires: libswscale-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: qt5-qtbase-devel
|
BuildRequires: qt6-qtsvg-devel
|
||||||
|
BuildRequires: qt6-qttools-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
|
Obsoletes: libQtColorWidgets-Qt6 <= 0.5.4-1mamba
|
||||||
|
Obsoletes: libQtColorWidgets-Qt6-devel <= 0.5.4-1mamba
|
||||||
|
|
||||||
%description
|
%description
|
||||||
A simple vector graphics animation program.
|
A simple vector graphics animation program.
|
||||||
|
|
||||||
%package -n libQtColorWidgets-Qt6
|
|
||||||
Group: System/Libraries
|
|
||||||
Summary: Shared libraries for %{name}
|
|
||||||
|
|
||||||
%description -n libQtColorWidgets-Qt6
|
|
||||||
A user-friendly color dialog and several color-related widgets for Qt6.
|
|
||||||
This package contains shared libraries for %{name}.
|
|
||||||
|
|
||||||
%package -n libQtColorWidgets-Qt6-devel
|
|
||||||
Group: Development/Libraries
|
|
||||||
Summary: Development files for %{name}
|
|
||||||
Requires: libQtColorWidgets-Qt6 = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
|
|
||||||
%description -n libQtColorWidgets-Qt6-devel
|
|
||||||
This package contains libraries and header files for developing applications that use %{name}.
|
|
||||||
|
|
||||||
%debug_package
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#-D -T
|
#-D -T
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
#%patch 0 -p1
|
|
||||||
#%ifarch x86_64 aarch64
|
|
||||||
#%patch 1 -p1
|
|
||||||
#%endif
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
#:<< _EOF
|
#:<< _EOF
|
||||||
%cmake -d build
|
%cmake -d build \
|
||||||
|
-DBUILD_WITH_QT6=ON \
|
||||||
|
-DPython3_EXECUTABLE=%{__python3}
|
||||||
|
|
||||||
%make
|
%make
|
||||||
make translations VERBOSE=1
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
%makeinstall -C build
|
%makeinstall -C build
|
||||||
%makeinstall -C build/external/Qt-Color-Widgets
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
%post -n libQtColorWidgets-Qt6 -p /sbin/ldconfig
|
%files -f %{name}.lang
|
||||||
%postun -n libQtColorWidgets-Qt6 -p /sbin/ldconfig
|
|
||||||
|
|
||||||
%files
|
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_bindir}/glaxnimate
|
%{_bindir}/glaxnimate
|
||||||
%{_datadir}/applications/org.mattbas.Glaxnimate.desktop
|
%{_datadir}/applications/org.kde.glaxnimate.desktop
|
||||||
%{_datadir}/metainfo/org.mattbas.Glaxnimate.metainfo.xml
|
%{_metainfodir}/org.kde.glaxnimate.metainfo.xml
|
||||||
|
%{_datadir}/config.kcfg/glaxnimate_settings.kcfg
|
||||||
%dir %{_datadir}/glaxnimate
|
%dir %{_datadir}/glaxnimate
|
||||||
%dir %{_datadir}/glaxnimate/glaxnimate
|
%dir %{_datadir}/glaxnimate/glaxnimate
|
||||||
%{_datadir}/glaxnimate/glaxnimate/*
|
%{_datadir}/glaxnimate/glaxnimate/*
|
||||||
%{_datadir}/icons/hicolor/*/apps/*.png
|
%{_datadir}/icons/hicolor/*/apps/*.png
|
||||||
%{_datadir}/icons/hicolor/scalable/apps/*.svg
|
%{_datadir}/icons/hicolor/scalable/apps/*.svg
|
||||||
|
%doc LICENSES
|
||||||
%files -n libQtColorWidgets-Qt6
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/libQtColorWidgets.so.*
|
|
||||||
%doc LICENSES external/Qt-Color-Widgets/LICENSE-EXCEPTION
|
|
||||||
|
|
||||||
%files -n libQtColorWidgets-Qt6-devel
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%dir %{_includedir}/QtColorWidgets
|
|
||||||
%{_includedir}/QtColorWidgets/*
|
|
||||||
%dir %{_libdir}/cmake/QtColorWidgets
|
|
||||||
%{_libdir}/cmake/QtColorWidgets/QtColorWidgets*.cmake
|
|
||||||
%{_libdir}/cmake/QtColorWidgets/qtcolorwidgets-*.cmake
|
|
||||||
%{_libdir}/libQtColorWidgets.so
|
|
||||||
%{_libdir}/pkgconfig/QtColorWidgets.pc
|
|
||||||
#%doc README.md
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Feb 13 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.80-2mamba
|
||||||
|
- rebuilt with python3 3.11
|
||||||
|
|
||||||
|
* Wed Feb 12 2025 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.80-1mamba
|
||||||
|
- update to 0.5.80
|
||||||
|
|
||||||
* Sat Sep 09 2023 Automatic Build System <autodist@mambasoft.it> 0.5.4-1mamba
|
* Sat Sep 09 2023 Automatic Build System <autodist@mambasoft.it> 0.5.4-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user