provide external libQtColorWidgets.so.2 [release 0.5.1-2mamba;Mon Sep 12 2022]
This commit is contained in:
parent
9bf407c11d
commit
01a414cd9a
@ -1,2 +1,4 @@
|
|||||||
# glaxnimate
|
# glaxnimate
|
||||||
|
|
||||||
|
A simple vector graphics animation program.
|
||||||
|
|
||||||
|
39
glaxnimate-0.5.1-cmake-install-libdir.patch
Normal file
39
glaxnimate-0.5.1-cmake-install-libdir.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
--- glaxnimate-0.5.1/external/Qt-Color-Widgets/cmake/install.cmake.orig 2022-09-12 19:28:44.100673084 +0200
|
||||||
|
+++ glaxnimate-0.5.1/external/Qt-Color-Widgets/cmake/install.cmake 2022-09-12 19:29:15.798465804 +0200
|
||||||
|
@@ -11,8 +11,8 @@
|
||||||
|
EXPORT ${i_target_name}
|
||||||
|
RUNTIME DESTINATION bin
|
||||||
|
INCLUDES DESTINATION include
|
||||||
|
- ARCHIVE DESTINATION lib
|
||||||
|
- LIBRARY DESTINATION lib)
|
||||||
|
+ ARCHIVE DESTINATION lib64
|
||||||
|
+ LIBRARY DESTINATION lib64)
|
||||||
|
|
||||||
|
install (DIRECTORY include/
|
||||||
|
DESTINATION include
|
||||||
|
@@ -30,7 +30,7 @@
|
||||||
|
|
||||||
|
install(
|
||||||
|
EXPORT ${i_target_name}
|
||||||
|
- DESTINATION lib/cmake/${i_target_name}${i_target_output_suffix}
|
||||||
|
+ DESTINATION lib64/cmake/${i_target_name}${i_target_output_suffix}
|
||||||
|
FILE "${i_target_name}${i_target_output_suffix}.cmake"
|
||||||
|
COMPONENT Devel)
|
||||||
|
|
||||||
|
@@ -55,7 +55,7 @@
|
||||||
|
@ONLY
|
||||||
|
)
|
||||||
|
|
||||||
|
- set(ConfigPackageLocation "lib/cmake/${i_target_name}${i_target_output_suffix}")
|
||||||
|
+ set(ConfigPackageLocation "lib64/cmake/${i_target_name}${i_target_output_suffix}")
|
||||||
|
install(EXPORT ${i_target_name}
|
||||||
|
FILE
|
||||||
|
"${CMAKE_BASE_FILE_NAME}${CMAKE_FILE_OUTPUT_SUFFIX}-targets.cmake"
|
||||||
|
@@ -83,6 +83,6 @@
|
||||||
|
install(FILES
|
||||||
|
${CMAKE_CURRENT_BINARY_DIR}/${i_target_name}${i_target_output_suffix}.pc
|
||||||
|
DESTINATION
|
||||||
|
- lib/pkgconfig
|
||||||
|
+ lib64/pkgconfig
|
||||||
|
)
|
||||||
|
endfunction (install_project)
|
13
glaxnimate-0.5.1-qt6.patch
Normal file
13
glaxnimate-0.5.1-qt6.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
--- glaxnimate-0.5.1/CMakeLists.txt.orig 2022-09-12 12:28:42.619124097 +0200
|
||||||
|
+++ glaxnimate-0.5.1/CMakeLists.txt 2022-09-12 12:28:49.835089027 +0200
|
||||||
|
@@ -89,8 +89,8 @@
|
||||||
|
|
||||||
|
# Qt
|
||||||
|
#find_package(Qt5Qml QUIET)
|
||||||
|
-set(QT_VERSION_MAJOR 5)
|
||||||
|
-find_package(QT NAMES Qt5 Qt6 COMPONENTS Core QUIET)
|
||||||
|
+set(QT_VERSION_MAJOR 6)
|
||||||
|
+find_package(QT NAMES Qt6 COMPONENTS Core QUIET)
|
||||||
|
find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Widgets Xml UiTools Concurrent Network Svg REQUIRED)
|
||||||
|
message(STATUS "Using Qt ${QT_VERSION_MAJOR}")
|
||||||
|
|
112
glaxnimate.spec
Normal file
112
glaxnimate.spec
Normal file
@ -0,0 +1,112 @@
|
|||||||
|
Name: glaxnimate
|
||||||
|
Version: 0.5.1
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A simple vector graphics animation program
|
||||||
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://glaxnimate.mattbas.org/
|
||||||
|
Source: https://gitlab.com/mattbas/glaxnimate.git/%{version}/glaxnimate-%{version}.tar.bz2
|
||||||
|
Patch0: glaxnimate-0.5.1-qt6.patch
|
||||||
|
Patch1: glaxnimate-0.5.1-cmake-install-libdir.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libarchive-devel
|
||||||
|
BuildRequires: libavcodec-ffmpeg-devel
|
||||||
|
BuildRequires: libavformat-ffmpeg-devel
|
||||||
|
BuildRequires: libavutil-ffmpeg-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
|
BuildRequires: libpotrace-devel
|
||||||
|
BuildRequires: libpython310-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libswscale-ffmpeg-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: qt6-qtbase-devel
|
||||||
|
BuildRequires: qt6-qtsvg-devel
|
||||||
|
BuildRequires: qt6-qttools-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: cmake
|
||||||
|
|
||||||
|
%description
|
||||||
|
A simple vector graphics animation program.
|
||||||
|
|
||||||
|
%package -n libQtColorWidgets-Qt6
|
||||||
|
Group: System/Libraries
|
||||||
|
Summary: Shared libraries for %{name}
|
||||||
|
|
||||||
|
%description -n libQtColorWidgets-Qt6
|
||||||
|
A user-friendly color dialog and several color-related widgets for Qt6.
|
||||||
|
This package contains shared libraries for %{name}.
|
||||||
|
|
||||||
|
%package -n libQtColorWidgets-Qt6-devel
|
||||||
|
Group: Development/Libraries
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: libQtColorWidgets-Qt6 = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n libQtColorWidgets-Qt6-devel
|
||||||
|
This package contains libraries and header files for developing applications that use %{name}.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
|
%patch0 -p1
|
||||||
|
%ifarch x86_64 aarch64
|
||||||
|
%patch1 -p1
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%build
|
||||||
|
#:<< _EOF
|
||||||
|
%cmake -d build
|
||||||
|
%make
|
||||||
|
#make translations VERBOSE=1
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall -C build
|
||||||
|
%makeinstall -C build/external/Qt-Color-Widgets
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n libQtColorWidgets-Qt6 -p /sbin/ldconfig
|
||||||
|
%postun -n libQtColorWidgets-Qt6 -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/glaxnimate
|
||||||
|
%{_datadir}/applications/glaxnimate.desktop
|
||||||
|
%dir %{_datadir}/glaxnimate
|
||||||
|
%dir %{_datadir}/glaxnimate/glaxnimate
|
||||||
|
%{_datadir}/glaxnimate/glaxnimate/*
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/glaxnimate.png
|
||||||
|
%{_datadir}/icons/hicolor/scalable/apps/glaxnimate.svg
|
||||||
|
%doc COPYING
|
||||||
|
|
||||||
|
%files -n libQtColorWidgets-Qt6
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libQtColorWidgets.so.*
|
||||||
|
%doc external/Qt-Color-Widgets/COPYING
|
||||||
|
|
||||||
|
%files -n libQtColorWidgets-Qt6-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_includedir}/QtColorWidgets
|
||||||
|
%{_includedir}/QtColorWidgets/*
|
||||||
|
%dir %{_libdir}/cmake/QtColorWidgets
|
||||||
|
%{_libdir}/cmake/QtColorWidgets/QtColorWidgets*.cmake
|
||||||
|
%{_libdir}/cmake/QtColorWidgets/qtcolorwidgets-*.cmake
|
||||||
|
%{_libdir}/libQtColorWidgets.so
|
||||||
|
%{_libdir}/pkgconfig/QtColorWidgets.pc
|
||||||
|
#%doc README.md
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Sep 12 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-2mamba
|
||||||
|
- provide external libQtColorWidgets.so.2
|
||||||
|
|
||||||
|
* Mon Sep 12 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.1-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user