59 lines
1.8 KiB
RPMSpec
59 lines
1.8 KiB
RPMSpec
Name: giws
|
|
Version: 1.2.1
|
|
Release: 2mamba
|
|
Summary: Generate C++ class wrappers to call Java methods/objects
|
|
Group: Development/Tools
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://www.scilab.org/products/other/giws
|
|
# http://forge.scilab.org/index.php/p/giws/downloads/182/get/
|
|
Source: giws-%{version}.tar.gz
|
|
License: CeCILL
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: libpython-devel
|
|
## AUTOBUILDREQ-END
|
|
Requires: python >= %python_version
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
Giws is basically doing the same stuff as SWIG but the opposite.
|
|
Calling Java from C/C++ can be tricky: JNI calls are complicated especially when dealing with non primivite types or arrays, performance issues must be kept in mind all the time, the code can be redundant (checking exceptions, checking returns of operations...).
|
|
Giws hides this complexity through a C++ class which wraps the Java class.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
|
|
%{__python} setup.py build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%{__python} setup.py install \
|
|
-O1 --skip-build \
|
|
--root="%{buildroot}" \
|
|
--install-headers=%{_includedir}/python \
|
|
--install-lib=%{python_sitearch}
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%{_bindir}/giws
|
|
%{python_sitearch}/*.py*
|
|
%{python_sitearch}/classRepresentation/*.py*
|
|
%{python_sitearch}/datatypes/*.py*
|
|
%{python_sitearch}/giws-%{version}-py%{python_version}.egg-info
|
|
%doc AUTHORS COPYING LICENSE
|
|
#BUGS README README-DEV TODO examples
|
|
|
|
%changelog
|
|
* Sat Aug 03 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.1-2mamba
|
|
- rebuilt with python 2.7
|
|
|
|
* Fri Feb 04 2011 gil <puntogil@libero.it> 1.2.1-1mamba
|
|
- package created by autospec
|