gitea/gitea.spec

116 lines
3.4 KiB
RPMSpec

Name: gitea
Version: 1.21.9
Release: 1mamba
Summary: Painless self-hosted Git service, community managed
Group: System/Servers
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://about.gitea.com/
Source: https+git://github.com/go-gitea/gitea.git/v%{version}/gitea-%{version}.tar.bz2
Source1: gitea.service
Source2: gitea.sysusers
Source3: gitea.tmpfiles
License: MIT
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libpam-devel
## AUTOBUILDREQ-END
BuildRequires: go
BuildRequires: nodejs
%description
Painless self-hosted all-in-one software development service, including Git hosting, code review, team collaboration, package registry and CI/CD.
#% debug_package
%prep
%setup -q
#-D -T
#:<< _EOF
# Workaround for poetry stuck in infinite processes
#poetry cache clear --all .
#make deps
%build
export EXTRA_GOFLAGS="-buildmode=pie -mod=readonly -modcacherw"
export LDFLAGS="-linkmode=external -compressdwarf=false -X \
'code.gitea.io/gitea/modules/setting.AppWorkPath=/var/lib/gitea/' \
-X 'code.gitea.io/gitea/modules/setting.CustomConf=%{_sysconfdir}/gitea/app.ini'"
export TAGS="bindata sqlite sqlite_unlock_notify pam"
# Replace chroma with custom fork adding RPM Spec support for syntax highlighting
go mod edit -replace github.com/alecthomas/chroma/v2="github.com/mambasoft/chroma/v2@v2.0.0-20240102115650-6fed1b9b0d99"
go mod tidy
%make -j1
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
#% makeinstall
install -D -m755 gitea %{buildroot}%{_bindir}/gitea
install -D -m644 %{SOURCE1} %{buildroot}%{_unitdir}/gitea.service
install -D -m644 %{SOURCE2} %{buildroot}%{_sysusersdir}/gitea.conf
install -D -m644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/gitea.conf
install -D -m644 custom/conf/app.example.ini %{buildroot}%{_sysconfdir}/gitea/app.ini
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%pre
%sysusers_create_package gitea %{SOURCE2}
%tmpfiles_create_package gitea %{SOURCE3}
:
%post
%systemd_post gitea
:
%preun
%systemd_preun gitea
:
%postun
%systemd_postun gitea
:
%files
%defattr(-,root,root)
%config(noreplace) %{_sysconfdir}/gitea/app.ini
%{_bindir}/gitea
%{_unitdir}/gitea.service
%{_sysusersdir}/gitea.conf
%{_tmpfilesdir}/gitea.conf
%doc LICENSE
%changelog
* Fri Mar 22 2024 Automatic Build System <autodist@openmamba.org> 1.21.9-1mamba
- automatic version update by autodist
* Wed Mar 13 2024 Automatic Build System <autodist@openmamba.org> 1.21.8-1mamba
- automatic version update by autodist
* Mon Feb 26 2024 Automatic Build System <autodist@openmamba.org> 1.21.7-1mamba
- automatic version update by autodist
* Fri Feb 23 2024 Automatic Build System <autodist@openmamba.org> 1.21.6-1mamba
- automatic version update by autodist
* Thu Feb 01 2024 Automatic Build System <autodist@openmamba.org> 1.21.5-1mamba
- automatic version update by autodist
* Wed Jan 17 2024 Automatic Build System <autodist@openmamba.org> 1.21.4-1mamba
- automatic version update by autodist
* Tue Jan 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.21.3-3mamba
- use custom chroma repository for rpm spec support
- gitea.service: don't set ProtectSystem=strict to fix usage of sendmail
* Thu Dec 28 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.21.3-2mamba
- fixed service file name
* Wed Dec 27 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.21.3-1mamba
- package created using the webbuild interface