automatic version update by autodist [release 1.4.3.5-1mamba;Wed Apr 25 2012]
This commit is contained in:
parent
6cc6c2ade1
commit
6b18ebe7f4
@ -1,2 +1,4 @@
|
|||||||
# git-cola
|
# git-cola
|
||||||
|
|
||||||
|
git-cola is a powerful GUI for git that gives you an easy way to interact with Git repositories.
|
||||||
|
|
||||||
|
15
git-cola-1.4.2.5-defapps.patch
Normal file
15
git-cola-1.4.2.5-defapps.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- cola-1.4.2.5/cola/models/main.py.orig 2010-11-12 15:54:13.000000000 +0100
|
||||||
|
+++ cola-1.4.2.5/cola/models/main.py 2010-11-12 15:55:07.000000000 +0100
|
||||||
|
@@ -167,9 +167,9 @@ from cola.models.observable import Obser
|
||||||
|
'cola_showoutput': 'errors',
|
||||||
|
'cola_tabwidth': 8,
|
||||||
|
'merge_keepbackup': True,
|
||||||
|
- 'diff_tool': os.getenv('GIT_DIFF_TOOL', 'xxdiff'),
|
||||||
|
- 'merge_tool': os.getenv('GIT_MERGE_TOOL', 'xxdiff'),
|
||||||
|
- 'gui_editor': os.getenv('VISUAL', os.getenv('EDITOR', 'gvim')),
|
||||||
|
+ 'diff_tool': os.getenv('GIT_DIFF_TOOL', 'kdiff3'),
|
||||||
|
+ 'merge_tool': os.getenv('GIT_MERGE_TOOL', 'kdiff3'),
|
||||||
|
+ 'gui_editor': os.getenv('VISUAL', os.getenv('EDITOR', 'kate -u')),
|
||||||
|
'gui_historybrowser': 'gitk',
|
||||||
|
}
|
||||||
|
|
12
git-cola-1.4.2.5-doc.patch
Normal file
12
git-cola-1.4.2.5-doc.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
--- cola-1.4.2.5/cola/resources.py.orig 2010-11-12 17:32:20.000000000 +0100
|
||||||
|
+++ cola-1.4.2.5/cola/resources.py 2010-11-12 17:34:35.000000000 +0100
|
||||||
|
@@ -21,7 +21,8 @@
|
||||||
|
|
||||||
|
def doc(*args):
|
||||||
|
"""Return a path relative to cola's /usr/share/doc/ directory"""
|
||||||
|
- return os.path.join(_prefix, 'share', 'doc', 'git-cola', *args)
|
||||||
|
+ from cola import version
|
||||||
|
+ return os.path.join(_prefix, 'share', 'doc', 'git-cola-' + version.version(), *args)
|
||||||
|
|
||||||
|
|
||||||
|
def html_docs():
|
106
git-cola.spec
Normal file
106
git-cola.spec
Normal file
@ -0,0 +1,106 @@
|
|||||||
|
Name: git-cola
|
||||||
|
Version: 1.4.3.5
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A highly caffeinated git GUI
|
||||||
|
Group: Graphical Desktop/Applications/Development
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Stefano Cotta Ramusino <stefano.cotta@openmamba.org>
|
||||||
|
URL: http://cola.tuxfamily.org/
|
||||||
|
Source: http://cola.tuxfamily.org/releases/cola-%{version}.tar.gz
|
||||||
|
Patch0: git-cola-1.4.2.5-doc.patch
|
||||||
|
Patch1: git-cola-1.4.2.5-defapps.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
BuildRequires: PyQt4-devel
|
||||||
|
BuildRequires: python
|
||||||
|
BuildRequires: python-pyinotify
|
||||||
|
BuildRequires: python-jsonpickle
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: python-setuptools
|
||||||
|
BuildRequires: desktop-file-utils
|
||||||
|
BuildRequires: asciidoc
|
||||||
|
BuildRequires: xmlto
|
||||||
|
BuildRequires: python-Sphinx
|
||||||
|
BuildRequires: gettext
|
||||||
|
BuildRequires: perl
|
||||||
|
Requires: git-gui
|
||||||
|
Requires: python >= %python_version
|
||||||
|
Requires: python-pyinotify
|
||||||
|
Requires: python-jsonpickle
|
||||||
|
Requires: PyQt4
|
||||||
|
Requires: kate
|
||||||
|
Requires: kdiff3
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
git-cola is a powerful GUI for git that gives you an easy way to interact with Git repositories.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n cola-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
CFLAGS="%{optflags}" %{__python} setup.py build
|
||||||
|
|
||||||
|
%make doc \
|
||||||
|
prefix=%{_prefix}
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%{__python} setup.py install \
|
||||||
|
-O1 --skip-build \
|
||||||
|
--root="%{buildroot}" \
|
||||||
|
--install-headers=%{_includedir}/python \
|
||||||
|
--install-lib=%{python_sitearch} \
|
||||||
|
--record=%{name}.filelist \
|
||||||
|
--prefix=%{_prefix} \
|
||||||
|
--standalone
|
||||||
|
|
||||||
|
# install documentation
|
||||||
|
make install-doc install-html \
|
||||||
|
DESTDIR=%{buildroot} \
|
||||||
|
prefix=%{_prefix}
|
||||||
|
|
||||||
|
sed -i "\,^%{_docdir},d" %{name}.filelist
|
||||||
|
mv %{buildroot}%{_docdir}/git-cola/* .
|
||||||
|
rm -fr %{buildroot}%{_docdir}/git-cola
|
||||||
|
|
||||||
|
# install desktop file
|
||||||
|
rm -f %{buildroot}%{_datadir}/applications/cola.desktop
|
||||||
|
desktop-file-install \
|
||||||
|
--delete-original \
|
||||||
|
--dir %{buildroot}%{_datadir}/applications \
|
||||||
|
share/applications/cola.desktop
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.filelist
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/git-cola
|
||||||
|
%{_mandir}/man1/git-cola.1.gz
|
||||||
|
%doc COPYRIGHT git-cola.txt html LICENSE README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Wed Apr 25 2012 Automatic Build System <autodist@mambasoft.it> 1.4.3.5-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 1.4.3.4-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Thu May 12 2011 Automatic Build System <autodist@mambasoft.it> 1.4.3.3-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Fri Nov 12 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.4.2.5-1mamba
|
||||||
|
- update to 1.4.2.5
|
||||||
|
- update patches
|
||||||
|
|
||||||
|
* Fri Jan 22 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.4.1.2-2mamba
|
||||||
|
- add missing requirements
|
||||||
|
|
||||||
|
* Tue Jan 19 2010 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 1.4.1.2-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user