automatic version update by autodist [release 4.6.1-1mamba;Thu Mar 14 2024]
This commit is contained in:
parent
0780d3b0d8
commit
381298bcb5
@ -1,15 +0,0 @@
|
||||
--- cola-1.4.2.5/cola/models/main.py.orig 2010-11-12 15:54:13.000000000 +0100
|
||||
+++ cola-1.4.2.5/cola/models/main.py 2010-11-12 15:55:07.000000000 +0100
|
||||
@@ -167,9 +167,9 @@ from cola.models.observable import Obser
|
||||
'cola_showoutput': 'errors',
|
||||
'cola_tabwidth': 8,
|
||||
'merge_keepbackup': True,
|
||||
- 'diff_tool': os.getenv('GIT_DIFF_TOOL', 'xxdiff'),
|
||||
- 'merge_tool': os.getenv('GIT_MERGE_TOOL', 'xxdiff'),
|
||||
- 'gui_editor': os.getenv('VISUAL', os.getenv('EDITOR', 'gvim')),
|
||||
+ 'diff_tool': os.getenv('GIT_DIFF_TOOL', 'kdiff3'),
|
||||
+ 'merge_tool': os.getenv('GIT_MERGE_TOOL', 'kdiff3'),
|
||||
+ 'gui_editor': os.getenv('VISUAL', os.getenv('EDITOR', 'kate -u')),
|
||||
'gui_historybrowser': 'gitk',
|
||||
}
|
||||
|
@ -1,12 +0,0 @@
|
||||
--- cola-1.4.2.5/cola/resources.py.orig 2010-11-12 17:32:20.000000000 +0100
|
||||
+++ cola-1.4.2.5/cola/resources.py 2010-11-12 17:34:35.000000000 +0100
|
||||
@@ -21,7 +21,8 @@
|
||||
|
||||
def doc(*args):
|
||||
"""Return a path relative to cola's /usr/share/doc/ directory"""
|
||||
- return os.path.join(_prefix, 'share', 'doc', 'git-cola', *args)
|
||||
+ from cola import version
|
||||
+ return os.path.join(_prefix, 'share', 'doc', 'git-cola-' + version.version(), *args)
|
||||
|
||||
|
||||
def html_docs():
|
@ -1,5 +1,5 @@
|
||||
Name: git-cola
|
||||
Version: 4.5.0
|
||||
Version: 4.6.1
|
||||
Release: 1mamba
|
||||
Summary: A powerful Git GUI with a slick and intuitive user interface
|
||||
Group: Graphical Desktop/Applications/Development
|
||||
@ -8,13 +8,11 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://github.com/git-cola/git-cola
|
||||
Source: https+git://github.com/git-cola/git-cola.git/v%{version}/git-cola-%{version}.tar.bz2
|
||||
Patch0: git-cola-1.4.2.5-doc.patch
|
||||
Patch1: git-cola-1.4.2.5-defapps.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: libpython311-devel
|
||||
BuildRequires: python3.11dist(polib)
|
||||
BuildRequires: python3.11dist(qtpy)
|
||||
BuildRequires: python3.11dist(setuptools)
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: python3-devel >= 3.11.5-3mamba
|
||||
#BuildRequires: desktop-file-utils
|
||||
@ -24,10 +22,7 @@ BuildRequires: gettext
|
||||
BuildRequires: perl
|
||||
BuildRequires: xmlto
|
||||
Requires: git-gui
|
||||
Requires: python3 >= %{python3_version}
|
||||
#Requires: python-pyinotify-py3
|
||||
Requires: python-jsonpickle-py3
|
||||
Requires: PyQt5
|
||||
#Requires: python-jsonpickle-py3
|
||||
BuildArch: noarch
|
||||
|
||||
%description
|
||||
@ -37,49 +32,45 @@ git-cola is a powerful GUI for git that gives you an easy way to interact with G
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch 0 -p1
|
||||
#%patch 1 -p1
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags}" %{__python3} setup.py build
|
||||
|
||||
%make doc \
|
||||
prefix=%{_prefix}
|
||||
CFLAGS="%{optflags}" %{__python3} -m build --no-isolation --wheel
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%{__python3} setup.py install \
|
||||
-O1 --skip-build \
|
||||
--root="%{buildroot}" \
|
||||
--install-headers=%{python3_inc} \
|
||||
--install-lib=%{python3_sitearch} \
|
||||
--record=%{name}.filelist \
|
||||
--prefix=%{_prefix}
|
||||
%{__python3} -m installer --destdir=%{buildroot} dist/*.whl
|
||||
|
||||
# install documentation
|
||||
make install-doc install-html \
|
||||
DESTDIR=%{buildroot} \
|
||||
prefix=%{_prefix}
|
||||
#%if "%{?with_pyver}" != "3"
|
||||
## Rename any conflicting file outside of python site packages tree
|
||||
#for f in %{_bindir}/pdm; do
|
||||
# mv %{buildroot}${f}{,-%{?pyappend}}
|
||||
#done
|
||||
#%endif
|
||||
|
||||
sed -i "\,\.egg-info/,d;s,.*/man/.*,&.gz," %{name}.filelist
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.filelist
|
||||
%files %{?pyappend}
|
||||
%defattr(-,root,root)
|
||||
%dir %{python3_sitearch}/git_cola-%{version}-py*.egg-info
|
||||
%{python3_sitearch}/git_cola-%{version}-py*.egg-info/*
|
||||
%{_mandir}/man1/git-cola.1*
|
||||
%{_mandir}/man1/git-dag.1*
|
||||
%{_mandir}/man1/git-dag.1*
|
||||
%{_bindir}/cola
|
||||
%{_bindir}/git-cola
|
||||
%{_bindir}/git-cola-sequence-editor
|
||||
%{_bindir}/git-dag
|
||||
%{_datadir}/applications/git-cola-folder-handler.desktop
|
||||
%{_datadir}/applications/git-cola.desktop
|
||||
%{_datadir}/applications/git-dag.desktop
|
||||
%{_metainfodir}/git-cola.appdata.xml
|
||||
%{_metainfodir}/git-dag.appdata.xml
|
||||
%dir %{python3_sitelib}/git_cola-%{version}.dist-info
|
||||
%{python3_sitelib}/git_cola-%{version}.dist-info/*
|
||||
%dir %{python3_sitelib}/cola
|
||||
%{python3_sitelib}/cola/*
|
||||
%{_datadir}/icons/hicolor/scalable/apps/git-cola.svg
|
||||
%dir %{_docdir}/git-cola
|
||||
%{_docdir}/git-cola/*.rst
|
||||
%dir %{_docdir}/git-cola/html
|
||||
%{_docdir}/git-cola/html/*
|
||||
%{_docdir}/git-cola/*
|
||||
%doc COPYING COPYRIGHT
|
||||
|
||||
%changelog
|
||||
* Thu Mar 14 2024 Automatic Build System <autodist@openmamba.org> 4.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jan 23 2024 Automatic Build System <autodist@openmamba.org> 4.5.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user