automatic version update by autodist [release 2.8.10-1mamba;Mon Jan 13 2014]
This commit is contained in:
parent
6450bb0fc0
commit
b1dd9788ce
10
README.md
10
README.md
@ -1,2 +1,12 @@
|
|||||||
# gimp
|
# gimp
|
||||||
|
|
||||||
|
GIMP is an acronym for GNU Image Manipulation Program.
|
||||||
|
It is a freely distributed piece of software suitable for such tasks as photo retouching, image composition and image authoring.
|
||||||
|
It is an extremely capable piece of software with many capabilities.
|
||||||
|
It can be used as a simple paint program, a expert quality photo retouching program, an online batch processing system, a mass production image renderer, a image format converter, etc.
|
||||||
|
|
||||||
|
GIMP is extremely expandedable and extensible.
|
||||||
|
It is designed to be augmented with plugins and extensions to do just about anything.
|
||||||
|
|
||||||
|
The advanced scripting interface allows everything from the simplest task to the most complex image manipulation procedures to be easily scripted.
|
||||||
|
|
||||||
|
10
gimp-2.2.13-gimprc-default_browser.patch
Normal file
10
gimp-2.2.13-gimprc-default_browser.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- gimp-2.2.13/etc/gimprc 2006-08-24 22:54:29.000000000 +0200
|
||||||
|
+++ gimp-2.2.13/etc/gimprc-browserfix 2007-01-10 21:55:54.000000000 +0100
|
||||||
|
@@ -586,6 +586,7 @@
|
||||||
|
# filename.
|
||||||
|
#
|
||||||
|
# (web-browser "mozilla %s")
|
||||||
|
+(web-browser "firefox %s")
|
||||||
|
|
||||||
|
# The window type hint that is set on the toolbox. This may affect how your
|
||||||
|
# window manager decorates and handles the toolbox window. Possible values
|
12
gimp-2.4.0-desktop_file.patch
Normal file
12
gimp-2.4.0-desktop_file.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru gimp-2.4.0.orig/po/it.po gimp-2.4.0/po/it.po
|
||||||
|
--- gimp-2.4.0.orig/po/it.po 2007-10-22 21:16:25.000000000 +0200
|
||||||
|
+++ gimp-2.4.0/po/it.po 2007-10-25 00:33:27.000000000 +0200
|
||||||
|
@@ -44,7 +44,7 @@
|
||||||
|
|
||||||
|
#: ../app/about.h:27 ../desktop/gimp.desktop.in.in.h:2
|
||||||
|
msgid "GNU Image Manipulation Program"
|
||||||
|
-msgstr "GNU Image Manipulation Program"
|
||||||
|
+msgstr "Manipolazione immagini"
|
||||||
|
|
||||||
|
#: ../app/about.h:30
|
||||||
|
msgid ""
|
23
gimp-2.6.6-BABL.patch
Normal file
23
gimp-2.6.6-BABL.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
--- app/sanity.c 2009-08-04 18:32:37.000000000 +0200
|
||||||
|
+++ app/sanity.c 2009-08-04 19:47:54.000000000 +0200
|
||||||
|
@@ -257,6 +257,7 @@
|
||||||
|
gint babl_major_version;
|
||||||
|
gint babl_minor_version;
|
||||||
|
gint babl_micro_version;
|
||||||
|
+ gint bversion;
|
||||||
|
|
||||||
|
#define BABL_REQUIRED_MAJOR 0
|
||||||
|
#define BABL_REQUIRED_MINOR 0
|
||||||
|
@@ -266,9 +267,9 @@
|
||||||
|
&babl_minor_version,
|
||||||
|
&babl_micro_version);
|
||||||
|
|
||||||
|
- if (babl_major_version < BABL_REQUIRED_MAJOR ||
|
||||||
|
- babl_minor_version < BABL_REQUIRED_MINOR ||
|
||||||
|
- babl_micro_version < BABL_REQUIRED_MICRO)
|
||||||
|
+ bversion = babl_micro_version + babl_minor_version*100 + babl_major_version*10000;
|
||||||
|
+
|
||||||
|
+if (bversion < (BABL_REQUIRED_MICRO + BABL_REQUIRED_MINOR*100 + BABL_REQUIRED_MAJOR*10000))
|
||||||
|
{
|
||||||
|
return g_strdup_printf
|
||||||
|
("BABL version too old!\n\n"
|
24
gimp-2.6.6-GEGL.patch
Normal file
24
gimp-2.6.6-GEGL.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru gimp-2.6.6.orig/app/sanity.c gimp-2.6.6/app/sanity.c
|
||||||
|
--- gimp-2.6.6.orig/app/sanity.c 2009-08-06 02:39:26.000000000 +0200
|
||||||
|
+++ gimp-2.6.6/app/sanity.c 2009-08-06 02:42:49.000000000 +0200
|
||||||
|
@@ -296,6 +296,7 @@
|
||||||
|
gint gegl_major_version;
|
||||||
|
gint gegl_minor_version;
|
||||||
|
gint gegl_micro_version;
|
||||||
|
+ gint bversion;
|
||||||
|
|
||||||
|
#define GEGL_REQUIRED_MAJOR 0
|
||||||
|
#define GEGL_REQUIRED_MINOR 0
|
||||||
|
@@ -305,9 +306,9 @@
|
||||||
|
&gegl_minor_version,
|
||||||
|
&gegl_micro_version);
|
||||||
|
|
||||||
|
- if (gegl_major_version < GEGL_REQUIRED_MAJOR ||
|
||||||
|
- gegl_minor_version < GEGL_REQUIRED_MINOR ||
|
||||||
|
- gegl_micro_version < GEGL_REQUIRED_MICRO)
|
||||||
|
+ bversion = gegl_micro_version + gegl_minor_version*100 + gegl_major_version*10000;
|
||||||
|
+
|
||||||
|
+ if (bversion < (GEGL_REQUIRED_MICRO + GEGL_REQUIRED_MINOR*100 + GEGL_REQUIRED_MAJOR*10000))
|
||||||
|
{
|
||||||
|
return g_strdup_printf
|
||||||
|
("GEGL version too old!\n\n"
|
24
gimp-2.7.4-fix_ld_missing_libm.patch
Normal file
24
gimp-2.7.4-fix_ld_missing_libm.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru gimp-2.7.4.orig/devel-docs/tools/Makefile.am gimp-2.7.4/devel-docs/tools/Makefile.am
|
||||||
|
--- gimp-2.7.4.orig/devel-docs/tools/Makefile.am 2012-02-11 16:48:48.581478261 +0100
|
||||||
|
+++ gimp-2.7.4/devel-docs/tools/Makefile.am 2012-02-11 16:44:38.665414294 +0100
|
||||||
|
@@ -34,7 +34,7 @@
|
||||||
|
$(libgimpcolor) \
|
||||||
|
$(libgimpbase) \
|
||||||
|
$(GTK_LIBS) \
|
||||||
|
- $(X_LIBS) -lX11 -lXext
|
||||||
|
+ $(X_LIBS) -lX11 -lXext -lm
|
||||||
|
|
||||||
|
|
||||||
|
EXTRA_PROGRAMS = doc-shooter
|
||||||
|
diff -Nru gimp-2.7.4.orig/devel-docs/tools/Makefile.in gimp-2.7.4/devel-docs/tools/Makefile.in
|
||||||
|
--- gimp-2.7.4.orig/devel-docs/tools/Makefile.in 2012-02-11 16:48:57.343393068 +0100
|
||||||
|
+++ gimp-2.7.4/devel-docs/tools/Makefile.in 2012-02-11 16:45:47.707603180 +0100
|
||||||
|
@@ -438,7 +438,7 @@
|
||||||
|
$(libgimpcolor) \
|
||||||
|
$(libgimpbase) \
|
||||||
|
$(GTK_LIBS) \
|
||||||
|
- $(X_LIBS) -lX11 -lXext
|
||||||
|
+ $(X_LIBS) -lX11 -lXext -lm
|
||||||
|
|
||||||
|
EXTRA_DIST = README.shooter
|
||||||
|
all: all-am
|
12
gimp-2.8.10-freetype-2.5.2.patch
Normal file
12
gimp-2.8.10-freetype-2.5.2.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -Nru gimp-2.8.10.orig/app/text/gimpfont.c gimp-2.8.10/app/text/gimpfont.c
|
||||||
|
--- gimp-2.8.10.orig/app/text/gimpfont.c 2014-01-12 13:30:58.989882059 +0100
|
||||||
|
+++ gimp-2.8.10/app/text/gimpfont.c 2014-01-12 13:29:42.560662655 +0100
|
||||||
|
@@ -27,7 +27,7 @@
|
||||||
|
|
||||||
|
#define PANGO_ENABLE_ENGINE 1 /* Argh */
|
||||||
|
#include <pango/pango-ot.h>
|
||||||
|
-#include <freetype/tttables.h>
|
||||||
|
+#include <tttables.h>
|
||||||
|
|
||||||
|
#include "text-types.h"
|
||||||
|
|
499
gimp.spec
Normal file
499
gimp.spec
Normal file
@ -0,0 +1,499 @@
|
|||||||
|
# GIMP specfile for openmamba
|
||||||
|
#
|
||||||
|
# TIP: also check for gimp-help package updates when upgrading gimp
|
||||||
|
#
|
||||||
|
%define majversion %(echo %version | cut -d. -f 1-2)
|
||||||
|
%define api_version 2.0
|
||||||
|
|
||||||
|
%define enable_python 1
|
||||||
|
|
||||||
|
%define libname libgimp
|
||||||
|
|
||||||
|
Name: gimp
|
||||||
|
Version: 2.8.10
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: The GNU Image Manipulation Program
|
||||||
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.gimp.org
|
||||||
|
Source0: ftp://ftp.gimp.org/pub/gimp/v%{majversion}/gimp-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-2.4.0-desktop_file.patch
|
||||||
|
Patch1: %{name}-2.2.13-gimprc-default_browser.patch
|
||||||
|
# patch to avoid the problem with BABL version 0.1.0 and major
|
||||||
|
Patch2: %{name}-2.6.6-BABL.patch
|
||||||
|
Patch3: %{name}-2.6.6-GEGL.patch
|
||||||
|
Patch4: %{name}-2.7.4-fix_ld_missing_libm.patch
|
||||||
|
Patch5: gimp-2.8.10-freetype-2.5.2.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: bash
|
||||||
|
BuildRequires: coreutils
|
||||||
|
BuildRequires: ldconfig
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: dbus-tools
|
||||||
|
BuildRequires: GConf-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: gtk-doc
|
||||||
|
BuildRequires: libaa-devel
|
||||||
|
BuildRequires: libalsa-devel
|
||||||
|
BuildRequires: libart_lgpl-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libdbus-devel
|
||||||
|
BuildRequires: libdbus-glib-devel
|
||||||
|
BuildRequires: libexif6-devel
|
||||||
|
BuildRequires: libexpat-devel
|
||||||
|
BuildRequires: libfontconfig-devel
|
||||||
|
BuildRequires: libfreetype-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgtk-devel
|
||||||
|
BuildRequires: libgtkhtml2-devel
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: liblcms-devel
|
||||||
|
BuildRequires: libmng-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libpoppler-devel
|
||||||
|
BuildRequires: libpopt-devel
|
||||||
|
BuildRequires: librsvg-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libtiff-devel
|
||||||
|
BuildRequires: libwmf-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libxml2-devel
|
||||||
|
BuildRequires: libXmu-devel
|
||||||
|
BuildRequires: libXpm-devel
|
||||||
|
BuildRequires: libXt-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: ORBit2-devel
|
||||||
|
BuildRequires: pygtk-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: libgsf-devel
|
||||||
|
BuildRequires: libcroco-devel
|
||||||
|
BuildRequires: libgail-devel
|
||||||
|
BuildRequires: perl
|
||||||
|
# build requirements for gimp-help
|
||||||
|
BuildRequires: libxslt-devel
|
||||||
|
BuildRequires: ImageMagick
|
||||||
|
BuildRequires: libgegl-devel
|
||||||
|
%if %{enable_python}
|
||||||
|
# build requirement needed to build python extension
|
||||||
|
BuildRequires: pygtk-devel
|
||||||
|
BuildRequires: libpython-devel
|
||||||
|
%endif
|
||||||
|
BuildRequires: /usr/bin/xmllint
|
||||||
|
BuildRequires: /usr/bin/xsltproc
|
||||||
|
BuildRequires: libbabl-devel
|
||||||
|
BuildRequires: libjasper-devel
|
||||||
|
BuildRequires: intltool >= 0.40.1
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
#Requires: gimp-print >= 4.2.5
|
||||||
|
Requires: libtiff >= 3.5.7
|
||||||
|
Requires: dbus-tools
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
#====================================================
|
||||||
|
# warning FIXME: "reverse" hardcoded to FALSE.
|
||||||
|
# warning FIXME: make interpolated transformations work on layers without alpha
|
||||||
|
# warning FIXME: use GParamSpecString::ensure_non_null and chain up once we depend on glib 2.12.12 or newer
|
||||||
|
# warning FIXME: need container of dirty images
|
||||||
|
#====================================================
|
||||||
|
|
||||||
|
%description
|
||||||
|
GIMP is an acronym for GNU Image Manipulation Program.
|
||||||
|
It is a freely distributed piece of software suitable for such tasks as photo retouching, image composition and image authoring.
|
||||||
|
It is an extremely capable piece of software with many capabilities.
|
||||||
|
It can be used as a simple paint program, a expert quality photo retouching program, an online batch processing system, a mass production image renderer, a image format converter, etc.
|
||||||
|
|
||||||
|
GIMP is extremely expandedable and extensible.
|
||||||
|
It is designed to be augmented with plugins and extensions to do just about anything.
|
||||||
|
|
||||||
|
The advanced scripting interface allows everything from the simplest task to the most complex image manipulation procedures to be easily scripted.
|
||||||
|
|
||||||
|
%package console
|
||||||
|
Summary: GIMP libraries
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description console
|
||||||
|
GIMP is an acronym for GNU Image Manipulation Program.
|
||||||
|
It is a freely distributed piece of software suitable for such tasks as photo retouching, image composition and image authoring.
|
||||||
|
It is an extremely capable piece of software with many capabilities.
|
||||||
|
It can be used as a simple paint program, a expert quality photo retouching program, an online batch processing system, a mass production image renderer, a image format converter, etc.
|
||||||
|
|
||||||
|
This package contains a console-only binary which does not link GTK+ at all.
|
||||||
|
|
||||||
|
%package -n %{libname}
|
||||||
|
Summary: GIMP libraries
|
||||||
|
Group: System/Libraries
|
||||||
|
License: LGPL
|
||||||
|
|
||||||
|
%description -n %{libname}
|
||||||
|
This is the library that provides core GIMP functionality.
|
||||||
|
It enable other programs to use GIMP's features but is mainly intended to be used by the GIMP and its "external" plugins.
|
||||||
|
|
||||||
|
%package -n %{libname}-devel
|
||||||
|
Summary: Static libraries and headers for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Obsoletes: gimp-devel
|
||||||
|
Provides: gimp-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description -n %{libname}-devel
|
||||||
|
GIMP is an acronym for GNU Image Manipulation Program.
|
||||||
|
It is a freely distributed piece of software suitable for such tasks as photo retouching, image composition and image authoring.
|
||||||
|
It is an extremely capable piece of software with many capabilities.
|
||||||
|
It can be used as a simple paint program, a expert quality photo retouching program, an online batch processing system, a mass production image renderer, a image format converter, etc.
|
||||||
|
GIMP is extremely expandedable and extensible.
|
||||||
|
It is designed to be augmented with plugins and extensions to do just about anything.
|
||||||
|
The advanced scripting interface allows everything from the simplest task to the most complex image manipulation procedures to be easily scripted.
|
||||||
|
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%package -n %{libname}-apidocs
|
||||||
|
Summary: GIMP library API documentation
|
||||||
|
Group: Documentation
|
||||||
|
Requires: gtk-doc
|
||||||
|
|
||||||
|
%description -n %{libname}-apidocs
|
||||||
|
GIMP library API documentation.
|
||||||
|
|
||||||
|
%package -n python-%{name}
|
||||||
|
Summary: GIMP python extension
|
||||||
|
Group: System/Libraries/Python
|
||||||
|
Provides: %{name}-python = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Requires: pygtk
|
||||||
|
%py_requires
|
||||||
|
|
||||||
|
%description -n python-%{name}
|
||||||
|
This package contains the python modules for GIMP, which act as a wrapper to libgimp allowing the writing of plug-ins for Gimp.
|
||||||
|
This is similar to script-fu, except that you can use the full set of Python extension modules from the plug-in, and you write plug-in in python instead of in scheme.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch2
|
||||||
|
#%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
export CFLAGS="%{optflags} -ffast-math"
|
||||||
|
%configure \
|
||||||
|
--enable-gimp-console \
|
||||||
|
%if %enable_python
|
||||||
|
--enable-python=yes \
|
||||||
|
PYTHON=python%{python_version} \
|
||||||
|
%else
|
||||||
|
--enable-python=no \
|
||||||
|
%endif
|
||||||
|
--enable-gtk-doc \
|
||||||
|
# --enable-gimp-remote \
|
||||||
|
|
||||||
|
%make FIXXREF_OPTIONS="--module \$(DOC_MODULE)"
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
#ln -s gimp-%{majversion} %{buildroot}%{_bindir}/gimp
|
||||||
|
#ln -s gimp-console-%{majversion} %{buildroot}%{_bindir}/gimp-console
|
||||||
|
|
||||||
|
%find_lang gimp20-libgimp
|
||||||
|
%find_lang gimp20-script-fu
|
||||||
|
%find_lang gimp20-std-plug-ins
|
||||||
|
%find_lang gimp20-python
|
||||||
|
%find_lang gimp20-tips
|
||||||
|
%find_lang gimp20
|
||||||
|
|
||||||
|
> gimp.lang
|
||||||
|
for f in gimp20-libgimp gimp20-script-fu gimp20-std-plug-ins gimp20-python gimp20-tips gimp20; do
|
||||||
|
cat $f.lang >> %{name}.lang
|
||||||
|
done
|
||||||
|
|
||||||
|
#install -D -m 755 data/misc/gimp.desktop \
|
||||||
|
# %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%post -n %{libname} -p /sbin/ldconfig
|
||||||
|
%postun -n %{libname} -p /sbin/ldconfig
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/gimp-%{majversion}
|
||||||
|
%{_bindir}/gimp
|
||||||
|
#%{_bindir}/gimp-remote-%{majversion}
|
||||||
|
#%{_bindir}/gimp-remote
|
||||||
|
%dir %{_datadir}/gimp
|
||||||
|
%{_datadir}/gimp/*
|
||||||
|
%{_datadir}/appdata/gimp.appdata.xml
|
||||||
|
%{_datadir}/applications/%{name}.desktop
|
||||||
|
#%{_datadir}/application-registry/gimp.applications
|
||||||
|
#%{_datadir}/mime-info/gimp.keys
|
||||||
|
%{_datadir}/icons/hicolor/*/apps/gimp.png
|
||||||
|
#%{_datadir}/icons/hicolor/scalable/apps/gimp.svg
|
||||||
|
%dir %{_libdir}/gimp/%{api_version}
|
||||||
|
%dir %{_libdir}/gimp/%{api_version}/environ
|
||||||
|
%{_libdir}/gimp/%{api_version}/environ/default.env
|
||||||
|
%{_libdir}/gimp/%{api_version}/interpreters/*
|
||||||
|
%{_libdir}/gimp/%{api_version}/modules
|
||||||
|
%{_libdir}/gimp/%{api_version}/plug-ins
|
||||||
|
%exclude %{_libdir}/gimp/%{api_version}/plug-ins/*.py
|
||||||
|
%dir %{_sysconfdir}/gimp
|
||||||
|
%{_sysconfdir}/gimp/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
|
%files console
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/gimp-console
|
||||||
|
%{_bindir}/gimp-console-%{majversion}
|
||||||
|
|
||||||
|
%files -n %{libname}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/libgimp-*.so.*
|
||||||
|
%{_libdir}/libgimpconfig-*.so.*
|
||||||
|
%{_libdir}/libgimpthumb-*.so.*
|
||||||
|
%{_libdir}/libgimpbase-*.so.*
|
||||||
|
%{_libdir}/libgimpcolor-*.so.*
|
||||||
|
%{_libdir}/libgimpmath-*.so.*
|
||||||
|
%{_libdir}/libgimpmodule-*.so.*
|
||||||
|
%{_libdir}/libgimpui-*.so.*
|
||||||
|
%{_libdir}/libgimpwidgets-*.so.*
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
%files -n %{libname}-devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/gimptool-2.0
|
||||||
|
%{_datadir}/aclocal/*
|
||||||
|
%{_libdir}/*.la
|
||||||
|
%{_libdir}/*.so
|
||||||
|
%{_libdir}/pkgconfig/*
|
||||||
|
%dir %{_includedir}/gimp-%{api_version}
|
||||||
|
%{_includedir}/gimp-%{api_version}/*
|
||||||
|
%doc ChangeLog HACKING NEWS README README.i18n
|
||||||
|
|
||||||
|
%files -n %{libname}-apidocs
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_datadir}/gtk-doc/html/libgimp/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpbase/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpcolor/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpconfig/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpmath/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpmodule/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpthumb/
|
||||||
|
%{_datadir}/gtk-doc/html/libgimpwidgets/
|
||||||
|
|
||||||
|
%if %{enable_python}
|
||||||
|
%files -n python-%{name}
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_libdir}/gimp/%{api_version}/environ/pygimp.env
|
||||||
|
%{_libdir}/gimp/%{api_version}/python
|
||||||
|
%{_libdir}/gimp/%{api_version}/plug-ins/*.py
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Jan 13 2014 Automatic Build System <autodist@mambasoft.it> 2.8.10-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Nov 04 2013 Automatic Build System <autodist@mambasoft.it> 2.8.8-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Jun 26 2013 Automatic Build System <autodist@mambasoft.it> 2.8.6-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Wed Feb 06 2013 Automatic Build System <autodist@mambasoft.it> 2.8.4-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Fri Aug 24 2012 Automatic Build System <autodist@mambasoft.it> 2.8.2-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu May 03 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.8.0-1mamba
|
||||||
|
- update to 2.8.0
|
||||||
|
|
||||||
|
* Thu Jan 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 2.7.4-1mamba
|
||||||
|
- update to 2.7.4
|
||||||
|
|
||||||
|
* Tue Aug 23 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 2.7.3-1mamba
|
||||||
|
- update to 2.7.3
|
||||||
|
|
||||||
|
* Fri Nov 12 2010 Automatic Build System <autodist@mambasoft.it> 2.6.11-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Mon Oct 04 2010 Automatic Build System <autodist@mambasoft.it> 2.6.11-1mamba
|
||||||
|
- automatic update to 2.6.11 by autodist
|
||||||
|
|
||||||
|
* Thu Jul 08 2010 Automatic Build System <autodist@mambasoft.it> 2.6.10-1mamba
|
||||||
|
- automatic update to 2.6.10 by autodist
|
||||||
|
|
||||||
|
* Fri Jul 02 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.9-2mamba
|
||||||
|
- rebuilt against libpng 1.4
|
||||||
|
|
||||||
|
* Wed Jun 23 2010 Automatic Build System <autodist@mambasoft.it> 2.6.9-1mamba
|
||||||
|
- automatic update to 2.6.9 by autodist
|
||||||
|
|
||||||
|
* Fri Jun 04 2010 Automatic Build System <autodist@mambasoft.it> 2.6.8-2mamba
|
||||||
|
- automatic rebuild by autodist
|
||||||
|
|
||||||
|
* Sun Dec 27 2009 Automatic Build System <autodist@mambasoft.it> 2.6.8-1mamba
|
||||||
|
- automatic update to 2.6.8 by autodist
|
||||||
|
|
||||||
|
* Fri Aug 14 2009 Automatic Build System <autodist@mambasoft.it> 2.6.7-1mamba
|
||||||
|
- automatic update to 2.6.7 by autodist
|
||||||
|
|
||||||
|
* Thu Aug 06 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.6-3mamba
|
||||||
|
- added the same patch as below for GEGL 0.1.0
|
||||||
|
|
||||||
|
* Tue Aug 04 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.6.6-2mamba
|
||||||
|
- Added a patch to avoid error with BABL version major of 0.0.22
|
||||||
|
|
||||||
|
* Mon Mar 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.6-1mamba
|
||||||
|
- automatic update to 2.6.6 by autodist
|
||||||
|
|
||||||
|
* Mon Feb 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.5-1mamba
|
||||||
|
- automatic update to 2.6.5 by autodist
|
||||||
|
|
||||||
|
* Fri Jan 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.4-1mamba
|
||||||
|
- automatic update to 2.6.4 by autodist
|
||||||
|
|
||||||
|
* Sat Nov 22 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.3-1mamba
|
||||||
|
- automatic update to 2.6.3 by autodist
|
||||||
|
|
||||||
|
* Fri Oct 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.2-1mamba
|
||||||
|
- automatic update to 2.6.2 by autodist
|
||||||
|
|
||||||
|
* Thu Oct 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-1mamba
|
||||||
|
- automatic update to 2.6.1 by autodist
|
||||||
|
|
||||||
|
* Sat Aug 23 2008 gil <puntogil@libero.it> 2.4.7-1mamba
|
||||||
|
- update to 2.4.7
|
||||||
|
- pygtk2 replaced with pygtk
|
||||||
|
|
||||||
|
* Wed Jun 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.6-1mamba
|
||||||
|
- update to 2.4.6
|
||||||
|
|
||||||
|
* Thu Mar 27 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.5-1mamba
|
||||||
|
- update to 2.4.5
|
||||||
|
- removed requirement for gimp-print
|
||||||
|
|
||||||
|
* Mon Dec 17 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.3-2mamba
|
||||||
|
- added requirement for dbus-tools
|
||||||
|
|
||||||
|
* Sun Dec 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.3-1mamba
|
||||||
|
- update to 2.4.3
|
||||||
|
- gimp help moved to gimp-help stand-alone package
|
||||||
|
|
||||||
|
* Wed Nov 21 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1mamba
|
||||||
|
- update to 2.4.2
|
||||||
|
- gimp-help update to version 2.0.13
|
||||||
|
|
||||||
|
* Wed Oct 31 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.1-1mamba
|
||||||
|
- update to 2.4.1
|
||||||
|
|
||||||
|
* Wed Oct 24 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0-1mamba
|
||||||
|
- update to 2.4.0
|
||||||
|
|
||||||
|
* Tue Jun 05 2007 Aleph0 <aleph0@openmamba.org> 2.2.15-1mamba
|
||||||
|
- update to 2.2.15
|
||||||
|
- gimp-help updated to version 2.0.12
|
||||||
|
|
||||||
|
* Wed Jan 17 2007 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.13-2qilnx
|
||||||
|
- new subpackage apidocs with API documentation
|
||||||
|
|
||||||
|
* Wed Jan 10 2007 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.13-1qilnx
|
||||||
|
- update to version 2.2.13 by autospec
|
||||||
|
- created help packages for Italian, Korean, Norwegian, and Russian languages
|
||||||
|
- added some missing build requirements
|
||||||
|
- updated build requirements for Xorg
|
||||||
|
- use firefox instead of mozilla to display help pages
|
||||||
|
- use %%py_requires to set up requirements for python extensions subpackage
|
||||||
|
|
||||||
|
* Fri Jul 07 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.12-1qilnx
|
||||||
|
- update to version 2.2.12 by autospec
|
||||||
|
|
||||||
|
* Wed May 10 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.11-1qilnx
|
||||||
|
- update to version 2.2.11 by autospec
|
||||||
|
- gimp-help updated to version 2-0.10
|
||||||
|
|
||||||
|
* Fri Mar 03 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.10-2qilnx
|
||||||
|
- new packages libgimp, libgimp-devel (was gimp-devel), gimp-console
|
||||||
|
- new package python-gimp (python bindings for gimp)
|
||||||
|
- compiled with the fast-math gcc option
|
||||||
|
|
||||||
|
* Tue Jan 03 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.10-1qilnx
|
||||||
|
- update to version 2.2.10 by autospec
|
||||||
|
|
||||||
|
* Fri Dec 23 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.9-4qilnx
|
||||||
|
- patched desktop file to add mimefile support
|
||||||
|
|
||||||
|
* Tue Dec 13 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.2.9-3qilnx
|
||||||
|
- added --enable-gimp-console option for the configure
|
||||||
|
|
||||||
|
* Mon Nov 28 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.2.9-2qilnx
|
||||||
|
- modified desktop file adding mimefile
|
||||||
|
|
||||||
|
* Fri Oct 28 2005 Davide Madrisan <davide.madrisan@qilinux.it> 2.2.9-1qilnx
|
||||||
|
- update to version 2.2.9 by autospec
|
||||||
|
- specfile fixes/cleanups
|
||||||
|
- added some missing build requirements
|
||||||
|
|
||||||
|
* Wed Jun 29 2005 Alessandro Ramazzina <alessandro.ramazzina@qilinux.it> 2.2.8-1qilnx
|
||||||
|
- update to version 2.2.8 by autospec
|
||||||
|
|
||||||
|
* Wed May 11 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.7-1qilnx
|
||||||
|
- update to version 2.2.7 by autospec
|
||||||
|
|
||||||
|
* Mon Apr 18 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.6-1qilnx
|
||||||
|
- update to version 2.2.6 by autospec
|
||||||
|
|
||||||
|
* Mon Jan 17 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.2-1qilnx
|
||||||
|
- update to version 2.2.2 by autospec
|
||||||
|
- added documentation/help packages
|
||||||
|
|
||||||
|
* Wed Dec 29 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.2.1-1qilnx
|
||||||
|
- update to version 2.2.1 by autospec
|
||||||
|
|
||||||
|
* Fri Nov 26 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.6-1qilnx
|
||||||
|
- update to version 2.0.6 by autospec
|
||||||
|
|
||||||
|
* Wed Oct 13 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.5-2qilnx
|
||||||
|
- changed kde menu entry name to a more comprehensible one
|
||||||
|
|
||||||
|
* Sun Sep 26 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.5-1qilnx
|
||||||
|
- update to version 2.0.5 by autospec
|
||||||
|
|
||||||
|
* Thu Sep 09 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.4-1qilnx
|
||||||
|
- new version build
|
||||||
|
- added *.so missing symlinks
|
||||||
|
- moved gimptool in devel package
|
||||||
|
|
||||||
|
* Mon Jul 19 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.3-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Mon Jun 21 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.2-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Fri Apr 16 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.1-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Wed Mar 24 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0.0-1qilnx
|
||||||
|
- new version build
|
||||||
|
|
||||||
|
* Tue Jan 20 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0pre2-1qilnx
|
||||||
|
- new version rebuild
|
||||||
|
- added kde menu icon
|
||||||
|
|
||||||
|
* Wed Jan 07 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 2.0pre1-1qilnx
|
||||||
|
- new version rebuild
|
||||||
|
|
||||||
|
* Tue Dec 30 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.23-1qilnx
|
||||||
|
- new version rebuild
|
||||||
|
|
||||||
|
* Mon Sep 22 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.5-1qilnx
|
||||||
|
- first build for gimp
|
Loading…
Reference in New Issue
Block a user