remove obsolete requirement for libwebkit-gtk and python [release 2.10.36-2mamba;Mon Apr 01 2024]
This commit is contained in:
parent
ac639772e1
commit
158baef7bc
@ -1,10 +0,0 @@
|
|||||||
--- gimp-2.2.13/etc/gimprc 2006-08-24 22:54:29.000000000 +0200
|
|
||||||
+++ gimp-2.2.13/etc/gimprc-browserfix 2007-01-10 21:55:54.000000000 +0100
|
|
||||||
@@ -586,6 +586,7 @@
|
|
||||||
# filename.
|
|
||||||
#
|
|
||||||
# (web-browser "mozilla %s")
|
|
||||||
+(web-browser "firefox %s")
|
|
||||||
|
|
||||||
# The window type hint that is set on the toolbox. This may affect how your
|
|
||||||
# window manager decorates and handles the toolbox window. Possible values
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru gimp-2.4.0.orig/po/it.po gimp-2.4.0/po/it.po
|
|
||||||
--- gimp-2.4.0.orig/po/it.po 2007-10-22 21:16:25.000000000 +0200
|
|
||||||
+++ gimp-2.4.0/po/it.po 2007-10-25 00:33:27.000000000 +0200
|
|
||||||
@@ -44,7 +44,7 @@
|
|
||||||
|
|
||||||
#: ../app/about.h:27 ../desktop/gimp.desktop.in.in.h:2
|
|
||||||
msgid "GNU Image Manipulation Program"
|
|
||||||
-msgstr "GNU Image Manipulation Program"
|
|
||||||
+msgstr "Manipolazione immagini"
|
|
||||||
|
|
||||||
#: ../app/about.h:30
|
|
||||||
msgid ""
|
|
@ -1,23 +0,0 @@
|
|||||||
--- app/sanity.c 2009-08-04 18:32:37.000000000 +0200
|
|
||||||
+++ app/sanity.c 2009-08-04 19:47:54.000000000 +0200
|
|
||||||
@@ -257,6 +257,7 @@
|
|
||||||
gint babl_major_version;
|
|
||||||
gint babl_minor_version;
|
|
||||||
gint babl_micro_version;
|
|
||||||
+ gint bversion;
|
|
||||||
|
|
||||||
#define BABL_REQUIRED_MAJOR 0
|
|
||||||
#define BABL_REQUIRED_MINOR 0
|
|
||||||
@@ -266,9 +267,9 @@
|
|
||||||
&babl_minor_version,
|
|
||||||
&babl_micro_version);
|
|
||||||
|
|
||||||
- if (babl_major_version < BABL_REQUIRED_MAJOR ||
|
|
||||||
- babl_minor_version < BABL_REQUIRED_MINOR ||
|
|
||||||
- babl_micro_version < BABL_REQUIRED_MICRO)
|
|
||||||
+ bversion = babl_micro_version + babl_minor_version*100 + babl_major_version*10000;
|
|
||||||
+
|
|
||||||
+if (bversion < (BABL_REQUIRED_MICRO + BABL_REQUIRED_MINOR*100 + BABL_REQUIRED_MAJOR*10000))
|
|
||||||
{
|
|
||||||
return g_strdup_printf
|
|
||||||
("BABL version too old!\n\n"
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -Nru gimp-2.6.6.orig/app/sanity.c gimp-2.6.6/app/sanity.c
|
|
||||||
--- gimp-2.6.6.orig/app/sanity.c 2009-08-06 02:39:26.000000000 +0200
|
|
||||||
+++ gimp-2.6.6/app/sanity.c 2009-08-06 02:42:49.000000000 +0200
|
|
||||||
@@ -296,6 +296,7 @@
|
|
||||||
gint gegl_major_version;
|
|
||||||
gint gegl_minor_version;
|
|
||||||
gint gegl_micro_version;
|
|
||||||
+ gint bversion;
|
|
||||||
|
|
||||||
#define GEGL_REQUIRED_MAJOR 0
|
|
||||||
#define GEGL_REQUIRED_MINOR 0
|
|
||||||
@@ -305,9 +306,9 @@
|
|
||||||
&gegl_minor_version,
|
|
||||||
&gegl_micro_version);
|
|
||||||
|
|
||||||
- if (gegl_major_version < GEGL_REQUIRED_MAJOR ||
|
|
||||||
- gegl_minor_version < GEGL_REQUIRED_MINOR ||
|
|
||||||
- gegl_micro_version < GEGL_REQUIRED_MICRO)
|
|
||||||
+ bversion = gegl_micro_version + gegl_minor_version*100 + gegl_major_version*10000;
|
|
||||||
+
|
|
||||||
+ if (bversion < (GEGL_REQUIRED_MICRO + GEGL_REQUIRED_MINOR*100 + GEGL_REQUIRED_MAJOR*10000))
|
|
||||||
{
|
|
||||||
return g_strdup_printf
|
|
||||||
("GEGL version too old!\n\n"
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -Nru gimp-2.8.10.orig/app/text/gimpfont.c gimp-2.8.10/app/text/gimpfont.c
|
|
||||||
--- gimp-2.8.10.orig/app/text/gimpfont.c 2014-01-12 13:30:58.989882059 +0100
|
|
||||||
+++ gimp-2.8.10/app/text/gimpfont.c 2014-01-12 13:29:42.560662655 +0100
|
|
||||||
@@ -27,7 +27,7 @@
|
|
||||||
|
|
||||||
#define PANGO_ENABLE_ENGINE 1 /* Argh */
|
|
||||||
#include <pango/pango-ot.h>
|
|
||||||
-#include <freetype/tttables.h>
|
|
||||||
+#include <tttables.h>
|
|
||||||
|
|
||||||
#include "text-types.h"
|
|
||||||
|
|
79
gimp.spec
79
gimp.spec
@ -5,14 +5,12 @@
|
|||||||
%define majversion %(echo %version | cut -d. -f 1-2)
|
%define majversion %(echo %version | cut -d. -f 1-2)
|
||||||
%define api_version 2.0
|
%define api_version 2.0
|
||||||
|
|
||||||
%define enable_python 0
|
|
||||||
|
|
||||||
%define libname libgimp
|
%define libname libgimp
|
||||||
|
|
||||||
Name: gimp
|
Name: gimp
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.10.36
|
Version: 2.10.36
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: The GNU Image Manipulation Program
|
Summary: The GNU Image Manipulation Program
|
||||||
Group: Graphical Desktop/Applications/Graphics
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -20,13 +18,7 @@ Distribution: openmamba
|
|||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: https://www.gimp.org/
|
URL: https://www.gimp.org/
|
||||||
Source0: http://download.gimp.org/pub/gimp/v%{majversion}/gimp-%{version}.tar.bz2
|
Source0: http://download.gimp.org/pub/gimp/v%{majversion}/gimp-%{version}.tar.bz2
|
||||||
Patch0: %{name}-2.4.0-desktop_file.patch
|
Patch4: gimp-2.7.4-fix_ld_missing_libm.patch
|
||||||
Patch1: %{name}-2.2.13-gimprc-default_browser.patch
|
|
||||||
# patch to avoid the problem with BABL version 0.1.0 and major
|
|
||||||
Patch2: %{name}-2.6.6-BABL.patch
|
|
||||||
Patch3: %{name}-2.6.6-GEGL.patch
|
|
||||||
Patch4: %{name}-2.7.4-fix_ld_missing_libm.patch
|
|
||||||
Patch5: gimp-2.8.10-freetype-2.5.2.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -41,7 +33,7 @@ BuildRequires: libXpm-devel
|
|||||||
BuildRequires: libXt-devel
|
BuildRequires: libXt-devel
|
||||||
BuildRequires: libaa-devel
|
BuildRequires: libaa-devel
|
||||||
BuildRequires: libalsa-devel
|
BuildRequires: libalsa-devel
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libat-spi2-core-devel
|
||||||
BuildRequires: libbabl-devel
|
BuildRequires: libbabl-devel
|
||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
@ -62,6 +54,7 @@ BuildRequires: libimath-devel
|
|||||||
BuildRequires: libjpeg-devel
|
BuildRequires: libjpeg-devel
|
||||||
BuildRequires: libjson-c-devel
|
BuildRequires: libjson-c-devel
|
||||||
BuildRequires: libjson-glib-devel
|
BuildRequires: libjson-glib-devel
|
||||||
|
BuildRequires: libjxl-devel
|
||||||
BuildRequires: liblcms2-devel
|
BuildRequires: liblcms2-devel
|
||||||
BuildRequires: liblzma-devel
|
BuildRequires: liblzma-devel
|
||||||
BuildRequires: libmng-devel
|
BuildRequires: libmng-devel
|
||||||
@ -72,19 +65,13 @@ BuildRequires: libpango-devel
|
|||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpoppler-glib-devel
|
BuildRequires: libpoppler-glib-devel
|
||||||
BuildRequires: librsvg-devel
|
BuildRequires: librsvg-devel
|
||||||
BuildRequires: libsoup2-devel
|
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libunwind-devel
|
BuildRequires: libunwind-devel
|
||||||
%ifnarch aarch64
|
|
||||||
BuildRequires: libwebkit-gtk-devel
|
|
||||||
%endif
|
|
||||||
BuildRequires: libwebp-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libwmf-devel
|
BuildRequires: libwmf-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libgs-devel >= 10.01.2-1mamba
|
|
||||||
BuildRequires: libmypaint-devel >= 1.6.1-1mamba
|
|
||||||
BuildRequires: bash
|
BuildRequires: bash
|
||||||
BuildRequires: coreutils
|
BuildRequires: coreutils
|
||||||
BuildRequires: ldconfig
|
BuildRequires: ldconfig
|
||||||
@ -97,36 +84,18 @@ BuildRequires: perl
|
|||||||
# build requirements for gimp-help
|
# build requirements for gimp-help
|
||||||
BuildRequires: libxslt-devel
|
BuildRequires: libxslt-devel
|
||||||
BuildRequires: ImageMagick
|
BuildRequires: ImageMagick
|
||||||
%if %{enable_python}
|
|
||||||
# build requirement needed to build python extension
|
|
||||||
BuildRequires: pygtk-devel
|
|
||||||
BuildRequires: libpython-devel
|
|
||||||
BuildRequires: pycairo-py27-devel
|
|
||||||
%endif
|
|
||||||
BuildRequires: /usr/bin/xmllint
|
BuildRequires: /usr/bin/xmllint
|
||||||
BuildRequires: /usr/bin/xsltproc
|
BuildRequires: /usr/bin/xsltproc
|
||||||
BuildRequires: libbabl-devel
|
BuildRequires: libbabl-devel
|
||||||
BuildRequires: libjasper-devel
|
BuildRequires: libjasper-devel
|
||||||
BuildRequires: intltool >= 0.40.1
|
BuildRequires: intltool >= 0.40.1
|
||||||
BuildRequires: mypaint-brushes1
|
BuildRequires: mypaint-brushes1
|
||||||
Requires: mypaint-brushes1
|
|
||||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
%if %{enable_python}
|
Requires: mypaint-brushes1
|
||||||
Requires: python-gimp = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
%else
|
|
||||||
Obsoletes: python-gimp < 1:2.10.32-1mamba
|
|
||||||
%endif
|
|
||||||
#Requires: gimp-print >= 4.2.5
|
|
||||||
Requires: libtiff >= 3.5.7
|
|
||||||
Requires: dbus-tools
|
Requires: dbus-tools
|
||||||
Requires: iso-codes
|
Requires: iso-codes
|
||||||
Requires: graphviz
|
Requires: graphviz
|
||||||
#====================================================
|
Obsoletes: python-gimp < 1:2.10.32-1mamba
|
||||||
# warning FIXME: "reverse" hardcoded to FALSE.
|
|
||||||
# warning FIXME: make interpolated transformations work on layers without alpha
|
|
||||||
# warning FIXME: use GParamSpecString::ensure_non_null and chain up once we depend on glib 2.12.12 or newer
|
|
||||||
# warning FIXME: need container of dirty images
|
|
||||||
#====================================================
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
GIMP is an acronym for GNU Image Manipulation Program.
|
GIMP is an acronym for GNU Image Manipulation Program.
|
||||||
@ -187,25 +156,11 @@ Requires: gtk-doc
|
|||||||
%description -n %{libname}-apidocs
|
%description -n %{libname}-apidocs
|
||||||
GIMP library API documentation.
|
GIMP library API documentation.
|
||||||
|
|
||||||
%package -n python-%{name}
|
|
||||||
Summary: GIMP python extension
|
|
||||||
Group: System/Libraries/Python
|
|
||||||
Provides: %{name}-python = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
Requires: %{libname} = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
Requires: pygtk
|
|
||||||
|
|
||||||
%description -n python-%{name}
|
|
||||||
This package contains the python modules for GIMP, which act as a wrapper to libgimp allowing the writing of plug-ins for Gimp.
|
|
||||||
This is similar to script-fu, except that you can use the full set of Python extension modules from the plug-in, and you write plug-in in python instead of in scheme.
|
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
#%patch2
|
|
||||||
#%patch3 -p1
|
|
||||||
%patch 4 -p1
|
%patch 4 -p1
|
||||||
#%patch5 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CFLAGS="%{optflags} -ffast-math"
|
export CFLAGS="%{optflags} -ffast-math"
|
||||||
@ -216,14 +171,9 @@ export LDFLAGS="-lm"
|
|||||||
%configure \
|
%configure \
|
||||||
--enable-gimp-console \
|
--enable-gimp-console \
|
||||||
--with-bug-report-url=https://openmamba.org/ \
|
--with-bug-report-url=https://openmamba.org/ \
|
||||||
%if %{?enable_python}
|
--disable-python \
|
||||||
--enable-python=yes \
|
--without-webkit \
|
||||||
PYTHON=%{__python27} \
|
--enable-gtk-doc
|
||||||
%else
|
|
||||||
--enable-python=no \
|
|
||||||
%endif
|
|
||||||
--enable-gtk-doc \
|
|
||||||
# --enable-gimp-remote \
|
|
||||||
|
|
||||||
%make FIXXREF_OPTIONS="--module \$(DOC_MODULE)"
|
%make FIXXREF_OPTIONS="--module \$(DOC_MODULE)"
|
||||||
|
|
||||||
@ -301,15 +251,10 @@ export LDFLAGS="-lm"
|
|||||||
%{_datadir}/gtk-doc/html/libgimpthumb/
|
%{_datadir}/gtk-doc/html/libgimpthumb/
|
||||||
%{_datadir}/gtk-doc/html/libgimpwidgets/
|
%{_datadir}/gtk-doc/html/libgimpwidgets/
|
||||||
|
|
||||||
%if %{?enable_python}
|
|
||||||
%files -n python-%{name}
|
|
||||||
%defattr(-,root,root)
|
|
||||||
%{_libdir}/gimp/%{api_version}/environ/pygimp.env
|
|
||||||
%{_libdir}/gimp/%{api_version}/python
|
|
||||||
#%{_libdir}/gimp/%{api_version}/plug-ins/*.py
|
|
||||||
%endif
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.36-2mamba
|
||||||
|
- remove obsolete requirement for libwebkit-gtk and python
|
||||||
|
|
||||||
* Mon Nov 06 2023 Automatic Build System <autodist@mambasoft.it> 2.10.36-1mamba
|
* Mon Nov 06 2023 Automatic Build System <autodist@mambasoft.it> 2.10.36-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user