150 lines
4.4 KiB
RPMSpec
150 lines
4.4 KiB
RPMSpec
%define api_version 2.0
|
|
%define majver %(echo %version | cut -d. -f1-2)
|
|
|
|
Name: gimp-help
|
|
Version: 2.10.34
|
|
Epoch: 1
|
|
Release: 1mamba
|
|
Summary: The GIMP help for use with the internal GIMP help browser and more
|
|
Group: Documentation
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://www.gimp.org
|
|
Source0: https://download.gimp.org/pub/gimp/help/gimp-help-%{version}.tar.bz2
|
|
Patch0: %{name}-2.6.1-autogen.sh.patch
|
|
Patch1: %{name}-2.6.1-missing_from_git.patch
|
|
Patch2: %{name}-2.8.0-fix_missing_ca_quickreference.patch
|
|
License: GPL
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: gettext-devel
|
|
BuildRequires: pkgconfig
|
|
BuildRequires: libgsf-devel
|
|
BuildRequires: libcroco-devel
|
|
BuildRequires: libgail-devel
|
|
BuildRequires: perl
|
|
# build requirements for gimp-help
|
|
BuildRequires: libxslt-devel
|
|
BuildRequires: ImageMagick
|
|
BuildRequires: /usr/bin/xmllint
|
|
BuildRequires: /usr/bin/xsltproc
|
|
BuildRequires: gnome-doc-utils
|
|
BuildRequires: docbook-dtds
|
|
BuildRequires: docbook-xsl
|
|
BuildArch: noarch
|
|
|
|
# FIXME:
|
|
#
|
|
#checking for dblatex... no
|
|
#configure: WARNING: cannot find dblatex(1), PDF generation disabled
|
|
#checking for docbook2odf... no
|
|
#configure: WARNING: cannot find docbook2odf(1), ODF generation disabled
|
|
|
|
%description
|
|
The GIMP help for use with the internal GIMP help browser and more.
|
|
|
|
%define lang_subpkg() \
|
|
%package %{1}\
|
|
Summary: %{2} help files for GIMP\
|
|
Requires: gimp >= %{majver}\
|
|
Obsoletes: %{name}-%{1} < 1:2.10.0\
|
|
Obsoletes: %{name}-i18n-%{1} < 1:2.10.0\
|
|
Supplements: (gimp >= %{majver} and langpacks-%{1})\
|
|
\
|
|
%description %{1}\
|
|
This package contains the %{2} help files for GIMP.\
|
|
\
|
|
%files %{1}\
|
|
%defattr(-,root,root)\
|
|
%dir %{_datadir}/gimp/%{api_version}/help/%{1}\
|
|
%{_datadir}/gimp/%{api_version}/help/%{1}/*\
|
|
%if "%{_build_cpu}" == "i586"\
|
|
%{_datadir}/gimp/%{api_version}/help/pdf/gimp-keys-%{1}.pdf\
|
|
%endif
|
|
|
|
%lang_subpkg ca Catalan
|
|
%lang_subpkg cs Czech
|
|
%lang_subpkg da Danish
|
|
%lang_subpkg de German
|
|
#% lang_subpkg el Greek
|
|
%lang_subpkg en English
|
|
%lang_subpkg en_GB %{quote:British English}
|
|
%lang_subpkg es Spanish
|
|
%lang_subpkg fa Persian
|
|
#% lang_subpkg fi Finnish
|
|
%lang_subpkg fr French
|
|
%lang_subpkg hr Croatian
|
|
%lang_subpkg hu Hungarian
|
|
%lang_subpkg it Italian
|
|
#% lang_subpkg ja Japanese
|
|
%lang_subpkg ko Korean
|
|
%lang_subpkg lt Lithuanian
|
|
%lang_subpkg nl Dutch
|
|
%lang_subpkg nn Norwegian
|
|
#% lang_subpkg pl Polish
|
|
%lang_subpkg pt Portuguese
|
|
%lang_subpkg pt_BR %{quote:Portuguese (Brazilian)}
|
|
%lang_subpkg ro Romanian
|
|
#% lang_subpkg ru Russian
|
|
%lang_subpkg sl Slovenian
|
|
%lang_subpkg sv Swedish
|
|
%lang_subpkg uk Ukranian
|
|
%lang_subpkg zh_CN %{quote:Chinese (Simplified)}
|
|
|
|
%prep
|
|
%setup -q
|
|
#-D -T
|
|
#%patch2 -p1
|
|
|
|
%build
|
|
#:<< _EOF
|
|
%configure \
|
|
--without-gimp \
|
|
ALL_LINGUAS="ca cs da de en en_GB es fa fr hr hu it ko lt nl nn pt pt_BR ro sl sv uk zh_CN"
|
|
|
|
%make
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
%makeinstall DESTDIR=%{buildroot}
|
|
|
|
# FIXME: pdf are only in x86 build and also for excluded languages
|
|
for f in el fi ja pl ru; do
|
|
rm -f %{buildroot}%{_datadir}/gimp/%{api_version}/help/pdf/gimp-keys-${f}.pdf
|
|
done
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%changelog
|
|
* Mon Aug 21 2023 Automatic Build System <autodist@mambasoft.it> 2.10.34-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Wed Mar 10 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 2.10.0-1mamba
|
|
- update to 2.10.0
|
|
|
|
* Sun Dec 01 2013 Automatic Build System <autodist@mambasoft.it> 2.8.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Wed Aug 08 2012 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Thu Sep 15 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-2mamba
|
|
- gimp-help-i18n-ja: don't provide/obsolete gimp-help-ko but gimp-help-ja
|
|
|
|
* Tue Apr 19 2011 Automatic Build System <autodist@mambasoft.it> 2.6.1-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Sat Dec 20 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1mamba
|
|
- automatic update by autodist
|
|
|
|
* Tue Aug 26 2008 Aleph0 <aleph0@openmamba.org> 2.4.1-1mamba
|
|
- update to 2.4.1
|
|
- added missing build requirements for gome-doc-utils, docbook-dtds, and docbook-xsl
|
|
|
|
* Sun Dec 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0-1mamba
|
|
- new gimp-help stand-alone package split out of gimp package
|
|
- bump epoch because previous version of gimp-help was 2.4.3
|
|
- package set as noarch
|