automatic update by autodist [release 2.8.1-1mamba;Sun Dec 01 2013]
This commit is contained in:
parent
faad6784db
commit
4916faed34
@ -1,2 +1,5 @@
|
|||||||
# gimp-help
|
# gimp-help
|
||||||
|
|
||||||
|
The GIMP help for use with the internal GIMP help browser and more.
|
||||||
|
|
||||||
|
|
||||||
|
128
gimp-help-2.6.1-autogen.sh.patch
Normal file
128
gimp-help-2.6.1-autogen.sh.patch
Normal file
@ -0,0 +1,128 @@
|
|||||||
|
diff -Nru gimp-help-2.6.1.orig//autogen.sh gimp-help-2.6.1/autogen.sh
|
||||||
|
--- gimp-help-2.6.1.orig//autogen.sh 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ gimp-help-2.6.1/autogen.sh 2011-04-03 22:12:23.000000000 +0200
|
||||||
|
@@ -0,0 +1,124 @@
|
||||||
|
+#!/bin/sh
|
||||||
|
+
|
||||||
|
+# This script does all the magic calls to automake/autoconf and
|
||||||
|
+# friends that are needed to configure a cvs checkout. You need a
|
||||||
|
+# couple of extra tools to run this script successfully.
|
||||||
|
+#
|
||||||
|
+# If you are compiling from a released tarball you don't need these
|
||||||
|
+# tools and you shouldn't use this script. Just call ./configure
|
||||||
|
+# directly.
|
||||||
|
+
|
||||||
|
+PROJECT="gimp-help-2"
|
||||||
|
+TEST_TYPE=-f
|
||||||
|
+FILE=src/gimp.xml
|
||||||
|
+
|
||||||
|
+srcdir=`dirname $0`
|
||||||
|
+test -z "$srcdir" && srcdir=.
|
||||||
|
+ORIGDIR=`pwd`
|
||||||
|
+cd $srcdir
|
||||||
|
+
|
||||||
|
+DIE=0
|
||||||
|
+
|
||||||
|
+echo -n "Looking for latest automake version ... "
|
||||||
|
+required_automake_minor=10
|
||||||
|
+minor=15
|
||||||
|
+while [ $minor -ge $required_automake_minor ]; do
|
||||||
|
+ ver=1.$minor
|
||||||
|
+ if (automake-$ver --version) < /dev/null > /dev/null 2>&1; then
|
||||||
|
+ AUTOMAKE=automake-$ver
|
||||||
|
+ ACLOCAL=aclocal-$ver
|
||||||
|
+ echo $ver
|
||||||
|
+ break
|
||||||
|
+ fi
|
||||||
|
+ minor=`expr $minor - 1`
|
||||||
|
+done
|
||||||
|
+
|
||||||
|
+if [ -z "$AUTOMAKE" ]; then
|
||||||
|
+ echo
|
||||||
|
+ echo " You must have automake 1.$required_automake_minor or newer" \
|
||||||
|
+ "installed to compile $PROJECT."
|
||||||
|
+ echo " Download the appropriate package for your distribution,"
|
||||||
|
+ echo " or get the source tarball at ftp://ftp.gnu.org/pub/gnu/automake/"
|
||||||
|
+ DIE=1
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test "$DIE" -eq 1; then
|
||||||
|
+ echo
|
||||||
|
+ echo "Please install/upgrade the missing tools and call me again."
|
||||||
|
+ echo
|
||||||
|
+ exit 1
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+test $TEST_TYPE $FILE || {
|
||||||
|
+ echo
|
||||||
|
+ echo "You must run this script in the top-level $PROJECT directory."
|
||||||
|
+ echo
|
||||||
|
+ exit 1
|
||||||
|
+}
|
||||||
|
+
|
||||||
|
+
|
||||||
|
+echo
|
||||||
|
+echo "I am going to run ./configure with the following arguments:"
|
||||||
|
+echo
|
||||||
|
+echo " --enable-maintainer-mode --enable-build $AUTOGEN_CONFIGURE_ARGS $@"
|
||||||
|
+echo
|
||||||
|
+
|
||||||
|
+if test -z "$*"; then
|
||||||
|
+ echo "If you wish to pass additional arguments, please specify them "
|
||||||
|
+ echo "on the $0 command line or set the AUTOGEN_CONFIGURE_ARGS "
|
||||||
|
+ echo "environment variable."
|
||||||
|
+ echo
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+if test -z "$ACLOCAL_FLAGS"; then
|
||||||
|
+ acdir=`$ACLOCAL --print-ac-dir`
|
||||||
|
+ m4list="pkg.m4"
|
||||||
|
+
|
||||||
|
+ for file in $m4list
|
||||||
|
+ do
|
||||||
|
+ if [ ! -f "$acdir/$file" ]; then
|
||||||
|
+ echo
|
||||||
|
+ echo "WARNING: aclocal's directory is $acdir, but..."
|
||||||
|
+ echo " no file $acdir/$file"
|
||||||
|
+ echo " You may see fatal macro warnings below."
|
||||||
|
+ echo " If these files are installed in /some/dir, set the ACLOCAL_FLAGS "
|
||||||
|
+ echo " environment variable to \"-I /some/dir\", or install" echo " $acdir/$file."
|
||||||
|
+ echo
|
||||||
|
+ fi
|
||||||
|
+ done
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+$ACLOCAL $ACLOCAL_FLAGS
|
||||||
|
+RC=$?
|
||||||
|
+if test $RC -ne 0; then
|
||||||
|
+ echo "$ACLOCAL gave errors. Please fix the error conditions and try again."
|
||||||
|
+ exit 1
|
||||||
|
+fi
|
||||||
|
+
|
||||||
|
+$AUTOMAKE --add-missing || exit 1
|
||||||
|
+if [ -e Makefile.in ]; then
|
||||||
|
+ sed -e 's/^# HIDE FROM AUTOMAKE #//' \
|
||||||
|
+ -e '/^all\(-local\)\?:/i\
|
||||||
|
+\
|
||||||
|
+\
|
||||||
|
+' Makefile.in > Makefile.in.tmp &&
|
||||||
|
+ mv Makefile.in.tmp Makefile.in
|
||||||
|
+else
|
||||||
|
+ echo >&2 "Error: cannot find Makefile.in"
|
||||||
|
+ exit 1
|
||||||
|
+fi
|
||||||
|
+autoconf || exit 1
|
||||||
|
+
|
||||||
|
+rm -rf autom4te.cache
|
||||||
|
+
|
||||||
|
+cd $ORIGDIR
|
||||||
|
+
|
||||||
|
+if $srcdir/configure --enable-maintainer-mode "$@"; then
|
||||||
|
+ echo
|
||||||
|
+ echo "Now type 'make' to compile $PROJECT."
|
||||||
|
+else
|
||||||
|
+ echo
|
||||||
|
+ echo "Configure failed or did not finish!"
|
||||||
|
+ exit 1
|
||||||
|
+fi
|
66
gimp-help-2.6.1-missing_from_git.patch
Normal file
66
gimp-help-2.6.1-missing_from_git.patch
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
diff -Nru gimp-help-2.6.1.orig//gimp-help-2.doap gimp-help-2.6.1/gimp-help-2.doap
|
||||||
|
--- gimp-help-2.6.1.orig//gimp-help-2.doap 1970-01-01 01:00:00.000000000 +0100
|
||||||
|
+++ gimp-help-2.6.1/gimp-help-2.doap 2011-04-07 13:44:37.000000000 +0200
|
||||||
|
@@ -0,0 +1,62 @@
|
||||||
|
+<Project xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
|
||||||
|
+ xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
|
||||||
|
+ xmlns:foaf="http://xmlns.com/foaf/0.1/"
|
||||||
|
+ xmlns:gnome="http://api.gnome.org/doap-extensions#"
|
||||||
|
+ xmlns="http://usefulinc.com/ns/doap#">
|
||||||
|
+
|
||||||
|
+ <name xml:lang="en">gimp-help-2</name>
|
||||||
|
+ <homepage rdf:resource="http://docs.gimp.org"/>
|
||||||
|
+ <mailing-list rdf:resource="https://lists.xcf.berkeley.edu/mailman/listinfo/gimp-docs" />
|
||||||
|
+ <download-page rdf:resource="http://docs.gimp.org/download.html" />
|
||||||
|
+ <bug-database rdf:resource="http://bugzilla.gnome.org/browse.cgi?product=GIMP-manual" />
|
||||||
|
+
|
||||||
|
+ <shortdesc xml:lang="en">GIMP User Manual</shortdesc>
|
||||||
|
+ <shortdesc xml:lang="de">GIMP-Benutzerhandbuch</shortdesc>
|
||||||
|
+ <!-- Based on I.1.1.2. The GIMP Help System -->
|
||||||
|
+ <description xml:lang="en">
|
||||||
|
+ The GIMP Documentation Team and other users have provided you with the
|
||||||
|
+ information necessary to understand how to use GIMP. The User Manual is an
|
||||||
|
+ important part of this help. The current version is on the web site of the
|
||||||
|
+ Documentation Team in HTML format. The HTML version is also available as
|
||||||
|
+ context sensitive help (if you installed it) while using GIMP by pressing
|
||||||
|
+ the F1 key.
|
||||||
|
+ </description>
|
||||||
|
+ <description xml:lang="de">
|
||||||
|
+ Das Dokumentations-Team und die Anwender von GIMP stellen Ihnen
|
||||||
|
+ vielfältige Informationen bereit, um Sie bei der Arbeit mit GIMP zu
|
||||||
|
+ unterstützen. Dieses Handbuch ist ein wichtiger Bestandteil der
|
||||||
|
+ Dokumentation. Die aktuelle Version finden Sie auf der Webseite des
|
||||||
|
+ GIMP-Dokumentations-Teams. Die HTML-Version wird zusätzlich als Kontexthilfe
|
||||||
|
+ verwendet. Sie können auf diese von GIMP aus jederzeit durch Drücken der
|
||||||
|
+ F1-Taste zugreifen.
|
||||||
|
+ </description>
|
||||||
|
+
|
||||||
|
+ <maintainer>
|
||||||
|
+ <foaf:Person>
|
||||||
|
+ <foaf:name>Róman Joost</foaf:name>
|
||||||
|
+ <foaf:mbox rdf:resource="mailto:romanofski@gimp.org" />
|
||||||
|
+ <gnome:userid>romanofski</gnome:userid>
|
||||||
|
+ </foaf:Person>
|
||||||
|
+ </maintainer>
|
||||||
|
+ <maintainer>
|
||||||
|
+ <foaf:Person>
|
||||||
|
+ <foaf:name>Ulf-D. Ehlert</foaf:name>
|
||||||
|
+ <foaf:mbox rdf:resource="mailto:ulfehlert@svn.gnome.org" />
|
||||||
|
+ <gnome:userid>ulfehlert</gnome:userid>
|
||||||
|
+ </foaf:Person>
|
||||||
|
+ </maintainer>
|
||||||
|
+ <maintainer>
|
||||||
|
+ <foaf:Person>
|
||||||
|
+ <foaf:name>Marco Ciampa</foaf:name>
|
||||||
|
+ <foaf:mbox rdf:resource="mailto:ciampix@libero.it" />
|
||||||
|
+ <gnome:userid>marcoc</gnome:userid>
|
||||||
|
+ </foaf:Person>
|
||||||
|
+ </maintainer>
|
||||||
|
+ <maintainer>
|
||||||
|
+ <foaf:Person>
|
||||||
|
+ <foaf:name>Julien Hardelin</foaf:name>
|
||||||
|
+ <foaf:mbox rdf:resource="mailto:jm.hard@wanadoo.fr" />
|
||||||
|
+ <gnome:userid>jhardlin</gnome:userid>
|
||||||
|
+ </foaf:Person>
|
||||||
|
+ </maintainer>
|
||||||
|
+</Project>
|
24
gimp-help-2.8.0-fix_missing_ca_quickreference.patch
Normal file
24
gimp-help-2.8.0-fix_missing_ca_quickreference.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru gimp-help-2.8.0.orig/configure gimp-help-2.8.0/configure
|
||||||
|
--- gimp-help-2.8.0.orig/configure 2012-05-28 00:53:07.000000000 +0200
|
||||||
|
+++ gimp-help-2.8.0/configure 2012-08-08 12:19:09.601572326 +0200
|
||||||
|
@@ -2492,7 +2492,7 @@
|
||||||
|
ALL_LINGUAS=`echo "$ALL_LINGUAS" | $SED -e 's/, */ /g'`
|
||||||
|
fi
|
||||||
|
if test "x$QUICKREFERENCE_ALL_LINGUAS" = "x"; then
|
||||||
|
- QUICKREFERENCE_ALL_LINGUAS="ca de el en fi fr it ja ko ru sv zh_CN"
|
||||||
|
+ QUICKREFERENCE_ALL_LINGUAS="de el en fi fr it ja ko ru sv zh_CN"
|
||||||
|
fi
|
||||||
|
|
||||||
|
|
||||||
|
diff -Nru gimp-help-2.8.0.orig/configure.ac gimp-help-2.8.0/configure.ac
|
||||||
|
--- gimp-help-2.8.0.orig/configure.ac 2012-05-24 10:40:04.000000000 +0200
|
||||||
|
+++ gimp-help-2.8.0/configure.ac 2012-08-08 12:18:56.457696731 +0200
|
||||||
|
@@ -62,7 +62,7 @@
|
||||||
|
ALL_LINGUAS=`echo "$ALL_LINGUAS" | $SED -e 's/[,] */ /g'`
|
||||||
|
fi
|
||||||
|
if test "x$QUICKREFERENCE_ALL_LINGUAS" = "x"; then
|
||||||
|
- QUICKREFERENCE_ALL_LINGUAS="ca de el en fi fr it ja ko ru sv zh_CN"
|
||||||
|
+ QUICKREFERENCE_ALL_LINGUAS="de el en fi fr it ja ko ru sv zh_CN"
|
||||||
|
fi
|
||||||
|
|
||||||
|
AC_SUBST(ALL_LINGUAS)
|
421
gimp-help.spec
Normal file
421
gimp-help.spec
Normal file
@ -0,0 +1,421 @@
|
|||||||
|
%define api_version 2.0
|
||||||
|
|
||||||
|
Name: gimp-help
|
||||||
|
Version: 2.8.1
|
||||||
|
Epoch: 1
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: The GIMP help for use with the internal GIMP help browser and more
|
||||||
|
Group: Documentation
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.gimp.org
|
||||||
|
Source0: ftp://ftp.gimp.org/pub/gimp/help/gimp-help-%{version}.tar.bz2
|
||||||
|
Patch0: %{name}-2.6.1-autogen.sh.patch
|
||||||
|
Patch1: %{name}-2.6.1-missing_from_git.patch
|
||||||
|
Patch2: %{name}-2.8.0-fix_missing_ca_quickreference.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRequires: gettext-devel
|
||||||
|
BuildRequires: pkgconfig
|
||||||
|
BuildRequires: libgsf-devel
|
||||||
|
BuildRequires: libcroco-devel
|
||||||
|
BuildRequires: libgail-devel
|
||||||
|
BuildRequires: perl
|
||||||
|
# build requirements for gimp-help
|
||||||
|
BuildRequires: libxslt-devel
|
||||||
|
BuildRequires: ImageMagick
|
||||||
|
BuildRequires: /usr/bin/xmllint
|
||||||
|
BuildRequires: /usr/bin/xsltproc
|
||||||
|
BuildRequires: gnome-doc-utils
|
||||||
|
BuildRequires: docbook-dtds
|
||||||
|
BuildRequires: docbook-xsl
|
||||||
|
BuildRequires: make381
|
||||||
|
BuildArch: noarch
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
# FIXME:
|
||||||
|
#
|
||||||
|
#checking for dblatex... no
|
||||||
|
#configure: WARNING: cannot find dblatex(1), PDF generation disabled
|
||||||
|
#checking for docbook2odf... no
|
||||||
|
#configure: WARNING: cannot find docbook2odf(1), ODF generation disabled
|
||||||
|
|
||||||
|
%description
|
||||||
|
The GIMP help for use with the internal GIMP help browser and more.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
#%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure --without-gimp
|
||||||
|
make html
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall DESTDIR=%{buildroot}
|
||||||
|
|
||||||
|
#install -D -m 755 data/misc/gimp.desktop \
|
||||||
|
# %{buildroot}%{_datadir}/applications/%{name}.desktop
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%package i18n-ca
|
||||||
|
Summary: Catalan help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-ca
|
||||||
|
Catalan help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-ca
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/ca
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/ca/*
|
||||||
|
|
||||||
|
%package i18n-cs
|
||||||
|
Summary: Czech help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-cs
|
||||||
|
Obsoletes: gimp-help-cs
|
||||||
|
|
||||||
|
%description i18n-cs
|
||||||
|
Czech help files for Gimp.
|
||||||
|
|
||||||
|
#%files help-cs
|
||||||
|
#%defattr(-,root,root)
|
||||||
|
#%dir %{_datadir}/gimp/%{api_version}/help/cs
|
||||||
|
#%{_datadir}/gimp/%{api_version}/help/cs/*
|
||||||
|
|
||||||
|
%package i18n-da
|
||||||
|
Summary: Danish help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-da
|
||||||
|
Danish help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-da
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/da
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/da/*
|
||||||
|
|
||||||
|
%package i18n-de
|
||||||
|
Summary: German help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-de
|
||||||
|
Obsoletes: gimp-help-de
|
||||||
|
|
||||||
|
%description i18n-de
|
||||||
|
German help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-de
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/de
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/de/*
|
||||||
|
|
||||||
|
%package i18n-el
|
||||||
|
Summary: Greek help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-el
|
||||||
|
Greek help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-el
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/el
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/el/*
|
||||||
|
|
||||||
|
%package i18n-en
|
||||||
|
Summary: English help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-en
|
||||||
|
Obsoletes: gimp-help-en
|
||||||
|
|
||||||
|
%description i18n-en
|
||||||
|
English help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-en
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/en
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/en/*
|
||||||
|
|
||||||
|
%package i18n-en_GB
|
||||||
|
Summary: British English help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-en_GB
|
||||||
|
British English help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-en_GB
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/en_GB
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/en_GB/*
|
||||||
|
|
||||||
|
%package i18n-es
|
||||||
|
Summary: Spanish help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-es
|
||||||
|
Obsoletes: gimp-help-es
|
||||||
|
|
||||||
|
%description i18n-es
|
||||||
|
Spanish help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-es
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/es
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/es/*
|
||||||
|
|
||||||
|
%package i18n-fi
|
||||||
|
Summary: Finnish help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-fi
|
||||||
|
Finnish help files for Gimp.
|
||||||
|
|
||||||
|
#%files i18n-fi
|
||||||
|
#%defattr(-,root,root)
|
||||||
|
#%dir %{_datadir}/gimp/%{api_version}/help/fi
|
||||||
|
#%{_datadir}/gimp/%{api_version}/help/fi/*
|
||||||
|
|
||||||
|
%package i18n-fr
|
||||||
|
Summary: French help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-fr
|
||||||
|
Obsoletes: gimp-help-fr
|
||||||
|
|
||||||
|
%description i18n-fr
|
||||||
|
French help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-fr
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/fr
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/fr/*
|
||||||
|
|
||||||
|
%package i18n-hr
|
||||||
|
Summary: Croatian help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-hr
|
||||||
|
Obsoletes: gimp-help-hr
|
||||||
|
|
||||||
|
%description i18n-hr
|
||||||
|
Croatian help files for Gimp.
|
||||||
|
|
||||||
|
#%files i18n-hr
|
||||||
|
#%defattr(-,root,root)
|
||||||
|
#%dir %{_datadir}/gimp/%{api_version}/help/hr
|
||||||
|
#%{_datadir}/gimp/%{api_version}/help/hr/*
|
||||||
|
|
||||||
|
%package i18n-it
|
||||||
|
Summary: Italian help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-it
|
||||||
|
Obsoletes: gimp-help-it
|
||||||
|
|
||||||
|
%description i18n-it
|
||||||
|
Italian help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-it
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/it
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/it/*
|
||||||
|
|
||||||
|
%package i18n-ja
|
||||||
|
Summary: Japanese help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-ja
|
||||||
|
Obsoletes: gimp-help-ja
|
||||||
|
|
||||||
|
%description i18n-ja
|
||||||
|
Japanese help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-ja
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/ja
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/ja/*
|
||||||
|
|
||||||
|
%package i18n-ko
|
||||||
|
Summary: Korean help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-ko
|
||||||
|
Obsoletes: gimp-help-ko
|
||||||
|
|
||||||
|
%description i18n-ko
|
||||||
|
Korean help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-ko
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/ko
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/ko/*
|
||||||
|
|
||||||
|
%package i18n-lt
|
||||||
|
Summary: Lithuanian help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-lt
|
||||||
|
Lithuanian help files for Gimp.
|
||||||
|
|
||||||
|
#%files i18n-lt
|
||||||
|
#%defattr(-,root,root)
|
||||||
|
#%dir %{_datadir}/gimp/%{api_version}/help/lt
|
||||||
|
#%{_datadir}/gimp/%{api_version}/help/lt/*
|
||||||
|
|
||||||
|
%package i18n-nl
|
||||||
|
Summary: Dutch help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-nl
|
||||||
|
Obsoletes: gimp-help-nl
|
||||||
|
|
||||||
|
%description i18n-nl
|
||||||
|
Dutch help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-nl
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/nl
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/nl/*
|
||||||
|
|
||||||
|
%package i18n-nn
|
||||||
|
Summary: Norwegian Nynorsk help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-no
|
||||||
|
Obsoletes: gimp-help-no
|
||||||
|
Provides: gimp-help-i18n-no
|
||||||
|
Obsoletes: gimp-help-i18n-no
|
||||||
|
|
||||||
|
%description i18n-nn
|
||||||
|
Norwegian Nynorsk help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-nn
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/nn
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/nn/*
|
||||||
|
|
||||||
|
%package i18n-pl
|
||||||
|
Summary: Polish help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-pl
|
||||||
|
Obsoletes: gimp-help-pl
|
||||||
|
|
||||||
|
%description i18n-pl
|
||||||
|
Polish help files for Gimp.
|
||||||
|
|
||||||
|
#%files i18n-pl
|
||||||
|
#%defattr(-,root,root)
|
||||||
|
#%dir %{_datadir}/gimp/%{api_version}/help/pl
|
||||||
|
#%{_datadir}/gimp/%{api_version}/help/pl/*
|
||||||
|
|
||||||
|
%package i18n-pt_BR
|
||||||
|
Summary: Brazil Portuguese help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-pt_BR
|
||||||
|
Brazil Portuguese help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-pt_BR
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/pt_BR
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/pt_BR/*
|
||||||
|
|
||||||
|
%package i18n-ru
|
||||||
|
Summary: Russian help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-ru
|
||||||
|
Obsoletes: gimp-help-ru
|
||||||
|
|
||||||
|
%description i18n-ru
|
||||||
|
Russian help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-ru
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/ru
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/ru/*
|
||||||
|
|
||||||
|
%package i18n-sl
|
||||||
|
Summary: Slovenian help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
|
||||||
|
%description i18n-sl
|
||||||
|
Slovenian help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-sl
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/sl
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/sl/*
|
||||||
|
|
||||||
|
%package i18n-sv
|
||||||
|
Summary: Swedish help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-sv
|
||||||
|
Obsoletes: gimp-help-sv
|
||||||
|
|
||||||
|
%description i18n-sv
|
||||||
|
Swedish help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-sv
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/sv
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/sv/*
|
||||||
|
|
||||||
|
%package i18n-zh_CN
|
||||||
|
Summary: Simplified chinese help files for Gimp
|
||||||
|
Group: System/Internationalization
|
||||||
|
Requires: gimp >= %{version}
|
||||||
|
Provides: gimp-help-zn_CN
|
||||||
|
Obsoletes: gimp-help-zn_CN
|
||||||
|
|
||||||
|
%description i18n-zh_CN
|
||||||
|
Simplified chinese help files for Gimp.
|
||||||
|
|
||||||
|
%files i18n-zh_CN
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%dir %{_datadir}/gimp/%{api_version}/help/zh_CN
|
||||||
|
%{_datadir}/gimp/%{api_version}/help/zh_CN/*
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Dec 01 2013 Automatic Build System <autodist@mambasoft.it> 2.8.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Wed Aug 08 2012 Automatic Build System <autodist@mambasoft.it> 2.8.0-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Thu Sep 15 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 2.6.1-2mamba
|
||||||
|
- gimp-help-i18n-ja: don't provide/obsolete gimp-help-ko but gimp-help-ja
|
||||||
|
|
||||||
|
* Tue Apr 19 2011 Automatic Build System <autodist@mambasoft.it> 2.6.1-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Sat Dec 20 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.2-1mamba
|
||||||
|
- automatic update by autodist
|
||||||
|
|
||||||
|
* Tue Aug 26 2008 Aleph0 <aleph0@openmamba.org> 2.4.1-1mamba
|
||||||
|
- update to 2.4.1
|
||||||
|
- added missing build requirements for gome-doc-utils, docbook-dtds, and docbook-xsl
|
||||||
|
|
||||||
|
* Sun Dec 16 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0-1mamba
|
||||||
|
- new gimp-help stand-alone package split out of gimp package
|
||||||
|
- bump epoch because previous version of gimp-help was 2.4.3
|
||||||
|
- package set as noarch
|
Loading…
Reference in New Issue
Block a user