package created by autospec [release 0.1.14-1mamba;Mon Oct 22 2007]
This commit is contained in:
parent
32adf6d38b
commit
a6c0a7752a
17
00-libMRML_include_CAccessorAdmin.h.gcc-4.1.patch
Normal file
17
00-libMRML_include_CAccessorAdmin.h.gcc-4.1.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
--- ../cvs-orig/gift/libMRML/include/CAccessorAdmin.h 2006-02-28 13:48:22.000000000 +0000
|
||||||
|
+++ gift/libMRML/include/CAccessorAdmin.h 2006-06-12 16:25:17.000000000 +0000
|
||||||
|
@@ -111,11 +111,11 @@
|
||||||
|
/** destructor */
|
||||||
|
~CAccessorAdmin();
|
||||||
|
/** */
|
||||||
|
- string CAccessorAdmin::getAlgorithmIDListID()const;
|
||||||
|
+ string getAlgorithmIDListID()const;
|
||||||
|
/** */
|
||||||
|
- string CAccessorAdmin::getName()const;
|
||||||
|
+ string getName()const;
|
||||||
|
/** */
|
||||||
|
- string CAccessorAdmin::getID()const;
|
||||||
|
+ string getID()const;
|
||||||
|
|
||||||
|
/** for sorting */
|
||||||
|
friend class CSortByName_pAP;
|
11
10-libMRML_include_CAttributeList.h.gcc-4.1.patch
Normal file
11
10-libMRML_include_CAttributeList.h.gcc-4.1.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- ../cvs-orig/gift/libMRML/include/CAttributeList.h 2006-02-28 13:48:22.000000000 +0000
|
||||||
|
+++ gift/libMRML/include/CAttributeList.h 2006-06-12 16:24:02.000000000 +0000
|
||||||
|
@@ -79,7 +79,7 @@
|
||||||
|
virtual pair<bool,string> stringReadAttribute(const string& inAttribute)const;
|
||||||
|
/** Outputting a string to XML
|
||||||
|
*/
|
||||||
|
- void CAttributeList::toXML(string& outString)const;
|
||||||
|
+ void toXML(string& outString)const;
|
||||||
|
/** the destructor
|
||||||
|
in the case of char* as content it deletes the arrays of char.
|
||||||
|
*/
|
16
20-libMRML_include_CI18nTranslator.h.gcc-4.1.patch
Normal file
16
20-libMRML_include_CI18nTranslator.h.gcc-4.1.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
--- ../cvs-orig/gift/libMRML/include/CI18nTranslator.h 2006-02-28 13:48:22.000000000 +0000
|
||||||
|
+++ gift/libMRML/include/CI18nTranslator.h 2006-06-12 16:26:26.000000000 +0000
|
||||||
|
@@ -98,11 +98,11 @@
|
||||||
|
void translateXMLTree(string inLanguageCode,
|
||||||
|
CXMLElement& inoutToBeTranslated)const;
|
||||||
|
/** for parsing the config file */
|
||||||
|
- static void CI18nTranslator::startXMLElement(void *inUserData,
|
||||||
|
+ static void startXMLElement(void *inUserData,
|
||||||
|
const char *inElementName,
|
||||||
|
const char **inAttributes);
|
||||||
|
/** for parsing the config file */
|
||||||
|
- static void CI18nTranslator::endXMLElement(void *inUserData,
|
||||||
|
+ static void endXMLElement(void *inUserData,
|
||||||
|
const char *inElementName);
|
||||||
|
};
|
||||||
|
#endif
|
35
30-libMRML_include_CSessionManager.h.gcc-4.1.patch
Normal file
35
30-libMRML_include_CSessionManager.h.gcc-4.1.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
--- ../cvs-orig/gift/libMRML/include/CSessionManager.h 2006-02-28 13:48:22.000000000 +0000
|
||||||
|
+++ gift/libMRML/include/CSessionManager.h 2006-06-12 16:27:51.000000000 +0000
|
||||||
|
@@ -172,18 +172,18 @@
|
||||||
|
bool rename(const string& inName);
|
||||||
|
/** the list of preferred languages of this
|
||||||
|
is cleared */
|
||||||
|
- void CSession::clearLanguages();
|
||||||
|
+ void clearLanguages();
|
||||||
|
/** one language code is added at the back of the list
|
||||||
|
of preferred languages */
|
||||||
|
- void CSession::addLanguage(string inLanguageCode);
|
||||||
|
+ void addLanguage(string inLanguageCode);
|
||||||
|
/** commit the list of languages. That means, here the
|
||||||
|
actual language that will be used throughout the
|
||||||
|
translation is determined */
|
||||||
|
- void CSession::commitLanguages(const CI18nTranslator& inTranslator);
|
||||||
|
+ void commitLanguages(const CI18nTranslator& inTranslator);
|
||||||
|
/** get the preferred languages of this session */
|
||||||
|
- list<string> CSession::getLanguages()const;
|
||||||
|
+ list<string> getLanguages()const;
|
||||||
|
/** get the preferred languages of this session */
|
||||||
|
- string CSession::getPreferredLanguage()const;
|
||||||
|
+ string getPreferredLanguage()const;
|
||||||
|
|
||||||
|
//--------------------------------------------------
|
||||||
|
/** generating XML output for configuration/shandshake */
|
||||||
|
@@ -420,7 +420,7 @@
|
||||||
|
/** i18n: get the list of preferred languages of this session */
|
||||||
|
list<string> getSessionLanguages(const string& inSessionID)const;
|
||||||
|
/** i18n: get the list of preferred languages of this session */
|
||||||
|
- void CSessionManager::translate(string inSessionID,
|
||||||
|
+ void translate(string inSessionID,
|
||||||
|
CXMLElement& inoutToBeTranslated)const;
|
||||||
|
};
|
||||||
|
|
@ -0,0 +1,11 @@
|
|||||||
|
--- ../cvs-orig/gift/libGIFTAcInvertedFile/include/CInvertedFileChunk.h 2006-02-28 13:48:22.000000000 +0000
|
||||||
|
+++ gift/libGIFTAcInvertedFile/include/CInvertedFileChunk.h 2006-06-12 16:31:02.000000000 +0000
|
||||||
|
@@ -73,7 +73,7 @@
|
||||||
|
* add one document of to the list for one feature
|
||||||
|
*
|
||||||
|
*/
|
||||||
|
- void CInvertedFileChunk::addElement(TID inDocumentID,
|
||||||
|
+ void addElement(TID inDocumentID,
|
||||||
|
double inDocumentFrequency);
|
||||||
|
|
||||||
|
/**
|
@ -1,2 +1,5 @@
|
|||||||
# gift
|
# gift
|
||||||
|
|
||||||
|
The GIFT (the GNU Image-Finding Tool) is a Content Based Image Retrieval System (CBIRS: http://en.wikipedia.org/wiki/CBIR). It enables you to do Query By Example (QBE: http://en.wikipedia.org/wiki/QBE) on images, giving you the opportunity to improve query results by relevance feedback. For processing your queries the program relies entirely on the content of the images, freeing you from the need to annotate all images before querying the collection.
|
||||||
|
The GIFT comes with a tool which lets you index whole directory trees containing images in one go. You then can use the GIFT server and its clients, to browse your own image collections.
|
||||||
|
|
||||||
|
18
gift-0.1.14-linuxdoc.patch
Normal file
18
gift-0.1.14-linuxdoc.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
diff -Nru gift-0.1.14.orig/Doc/configuring-and-hacking-the-gift.sgml gift-0.1.14/Doc/configuring-and-hacking-the-gift.sgml
|
||||||
|
--- gift-0.1.14.orig/Doc/configuring-and-hacking-the-gift.sgml 2004-12-02 16:43:54.000000000 +0100
|
||||||
|
+++ gift-0.1.14/Doc/configuring-and-hacking-the-gift.sgml 2007-10-22 00:51:35.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-<!doctype linuxdoc system "/usr/share/sgml/dtd/linuxdoc.dtd">
|
||||||
|
+<!doctype linuxdoc system "/usr/share/linuxdoc-tools/dtd/linuxdoc.dtd">
|
||||||
|
|
||||||
|
<article>
|
||||||
|
<title>Configuring and hacking the GIFT </title>
|
||||||
|
diff -Nru gift-0.1.14.orig/Doc/gift-guide.sgml gift-0.1.14/Doc/gift-guide.sgml
|
||||||
|
--- gift-0.1.14.orig/Doc/gift-guide.sgml 2005-03-24 10:25:18.000000000 +0100
|
||||||
|
+++ gift-0.1.14/Doc/gift-guide.sgml 2007-10-22 00:51:53.000000000 +0200
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-<!doctype linuxdoc system "/usr/share/sgml/dtd/linuxdoc.dtd">
|
||||||
|
+<!doctype linuxdoc system "/usr/share/linuxdoc-tools/dtd/linuxdoc.dtd">
|
||||||
|
|
||||||
|
<article>
|
||||||
|
<title>GIFT user's guide</title>
|
141
gift.spec
Normal file
141
gift.spec
Normal file
@ -0,0 +1,141 @@
|
|||||||
|
Name: gift
|
||||||
|
Version: 0.1.14
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: A Content Based Image Retrieval System
|
||||||
|
Group: Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://www.gnu.org/software/gift
|
||||||
|
Source: ftp://ftp.gnu.org/gnu/gift/gift-%{version}.tar.gz
|
||||||
|
Patch0: gift-0.1.14-linuxdoc.patch
|
||||||
|
Patch1: 00-libMRML_include_CAccessorAdmin.h.gcc-4.1.patch
|
||||||
|
Patch2: 10-libMRML_include_CAttributeList.h.gcc-4.1.patch
|
||||||
|
Patch3: 20-libMRML_include_CI18nTranslator.h.gcc-4.1.patch
|
||||||
|
Patch4: 30-libMRML_include_CSessionManager.h.gcc-4.1.patch
|
||||||
|
Patch5: 40-libGIFTAcInvertedFile_include_CInvertedFileChunk.h.gcc-4.1.patch
|
||||||
|
License: GPL
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
BuildRequires: perl-XML-Parser
|
||||||
|
BuildRequires: perl-Text-Iconv
|
||||||
|
BuildRequires: perl-XML-XQL
|
||||||
|
BuildRequires: perl-XML-DOM
|
||||||
|
BuildRequires: linuxdoc-tools
|
||||||
|
BuildRequires: linuxdoc-tools-latex
|
||||||
|
|
||||||
|
%description
|
||||||
|
The GIFT (the GNU Image-Finding Tool) is a Content Based Image Retrieval System (CBIRS: http://en.wikipedia.org/wiki/CBIR). It enables you to do Query By Example (QBE: http://en.wikipedia.org/wiki/QBE) on images, giving you the opportunity to improve query results by relevance feedback. For processing your queries the program relies entirely on the content of the images, freeing you from the need to annotate all images before querying the collection.
|
||||||
|
The GIFT comes with a tool which lets you index whole directory trees containing images in one go. You then can use the GIFT server and its clients, to browse your own image collections.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Devel package for %{name}
|
||||||
|
Group: Development/Libraries
|
||||||
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The GIFT (the GNU Image-Finding Tool) is a Content Based Image Retrieval System (CBIRS: http://en.wikipedia.org/wiki/CBIR). It enables you to do Query By Example (QBE: http://en.wikipedia.org/wiki/QBE) on images, giving you the opportunity to improve query results by relevance feedback. For processing your queries the program relies entirely on the content of the images, freeing you from the need to annotate all images before querying the collection.
|
||||||
|
The GIFT comes with a tool which lets you index whole directory trees containing images in one go. You then can use the GIFT server and its clients, to browse your own image collections.
|
||||||
|
This package contains static libraries and header files need for development.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch0 -p1
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
%patch3 -p1
|
||||||
|
%patch4 -p1
|
||||||
|
%patch5 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/gift
|
||||||
|
%{_bindir}/gift-endianize
|
||||||
|
%{_bindir}/gift-extract-features
|
||||||
|
%{_bindir}/gift-generate-inverted-file
|
||||||
|
%{_bindir}/gift-modify-distance-matrix
|
||||||
|
%{_bindir}/gift-one-minus
|
||||||
|
%{_bindir}/gift-write-feature-descs
|
||||||
|
%{_bindir}/*.pm
|
||||||
|
%{_bindir}/CGIFTLinkDemo.pl
|
||||||
|
%{_bindir}/CGLDAudreyMTam.pl
|
||||||
|
%{_bindir}/CTripleTransfer.pl
|
||||||
|
%{_bindir}/gift-*.pl
|
||||||
|
%{_libdir}/libGIFTAcDistanceMatrix.so.0
|
||||||
|
%{_libdir}/libGIFTAcDistanceMatrix.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTAcHierarchy.so.0
|
||||||
|
%{_libdir}/libGIFTAcHierarchy.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTAcInvertedFile.so.0
|
||||||
|
%{_libdir}/libGIFTAcInvertedFile.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTAcPerl.so.0
|
||||||
|
%{_libdir}/libGIFTAcPerl.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTAcURL2FTS.so.0
|
||||||
|
%{_libdir}/libGIFTAcURL2FTS.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTQuHierarchy.so.0
|
||||||
|
%{_libdir}/libGIFTQuHierarchy.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTQuInvertedFile.so.0
|
||||||
|
%{_libdir}/libGIFTQuInvertedFile.so.0.0.0
|
||||||
|
%{_libdir}/libGIFTQuPerl.so.0
|
||||||
|
%{_libdir}/libGIFTQuPerl.so.0.0.0
|
||||||
|
%{_libdir}/libMRML.so.1
|
||||||
|
%{_libdir}/libMRML.so.1.3.0
|
||||||
|
%doc AUTHORS COPYING ChangeLog NEWS README THANKS
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/libMRML-config
|
||||||
|
%{_datadir}/gift-config.mrml
|
||||||
|
%{_datadir}/gift-iconfigure.mrml
|
||||||
|
%{_datadir}/gift-ihandshake.mrml
|
||||||
|
%{_datadir}/mrml.dtd
|
||||||
|
%{_includedir}/libMRML/*
|
||||||
|
%{_includedir}/libGIFTQuPerl/*
|
||||||
|
%{_includedir}/libGIFTQuInvertedFile/*
|
||||||
|
%{_includedir}/libGIFTAcDistanceMatrix/*
|
||||||
|
%{_includedir}/libGIFTAcInvertedFile/*
|
||||||
|
%{_includedir}/libGIFTAcHierarchy/*
|
||||||
|
%{_includedir}/libGIFTAcPerl/*
|
||||||
|
%{_includedir}/libGIFTAcURL2FTS/*
|
||||||
|
%{_includedir}/libGIFTQuHierarchy/*
|
||||||
|
%{_libdir}/libGIFTAcDistanceMatrix.a
|
||||||
|
%{_libdir}/libGIFTAcDistanceMatrix.la
|
||||||
|
%{_libdir}/libGIFTAcDistanceMatrix.so
|
||||||
|
%{_libdir}/libGIFTAcHierarchy.a
|
||||||
|
%{_libdir}/libGIFTAcHierarchy.la
|
||||||
|
%{_libdir}/libGIFTAcHierarchy.so
|
||||||
|
%{_libdir}/libGIFTAcInvertedFile.a
|
||||||
|
%{_libdir}/libGIFTAcInvertedFile.la
|
||||||
|
%{_libdir}/libGIFTAcInvertedFile.so
|
||||||
|
%{_libdir}/libGIFTAcPerl.a
|
||||||
|
%{_libdir}/libGIFTAcPerl.la
|
||||||
|
%{_libdir}/libGIFTAcPerl.so
|
||||||
|
%{_libdir}/libGIFTAcURL2FTS.a
|
||||||
|
%{_libdir}/libGIFTAcURL2FTS.la
|
||||||
|
%{_libdir}/libGIFTAcURL2FTS.so
|
||||||
|
%{_libdir}/libGIFTQuHierarchy.a
|
||||||
|
%{_libdir}/libGIFTQuHierarchy.la
|
||||||
|
%{_libdir}/libGIFTQuHierarchy.so
|
||||||
|
%{_libdir}/libGIFTQuInvertedFile.a
|
||||||
|
%{_libdir}/libGIFTQuInvertedFile.la
|
||||||
|
%{_libdir}/libGIFTQuInvertedFile.so
|
||||||
|
%{_libdir}/libGIFTQuPerl.a
|
||||||
|
%{_libdir}/libGIFTQuPerl.la
|
||||||
|
%{_libdir}/libGIFTQuPerl.so
|
||||||
|
%{_libdir}/libMRML.a
|
||||||
|
%{_libdir}/libMRML.la
|
||||||
|
%{_libdir}/libMRML.so
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Mon Oct 22 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.14-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user