package created by silvan using the webbuild interface [release 7.6.3-1mamba;Sat Sep 07 2013]
This commit is contained in:
parent
e4636da2b2
commit
2539b56c6d
@ -1,2 +1,4 @@
|
||||
# ghc
|
||||
|
||||
GHC is a state-of-the-art, open source, compiler and interactive environment for the functional language Haskell.
|
||||
|
||||
|
20
ghc-7.6.3-pkgdir.patch
Normal file
20
ghc-7.6.3-pkgdir.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- ghc-6.12.3/libraries/Cabal/Cabal/Distribution/Simple/InstallDirs.hs~ 2010-06-09 20:10:19.000000000 +0200
|
||||
+++ ghc-6.12.3/libraries/Cabal/Cabal/Distribution/Simple/InstallDirs.hs 2010-08-26 21:28:52.969002660 +0200
|
||||
@@ -205,7 +205,7 @@
|
||||
-- users to be able to configure @--libdir=\/usr\/lib64@ for example but
|
||||
-- because by default we want to support installing multiple versions of
|
||||
-- packages and building the same package for multiple compilers we append the
|
||||
--- libsubdir to get: @\/usr\/lib64\/$pkgid\/$compiler@.
|
||||
+-- libsubdir to get: @\/usr\/lib64\/$compiler\/$pkgid@.
|
||||
--
|
||||
-- An additional complication is the need to support relocatable packages on
|
||||
-- systems which support such things, like Windows.
|
||||
@@ -236,7 +236,7 @@
|
||||
JHC -> "$compiler"
|
||||
LHC -> "$compiler"
|
||||
UHC -> "$pkgid"
|
||||
- _other -> "$pkgid" </> "$compiler",
|
||||
+ _other -> "$compiler" </> "$pkgid",
|
||||
dynlibdir = "$libdir",
|
||||
libexecdir = case buildOS of
|
||||
Windows -> "$prefix" </> "$pkgid"
|
104
ghc.spec
Normal file
104
ghc.spec
Normal file
@ -0,0 +1,104 @@
|
||||
%ifnarch %{ix86}
|
||||
%define bootstrap 1
|
||||
%endif
|
||||
Name: ghc
|
||||
Version: 7.6.3
|
||||
Release: 1mamba
|
||||
Summary: A compiler and interactive environment for the functional language Haskell.
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.haskell.org/ghc/
|
||||
Source: http://www.haskell.org/ghc/dist/%{version}/ghc-%{version}-src.tar.bz2
|
||||
Patch0: ghc-7.6.3-pkgdir.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgmp-devel
|
||||
BuildRequires: libncurses-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%if "%{bootstrap}" == "1"
|
||||
BuildRequires: ghc-bootstrap-compiler
|
||||
%else
|
||||
BuildRequires: ghc
|
||||
%endif
|
||||
Conflicts: ghc-bootstrap-compiler
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
GHC is a state-of-the-art, open source, compiler and interactive environment for the functional language Haskell.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#-D -T
|
||||
%patch0 -p1
|
||||
|
||||
%define _use_internal_dependency_generator 0
|
||||
%define __find_provides %{_builddir}/%{name}-%{version}/find_provides.sh
|
||||
cat > %{_builddir}/%{name}-%{version}/find_provides.sh <<_EOF
|
||||
#! /bin/sh
|
||||
%{_prefix}/lib/rpm/find-provides %{buildroot} %{_target_cpu} | \
|
||||
grep -v "libffi.so"
|
||||
exit 0
|
||||
_EOF
|
||||
chmod +x %{_builddir}/%{name}-%{version}/find_provides.sh
|
||||
|
||||
%define __find_requires %{_builddir}/%{name}-%{version}/find_requires.sh
|
||||
cat > %{_builddir}/%{name}-%{version}/find_requires.sh <<_EOF
|
||||
#! /bin/sh
|
||||
%{_prefix}/lib/rpm/find-requires %{buildroot} %{_target_cpu} 2>/dev/null
|
||||
exit 0
|
||||
_EOF
|
||||
chmod +x %{_builddir}/%{name}-%{version}/find_requires.sh
|
||||
|
||||
%build
|
||||
#:<< __EOF
|
||||
./configure \
|
||||
--prefix=%{_prefix} \
|
||||
--libdir=%{_libdir}
|
||||
|
||||
%make
|
||||
#__EOF
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/ghc
|
||||
%{_bindir}/ghc-%{version}
|
||||
%{_bindir}/ghc-pkg
|
||||
%{_bindir}/ghc-pkg-%{version}
|
||||
%{_bindir}/ghci
|
||||
%{_bindir}/ghci-%{version}
|
||||
%{_bindir}/haddock
|
||||
%{_bindir}/haddock-ghc-%{version}
|
||||
%{_bindir}/hp2ps
|
||||
%{_bindir}/hpc
|
||||
%{_bindir}/hsc2hs
|
||||
%{_bindir}/runghc
|
||||
%{_bindir}/runghc-%{version}
|
||||
%{_bindir}/runhaskell
|
||||
%dir %{_libdir}/ghc-%{version}
|
||||
%{_libdir}/ghc-%{version}/*
|
||||
%dir %{_datadir}/doc/ghc
|
||||
%dir %{_datadir}/doc/ghc/html
|
||||
%{_datadir}/doc/ghc/html/*
|
||||
%{_datadir}/doc/ghc/haddock.pdf
|
||||
%{_datadir}/doc/ghc/haddock.ps
|
||||
%{_datadir}/doc/ghc/users_guide.pdf
|
||||
%{_datadir}/doc/ghc/users_guide.ps
|
||||
%{_mandir}/man1/ghc.1*
|
||||
%doc LICENSE
|
||||
|
||||
%changelog
|
||||
* Sat Sep 07 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 7.6.3-1mamba
|
||||
- package created by silvan using the webbuild interface
|
Loading…
Reference in New Issue
Block a user