134 lines
4.0 KiB
RPMSpec
134 lines
4.0 KiB
RPMSpec
%define ghc_ver %(ghc --numeric-version)
|
|
%define pkg_name yaml
|
|
|
|
Name: ghc-yaml
|
|
Version: 0.11.11.2
|
|
Release: 2mamba
|
|
Summary: GHC library: Support for parsing and rendering YAML documents
|
|
Group: Development/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://hackage.haskell.org/package/%{pkg_name}
|
|
Source: http://hackage.haskell.org/package/yaml-%{version}/yaml-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: ghc-OneTuple-devel
|
|
BuildRequires: ghc-QuickCheck-devel
|
|
BuildRequires: ghc-StateVar-devel
|
|
BuildRequires: ghc-aeson-devel
|
|
BuildRequires: ghc-assoc-devel
|
|
BuildRequires: ghc-attoparsec-devel
|
|
BuildRequires: ghc-base-orphans-devel
|
|
BuildRequires: ghc-bifunctors-devel
|
|
BuildRequires: ghc-bitvec-devel
|
|
BuildRequires: ghc-comonad-devel
|
|
BuildRequires: ghc-conduit-devel
|
|
BuildRequires: ghc-contravariant-devel
|
|
BuildRequires: ghc-data-fix-devel
|
|
BuildRequires: ghc-distributive-devel
|
|
BuildRequires: ghc-dlist-devel
|
|
BuildRequires: ghc-foldable1-classes-compat-devel
|
|
BuildRequires: ghc-generically-devel
|
|
BuildRequires: ghc-hashable-devel
|
|
BuildRequires: ghc-indexed-traversable-devel
|
|
BuildRequires: ghc-indexed-traversable-instances-devel
|
|
BuildRequires: ghc-integer-conversion-devel
|
|
BuildRequires: ghc-integer-logarithms-devel
|
|
BuildRequires: ghc-libs
|
|
BuildRequires: ghc-libyaml-devel
|
|
BuildRequires: ghc-mono-traversable-devel
|
|
BuildRequires: ghc-network-uri-devel
|
|
BuildRequires: ghc-primitive-devel
|
|
BuildRequires: ghc-random-devel
|
|
BuildRequires: ghc-resourcet-devel
|
|
BuildRequires: ghc-scientific-devel
|
|
BuildRequires: ghc-semialign-devel
|
|
BuildRequires: ghc-semigroupoids-devel
|
|
BuildRequires: ghc-split-devel
|
|
BuildRequires: ghc-splitmix-devel
|
|
BuildRequires: ghc-strict-devel
|
|
BuildRequires: ghc-tagged-devel
|
|
BuildRequires: ghc-text-iso8601-devel
|
|
BuildRequires: ghc-text-short-devel
|
|
BuildRequires: ghc-th-abstraction-devel
|
|
BuildRequires: ghc-th-compat-devel
|
|
BuildRequires: ghc-these-devel
|
|
BuildRequires: ghc-time-compat-devel
|
|
BuildRequires: ghc-transformers-compat-devel
|
|
BuildRequires: ghc-unliftio-core-devel
|
|
BuildRequires: ghc-unordered-containers-devel
|
|
BuildRequires: ghc-uuid-types-devel
|
|
BuildRequires: ghc-vector-algorithms-devel
|
|
BuildRequires: ghc-vector-devel
|
|
BuildRequires: ghc-vector-stream-devel
|
|
BuildRequires: ghc-witherable-devel
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgmp-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ghc
|
|
BuildRequires: ghc-libyaml-devel >= 0.1.2-2mamba
|
|
Requires: ghc = %{ghc_ver}
|
|
|
|
%description
|
|
Support for parsing and rendering YAML documents.
|
|
|
|
%package devel
|
|
Summary: Haskell %{pkg_name} library development files
|
|
Provides: %{name}-static = %{version}-%{release}
|
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
|
%if %{defined ghc_version}
|
|
Requires: ghc = %{ghc_version}
|
|
%endif
|
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
|
|
%description devel
|
|
This package provides the Haskell %{pkg_name} library development files.
|
|
|
|
%if %{with haddock}
|
|
%package doc
|
|
Summary: Haskell %{pkg_name} library documentation
|
|
Requires: ghc-filesystem
|
|
|
|
%description doc
|
|
This package provides the Haskell %{pkg_name} library documentation.
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n yaml-%{version}
|
|
|
|
%build
|
|
%ghc_lib_build
|
|
|
|
%install
|
|
%ghc_lib_install
|
|
|
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f %{name}.files
|
|
%defattr(-,root,root)
|
|
%license LICENSE
|
|
|
|
%files devel -f %{name}-devel.files
|
|
%defattr(-,root,root)
|
|
#%doc CHANGELOG.markdown README.markdown
|
|
|
|
%if %{with haddock}
|
|
%files doc -f %{name}-doc.files
|
|
%defattr(-,root,root)
|
|
%license LICENSE
|
|
%endif
|
|
|
|
%changelog
|
|
* Sun Dec 03 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.11.11.2-2mamba
|
|
- rebuilt without ghc-exceptions-devel
|
|
|
|
* Sat Dec 02 2023 Automatic Build System <autodist@mambasoft.it> 0.11.11.2-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 13 2015 Davide Madrisan <davide.madrisan@gmail.com> 0.8.10.1-1mamba
|
|
- package created by autospec
|