package created using the webbuild interface [release 0.4.2-1mamba;Sat Dec 02 2023]
This commit is contained in:
parent
e4a43e9fc2
commit
fd9e76dd47
@ -1,2 +1,4 @@
|
|||||||
# ghc-witherable
|
# ghc-witherable
|
||||||
|
|
||||||
|
GHC witherable: filterable traversable.
|
||||||
|
|
||||||
|
18
ghc-witherable-0.4.2-ghc-9.4.8.patch
Normal file
18
ghc-witherable-0.4.2-ghc-9.4.8.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- witherable-0.4.2/witherable.cabal.orig 2023-12-02 17:36:44.265610695 +0100
|
||||||
|
+++ witherable-0.4.2/witherable.cabal 2023-12-02 17:37:18.332779814 +0100
|
||||||
|
@@ -24,12 +24,12 @@
|
||||||
|
Witherable
|
||||||
|
Data.Witherable
|
||||||
|
build-depends: base >=4.9 && <5,
|
||||||
|
- base-orphans >=0.8.4 && <0.9,
|
||||||
|
+ base-orphans >=0.8.4 && <0.10,
|
||||||
|
containers >=0.5.7.1 && <0.7,
|
||||||
|
- hashable >=1.2.7.0 && <1.4,
|
||||||
|
+ hashable >=1.2.7.0 && <1.5,
|
||||||
|
transformers >=0.5.2.0 && <0.6,
|
||||||
|
unordered-containers >=0.2.12.0 && <0.3,
|
||||||
|
- vector >=0.12.2.0 && <0.13,
|
||||||
|
+ vector >=0.12.2.0 && <0.14,
|
||||||
|
indexed-traversable >=0.1.1 && <0.2,
|
||||||
|
indexed-traversable-instances >=0.1 && <0.2
|
||||||
|
hs-source-dirs: src
|
91
ghc-witherable.spec
Normal file
91
ghc-witherable.spec
Normal file
@ -0,0 +1,91 @@
|
|||||||
|
%define ghc_ver %(ghc --numeric-version)
|
||||||
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||||
|
|
||||||
|
Name: ghc-witherable
|
||||||
|
Version: 0.4.2
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GHC witherable: filterable traversable
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source: https://hackage.haskell.org/package/witherable-%{version}/witherable-%{version}.tar.gz
|
||||||
|
Patch0: ghc-witherable-0.4.2-ghc-9.4.8.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghc-OneTuple-devel
|
||||||
|
BuildRequires: ghc-base-orphans-devel
|
||||||
|
BuildRequires: ghc-foldable1-classes-compat-devel
|
||||||
|
BuildRequires: ghc-hashable-devel
|
||||||
|
BuildRequires: ghc-indexed-traversable-devel
|
||||||
|
BuildRequires: ghc-indexed-traversable-instances-devel
|
||||||
|
BuildRequires: ghc-libs
|
||||||
|
BuildRequires: ghc-primitive-devel
|
||||||
|
BuildRequires: ghc-tagged-devel
|
||||||
|
BuildRequires: ghc-unordered-containers-devel
|
||||||
|
BuildRequires: ghc-vector-devel
|
||||||
|
BuildRequires: ghc-vector-stream-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ghc
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
Requires: ghc = %{ghc_ver}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%package doc
|
||||||
|
Summary: Haskell %{pkg_name} library documentation
|
||||||
|
Requires: ghc-filesystem
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package provides the Haskell %{pkg_name} library documentation.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n witherable-%{version}
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%doc CHANGELOG.markdown README.markdown
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%files doc -f %{name}-doc.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Dec 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.2-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user