package created using the webbuild interface [release 0.9.0.1-1mamba;Sat Dec 02 2023]
This commit is contained in:
parent
e2f79c853b
commit
fa44d8402c
@ -1,2 +1,4 @@
|
||||
# ghc-vector-algorithms
|
||||
|
||||
GHC vector-algorithms: Efficient algorithms for vector arrays.
|
||||
|
||||
|
11
ghc-vector-algorithms-0.9.0.1-primitive-0.9.patch
Normal file
11
ghc-vector-algorithms-0.9.0.1-primitive-0.9.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- vector-algorithms-0.9.0.1/vector-algorithms.cabal.orig 2023-12-02 22:23:03.733452421 +0100
|
||||
+++ vector-algorithms-0.9.0.1/vector-algorithms.cabal 2023-12-02 22:23:11.838420167 +0100
|
||||
@@ -59,7 +59,7 @@
|
||||
build-depends: base >= 4.5 && < 5,
|
||||
bitvec >= 1.0 && < 1.2,
|
||||
vector >= 0.6 && < 0.14,
|
||||
- primitive >=0.3 && <0.8,
|
||||
+ primitive >=0.3 && <0.9,
|
||||
bytestring >= 0.9 && < 1.0
|
||||
|
||||
if ! impl (ghc >= 7.8)
|
84
ghc-vector-algorithms.spec
Normal file
84
ghc-vector-algorithms.spec
Normal file
@ -0,0 +1,84 @@
|
||||
%define ghc_ver %(ghc --numeric-version)
|
||||
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||
|
||||
Name: ghc-vector-algorithms
|
||||
Version: 0.9.0.1
|
||||
Release: 1mamba
|
||||
Summary: GHC vector-algorithms: Efficient algorithms for vector arrays
|
||||
Group: Development/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://hackage.haskell.org/package/%{pkg_name}
|
||||
Source: https://hackage.haskell.org/package/vector-algorithms-%{version}/vector-algorithms-%{version}.tar.gz
|
||||
Patch0: ghc-vector-algorithms-0.9.0.1-primitive-0.9.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: ghc-bitvec-devel
|
||||
BuildRequires: ghc-libs
|
||||
BuildRequires: ghc-primitive-devel
|
||||
BuildRequires: ghc-vector-devel
|
||||
BuildRequires: ghc-vector-stream-devel
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libgmp-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: ghc
|
||||
BuildRequires: ghc-rpm-macros
|
||||
Requires: ghc = %{ghc_ver}
|
||||
|
||||
%description
|
||||
%{summary}.
|
||||
|
||||
%package devel
|
||||
Summary: Haskell %{pkg_name} library development files
|
||||
Provides: %{name}-static = %{version}-%{release}
|
||||
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||
%if %{defined ghc_version}
|
||||
Requires: ghc = %{ghc_version}
|
||||
%endif
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
This package provides the Haskell %{pkg_name} library development files.
|
||||
|
||||
%if %{with haddock}
|
||||
%package doc
|
||||
Summary: Haskell %{pkg_name} library documentation
|
||||
Requires: ghc-filesystem
|
||||
|
||||
%description doc
|
||||
This package provides the Haskell %{pkg_name} library documentation.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n vector-algorithms-%{version}
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
%ghc_lib_build
|
||||
|
||||
%install
|
||||
%ghc_lib_install
|
||||
|
||||
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.files
|
||||
%defattr(-,root,root)
|
||||
%license LICENSE
|
||||
|
||||
%files devel -f %{name}-devel.files
|
||||
%defattr(-,root,root)
|
||||
#%doc CHANGELOG.markdown README.markdown
|
||||
|
||||
%if %{with haddock}
|
||||
%files doc -f %{name}-doc.files
|
||||
%defattr(-,root,root)
|
||||
%license LICENSE
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Sat Dec 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.0.1-1mamba
|
||||
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user