package created using the webbuild interface [release 0.1.5-1mamba;Sat Dec 02 2023]
This commit is contained in:
parent
7406d8598d
commit
1afc7e6fe0
@ -1,2 +1,4 @@
|
|||||||
# ghc-text-short
|
# ghc-text-short
|
||||||
|
|
||||||
|
GHC text-short: Memory-efficient representation of Unicode text strings.
|
||||||
|
|
||||||
|
20
ghc-text-short-0.1.5-ghc-9.4.8.patch
Normal file
20
ghc-text-short-0.1.5-ghc-9.4.8.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- text-short-0.1.5/text-short.cabal.orig 2023-12-02 17:28:54.398864806 +0100
|
||||||
|
+++ text-short-0.1.5/text-short.cabal 2023-12-02 17:29:41.729188141 +0100
|
||||||
|
@@ -32,14 +32,14 @@
|
||||||
|
|
||||||
|
other-modules: Data.Text.Short.Internal
|
||||||
|
|
||||||
|
- build-depends: base >= 4.7 && < 4.17
|
||||||
|
+ build-depends: base >= 4.7 && < 4.19
|
||||||
|
, bytestring >= 0.10.4 && < 0.12
|
||||||
|
, hashable >= 1.2.6 && < 1.5
|
||||||
|
, deepseq >= 1.3 && < 1.5
|
||||||
|
, text >= 1.0 && < 1.3 || >=2.0 && <2.1
|
||||||
|
, binary >= 0.7.1 && < 0.9
|
||||||
|
- , ghc-prim >= 0.3.1 && < 0.9
|
||||||
|
- , template-haskell >= 2.9.0.0 && <2.19
|
||||||
|
+ , ghc-prim >= 0.3.1 && < 0.10
|
||||||
|
+ , template-haskell >= 2.9.0.0 && <2.20
|
||||||
|
|
||||||
|
if impl(ghc >=8.0)
|
||||||
|
build-depends: bytestring >= 0.10.8.0
|
81
ghc-text-short.spec
Normal file
81
ghc-text-short.spec
Normal file
@ -0,0 +1,81 @@
|
|||||||
|
%define ghc_ver %(ghc --numeric-version)
|
||||||
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||||
|
|
||||||
|
Name: ghc-text-short
|
||||||
|
Version: 0.1.5
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GHC text-short: Memory-efficient representation of Unicode text strings
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source: https://hackage.haskell.org/package/text-short-%{version}/text-short-%{version}.tar.gz
|
||||||
|
Patch0: ghc-text-short-0.1.5-ghc-9.4.8.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghc-hashable-devel
|
||||||
|
BuildRequires: ghc-libs
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ghc
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
Requires: ghc = %{ghc_ver}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%package doc
|
||||||
|
Summary: Haskell %{pkg_name} library documentation
|
||||||
|
Requires: ghc-filesystem
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package provides the Haskell %{pkg_name} library documentation.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n text-short-%{version}
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%doc CHANGELOG.markdown README.markdown
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%files doc -f %{name}-doc.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Dec 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.5-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user