package created using the webbuild interface [release 2.5.3~007effd-1mamba;Sun Nov 12 2023]
This commit is contained in:
parent
fd8e1510ec
commit
3ebf0152fc
@ -1,2 +1,3 @@
|
|||||||
# ghc-rpm-macros
|
# ghc-rpm-macros
|
||||||
|
|
||||||
|
RPM macros for building Haskell packages for GHC.
|
||||||
|
24
ghc-rpm-macros-2.5.3-openmamba.patch
Normal file
24
ghc-rpm-macros-2.5.3-openmamba.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
diff -Nru ghc-rpm-macros-2.5.3~007effd.orig/macros.ghc ghc-rpm-macros-2.5.3~007effd/macros.ghc
|
||||||
|
--- ghc-rpm-macros-2.5.3~007effd.orig/macros.ghc 2023-11-12 11:07:40.000000000 +0100
|
||||||
|
+++ ghc-rpm-macros-2.5.3~007effd/macros.ghc 2023-11-12 11:54:23.010525844 +0100
|
||||||
|
@@ -7,7 +7,7 @@
|
||||||
|
./Setup
|
||||||
|
|
||||||
|
# compiler version
|
||||||
|
-%ghc_version %{?ghc_version_override}%{!?ghc_version_override:%(rpm -q --qf %%{version} %{?ghc_name}%{!?ghc_name:ghc}-compiler)}
|
||||||
|
+%ghc_version %{?ghc_version_override}%{!?ghc_version_override:%(rpm -q --qf %%{version} %{?ghc_name}%{!?ghc_name:ghc})}
|
||||||
|
|
||||||
|
%ghc_major_version %(echo %{ghc_version} | sed -e "s/\\(.*\\)\\.[0-9]\\+/\\1/")
|
||||||
|
|
||||||
|
diff -Nru ghc-rpm-macros-2.5.3~007effd.orig/macros.ghc-extra ghc-rpm-macros-2.5.3~007effd/macros.ghc-extra
|
||||||
|
--- ghc-rpm-macros-2.5.3~007effd.orig/macros.ghc-extra 2023-11-12 11:07:40.000000000 +0100
|
||||||
|
+++ ghc-rpm-macros-2.5.3~007effd/macros.ghc-extra 2023-11-12 11:55:04.558493782 +0100
|
||||||
|
@@ -34,7 +34,7 @@
|
||||||
|
%{-l:License: %{-l*}}\
|
||||||
|
Provides: %{basepkg}-static = %{pkgver}-%{release}\
|
||||||
|
Provides: %{basepkg}-static%{?_isa} = %{pkgver}-%{release}\
|
||||||
|
-Requires: %{ghc_prefix}-compiler = %{ghc_version}%{?ghc_version_override:-%{release}}\
|
||||||
|
+Requires: %{ghc_prefix} = %{ghc_version}%{?ghc_version_override:-%{release}}\
|
||||||
|
%if 0%{!-m:1}\
|
||||||
|
Requires: %{ghc_prefix}-%{pkgname}%{?_isa} = %{pkgver}-%{release}\
|
||||||
|
%endif\
|
65
ghc-rpm-macros.spec
Normal file
65
ghc-rpm-macros.spec
Normal file
@ -0,0 +1,65 @@
|
|||||||
|
%define commit %(echo %version | cut -d~ -f2)
|
||||||
|
Name: ghc-rpm-macros
|
||||||
|
Version: 2.5.3~007effd
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: RPM macros for building Haskell packages for GHC
|
||||||
|
Group: Development/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://src.fedoraproject.org/rpms/ghc-rpm-macros/
|
||||||
|
Source: https://github.com/fedora-riscv/ghc-rpm-macros.git/main@%{commit}/ghc-rpm-macros-%{version}.tar.bz2
|
||||||
|
Patch0: ghc-rpm-macros-2.5.3-openmamba.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
|
||||||
|
%description
|
||||||
|
RPM macros for building Haskell packages for GHC.
|
||||||
|
|
||||||
|
#% debug_package
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
install -p -D -m 0644 macros.ghc %{buildroot}%{_rpmmacrodir}/macros.ghc
|
||||||
|
install -p -D -m 0644 macros.ghc-extra %{buildroot}%{_rpmmacrodir}/macros.ghc-extra
|
||||||
|
install -p -D -m 0644 macros.ghc-os %{buildroot}%{_rpmmacrodir}/macros.ghc-os
|
||||||
|
install -p -D -m 0755 ghc-deps.sh %{buildroot}%{_rpmconfigdir}/ghc-deps.sh
|
||||||
|
install -p -D -m 0644 ghc.attr %{buildroot}%{_fileattrsdir}/ghc.attr
|
||||||
|
install -p -D -m 0644 Setup.hs %{buildroot}%{_datadir}/%{name}/Setup.hs
|
||||||
|
install -p -D -m 0755 cabal-tweak-dep-ver %{buildroot}%{_bindir}/cabal-tweak-dep-ver
|
||||||
|
install -p -D -m 0755 cabal-tweak-flag %{buildroot}%{_bindir}/cabal-tweak-flag
|
||||||
|
install -p -D -m 0755 cabal-tweak-drop-dep %{buildroot}%{_bindir}/cabal-tweak-drop-dep
|
||||||
|
install -p -D -m 0755 cabal-tweak-remove-upperbound %{buildroot}%{_bindir}/cabal-tweak-remove-upperbound
|
||||||
|
install -p -D -m 0755 ghc-pkg-wrapper %{buildroot}%{_rpmconfigdir}/ghc-pkg-wrapper
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/cabal-tweak-dep-ver
|
||||||
|
%{_bindir}/cabal-tweak-drop-dep
|
||||||
|
%{_bindir}/cabal-tweak-flag
|
||||||
|
%{_bindir}/cabal-tweak-remove-upperbound
|
||||||
|
%{_fileattrsdir}/ghc.attr
|
||||||
|
%{_rpmconfigdir}/ghc-deps.sh
|
||||||
|
%{_rpmconfigdir}/ghc-pkg-wrapper
|
||||||
|
%{_rpmmacrodir}/macros.ghc
|
||||||
|
%{_rpmmacrodir}/macros.ghc-extra
|
||||||
|
%{_rpmmacrodir}/macros.ghc-os
|
||||||
|
%dir %{_datadir}/ghc-rpm-macros
|
||||||
|
%{_datadir}/ghc-rpm-macros/Setup.hs
|
||||||
|
%doc AUTHORS COPYING
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Nov 12 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 2.5.3~007effd-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user