package created using the webbuild interface [release 0.18.0-1mamba;Sun Dec 03 2023]

This commit is contained in:
Silvan Calarco 2024-01-05 22:52:17 +01:00
parent 9a84c9d349
commit e92cc60a80
3 changed files with 106 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# ghc-memory # ghc-memory
GHC memory: memory and related abstraction stuff.

View File

@ -0,0 +1,23 @@
--- memory-0.17.0/Data/Memory/Internal/CompatPrim64.hs.orig 2019-09-02 10:59:04.000000000 +0800
+++ memory-0.17.0/Data/Memory/Internal/CompatPrim64.hs 2023-02-17 02:13:44.131991990 +0800
@@ -148,14 +148,14 @@
w64# w _ _ = w
#elif WORD_SIZE_IN_BITS == 32
-import GHC.IntWord64
+import GHC.Exts
import GHC.Prim (Word#)
-timesWord64# :: Word64# -> Word64# -> Word64#
-timesWord64# a b =
- let !ai = word64ToInt64# a
- !bi = word64ToInt64# b
- in int64ToWord64# (timesInt64# ai bi)
+-- timesWord64# :: Word64# -> Word64# -> Word64#
+-- timesWord64# a b =
+-- let !ai = word64ToInt64# a
+-- !bi = word64ToInt64# b
+-- in int64ToWord64# (timesInt64# ai bi)
w64# :: Word# -> Word# -> Word# -> Word64#
w64# _ hw lw =

81
ghc-memory.spec Normal file
View File

@ -0,0 +1,81 @@
%define ghc_ver %(ghc --numeric-version)
%define pkg_name %(echo %name | sed "s|^ghc-||")
Name: ghc-memory
Version: 0.18.0
Release: 1mamba
Summary: GHC memory: memory and related abstraction stuff
Group: Development/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://hackage.haskell.org/package/%{pkg_name}
Source: https://hackage.haskell.org/package/memory-%{version}/memory-%{version}.tar.gz
Patch0: ghc-memory-0.18.0-i386-Word64.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: ghc-basement-devel
BuildRequires: ghc-libs
BuildRequires: glibc-devel
BuildRequires: libgmp-devel
## AUTOBUILDREQ-END
BuildRequires: ghc
BuildRequires: ghc-rpm-macros
Requires: ghc = %{ghc_ver}
%description
%{summary}.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{?epoch:%epoch:}%{version}-%{release}
Provides: %{name}-static%{?_isa} = %{?epoch:%epoch:}%{version}-%{release}
%if %{defined ghc_version}
Requires: ghc = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%prep
%setup -q -n memory-%{version}
%patch 0 -p1 -b .i386-Word64
%build
%ghc_lib_build
%install
%ghc_lib_install
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.files
%defattr(-,root,root)
%license LICENSE
%files devel -f %{name}-devel.files
%defattr(-,root,root)
#%doc CHANGELOG.markdown README.markdown
%if %{with haddock}
%files doc -f %{name}-doc.files
%defattr(-,root,root)
%license LICENSE
%endif
%changelog
* Sun Dec 03 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.18.0-1mamba
- package created using the webbuild interface