rebuilt without ghc-exceptions-devel [release 0.1.2-2mamba;Sun Dec 03 2023]
This commit is contained in:
parent
1f571ffa22
commit
3097fac4db
@ -1,2 +1,4 @@
|
|||||||
# ghc-libyaml
|
# ghc-libyaml
|
||||||
|
|
||||||
|
GHC libyaml: Low-level, streaming YAML interface.
|
||||||
|
|
||||||
|
11
ghc-libyaml-0.1.2-resourcet-1.3.patch
Normal file
11
ghc-libyaml-0.1.2-resourcet-1.3.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- libyaml-0.1.2/libyaml.cabal.orig 2023-12-02 23:53:06.224579919 +0100
|
||||||
|
+++ libyaml-0.1.2/libyaml.cabal 2023-12-02 23:53:19.540592206 +0100
|
||||||
|
@@ -57,7 +57,7 @@
|
||||||
|
base >=4.9.1 && <5
|
||||||
|
, bytestring >=0.9.1.4
|
||||||
|
, conduit >=1.2.8 && <1.4
|
||||||
|
- , resourcet >=0.3 && <1.3
|
||||||
|
+ , resourcet >=0.3 && <1.4
|
||||||
|
if flag(no-unicode)
|
||||||
|
cpp-options: -D__NO_UNICODE__
|
||||||
|
if !(flag(system-libyaml))
|
96
ghc-libyaml.spec
Normal file
96
ghc-libyaml.spec
Normal file
@ -0,0 +1,96 @@
|
|||||||
|
%define ghc_ver %(ghc --numeric-version)
|
||||||
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||||
|
|
||||||
|
Name: ghc-libyaml
|
||||||
|
Version: 0.1.2
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: GHC libyaml: Low-level, streaming YAML interface
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source: https://hackage.haskell.org/package/libyaml-%{version}/libyaml-%{version}.tar.gz
|
||||||
|
Patch0: ghc-libyaml-0.1.2-resourcet-1.3.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghc-bitvec-devel
|
||||||
|
BuildRequires: ghc-conduit-devel
|
||||||
|
BuildRequires: ghc-hashable-devel
|
||||||
|
BuildRequires: ghc-libs
|
||||||
|
BuildRequires: ghc-mono-traversable-devel
|
||||||
|
BuildRequires: ghc-primitive-devel
|
||||||
|
BuildRequires: ghc-resourcet-devel
|
||||||
|
BuildRequires: ghc-split-devel
|
||||||
|
BuildRequires: ghc-unliftio-core-devel
|
||||||
|
BuildRequires: ghc-unordered-containers-devel
|
||||||
|
BuildRequires: ghc-vector-algorithms-devel
|
||||||
|
BuildRequires: ghc-vector-devel
|
||||||
|
BuildRequires: ghc-vector-stream-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ghc
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
BuildRequires: ghc-conduit-devel >= 1.3.5-2mamba
|
||||||
|
Requires: ghc = %{ghc_ver}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%package doc
|
||||||
|
Summary: Haskell %{pkg_name} library documentation
|
||||||
|
Requires: ghc-filesystem
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package provides the Haskell %{pkg_name} library documentation.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n libyaml-%{version}
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%doc CHANGELOG.markdown README.markdown
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%files doc -f %{name}-doc.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Dec 03 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.2-2mamba
|
||||||
|
- rebuilt without ghc-exceptions-devel
|
||||||
|
|
||||||
|
* Sat Dec 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.1.2-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user