package created using the webbuild interface [release 1.0.3.1-1mamba;Sat Dec 02 2023]
This commit is contained in:
parent
65ba9193a5
commit
6ed33bed07
@ -1,2 +1,4 @@
|
|||||||
# ghc-integer-logarithms
|
# ghc-integer-logarithms
|
||||||
|
|
||||||
|
GHC integer-logarithms: Integer logarithms.
|
||||||
|
|
||||||
|
80
ghc-integer-logarithms.spec
Normal file
80
ghc-integer-logarithms.spec
Normal file
@ -0,0 +1,80 @@
|
|||||||
|
%define ghc_ver %(ghc --numeric-version)
|
||||||
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||||
|
|
||||||
|
Name: ghc-integer-logarithms
|
||||||
|
Version: 1.0.3.1
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GHC integer-logarithms: Integer logarithms
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source: https://hackage.haskell.org/package/integer-logarithms-%{version}/integer-logarithms-%{version}.tar.gz
|
||||||
|
Patch0: integer-logarithms-1.0.3.1-ghc-9.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghc-libs
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ghc
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
Requires: ghc = %{ghc_ver}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%package doc
|
||||||
|
Summary: Haskell %{pkg_name} library documentation
|
||||||
|
Requires: ghc-filesystem
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package provides the Haskell %{pkg_name} library documentation.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n integer-logarithms-%{version}
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%doc CHANGELOG.markdown README.markdown
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%files doc -f %{name}-doc.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Dec 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.3.1-1mamba
|
||||||
|
- package created using the webbuild interface
|
22
integer-logarithms-1.0.3.1-ghc-9.patch
Normal file
22
integer-logarithms-1.0.3.1-ghc-9.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- integer-logarithms-1.0.3.1/integer-logarithms.cabal.orig 2023-12-02 16:13:00.230724310 +0100
|
||||||
|
+++ integer-logarithms-1.0.3.1/integer-logarithms.cabal 2023-12-02 16:14:06.329272167 +0100
|
||||||
|
@@ -56,8 +56,8 @@
|
||||||
|
hs-source-dirs: src
|
||||||
|
build-depends:
|
||||||
|
array >=0.3 && <0.6
|
||||||
|
- , base >=4.3 && <4.16
|
||||||
|
- , ghc-prim >=0 && <0.8
|
||||||
|
+ , base >=4.3 && <4.19
|
||||||
|
+ , ghc-prim >=0 && <0.10
|
||||||
|
|
||||||
|
if !impl(ghc >=7.10)
|
||||||
|
build-depends: nats >=1.1.2 && <1.2
|
||||||
|
@@ -65,7 +65,7 @@
|
||||||
|
if impl(ghc >=9.0)
|
||||||
|
build-depends:
|
||||||
|
base >=4.15
|
||||||
|
- , ghc-bignum >=1.0 && <1.1
|
||||||
|
+ , ghc-bignum >=1.0 && <1.4
|
||||||
|
|
||||||
|
if !flag(integer-gmp)
|
||||||
|
build-depends: invalid-cabal-flag-settings <0
|
Loading…
Reference in New Issue
Block a user