64 lines
2.2 KiB
RPMSpec
64 lines
2.2 KiB
RPMSpec
%define ghc_ver %(ghc --version | sed "s|.*version ||")
|
|
%define pkgname %(echo %name | sed "s|^ghc-||")
|
|
Name: ghc-hexpat
|
|
Version: 0.20.3
|
|
Release: 1mamba
|
|
Summary: A general purpose Haskell XML library using Expat to do its parsing
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://hackage.haskell.org/package/%{pkgname}
|
|
Source: http://hackage.haskell.org/packages/archive/hexpat/%{version}/hexpat-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ghc
|
|
BuildRequires: ghc-List
|
|
BuildRequires: ghc-extensible-exceptions
|
|
BuildRequires: ghc-utf8-string
|
|
Requires: ghc-extensible-exceptions
|
|
Requires: ghc-List
|
|
Requires: ghc-utf8-string
|
|
Requires: ghc = %{ghc_ver}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
This package provides a general purpose Haskell XML library using Expat to do its parsing (http://expat.sourceforge.net/ - a fast stream-oriented XML parser written in C). It is extensible to any string type, with String, ByteString and Text provided out of the box.
|
|
|
|
%prep
|
|
%setup -q -n hexpat-%{version}
|
|
|
|
%build
|
|
runghc Setup.lhs configure \
|
|
--prefix=%{_prefix} --libdir=%{_libdir}
|
|
|
|
runghc Setup.lhs build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
runghc Setup.lhs copy --destdir=%{buildroot}
|
|
runghc Setup.lhs register \
|
|
--gen-pkg-config="%{buildroot}%{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf"
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
ghc-pkg register %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf &>/dev/null || true
|
|
:
|
|
|
|
%preun
|
|
ghc-pkg unregister %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf &>/dev/null || true
|
|
:
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%dir %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}
|
|
%{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/*
|
|
%{_datadir}/doc/%{pkgname}-%{version}/LICENSE
|
|
|
|
%changelog
|
|
* Sun Sep 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.20.3-1mamba
|
|
- package created by silvan using the webbuild interface
|