package created using the webbuild interface [release 0.3.1-1mamba;Sun Dec 03 2023]
This commit is contained in:
parent
7774ec9654
commit
a8b0407c46
@ -1,2 +1,4 @@
|
|||||||
# ghc-digits
|
# ghc-digits
|
||||||
|
|
||||||
|
GHC digits: Converts integers to lists of digits and back.
|
||||||
|
|
||||||
|
9
ghc-digits-0.3.1-fix-build.patch
Normal file
9
ghc-digits-0.3.1-fix-build.patch
Normal file
@ -0,0 +1,9 @@
|
|||||||
|
--- digits-0.3.1/Setup.lhs.orig 2023-12-03 15:07:18.493189958 +0100
|
||||||
|
+++ digits-0.3.1/Setup.lhs 2023-12-03 15:07:30.971271989 +0100
|
||||||
|
@@ -3,5 +3,5 @@
|
||||||
|
> import Distribution.Simple
|
||||||
|
> import System.Cmd
|
||||||
|
> tests _ _ _ _ = system "runhaskell src/Tests.hs" >> return ()
|
||||||
|
-> main = defaultMainWithHooks (simpleUserHooks {runTests = tests})
|
||||||
|
+> main = defaultMainWithHooks (simpleUserHooks)
|
||||||
|
|
83
ghc-digits.spec
Normal file
83
ghc-digits.spec
Normal file
@ -0,0 +1,83 @@
|
|||||||
|
%define ghc_ver %(ghc --numeric-version)
|
||||||
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||||
|
|
||||||
|
Name: ghc-digits
|
||||||
|
Version: 0.3.1
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GHC digits: Converts integers to lists of digits and back
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: https://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source: https://hackage.haskell.org/package/digits-%{version}/digits-%{version}.tar.gz
|
||||||
|
Patch0: ghc-digits-0.3.1-fix-build.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghc-QuickCheck-devel
|
||||||
|
BuildRequires: ghc-libs
|
||||||
|
BuildRequires: ghc-random-devel
|
||||||
|
BuildRequires: ghc-splitmix-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ghc
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
Requires: ghc = %{ghc_ver}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
Provides: %{name}-static%{?_isa} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%package doc
|
||||||
|
Summary: Haskell %{pkg_name} library documentation
|
||||||
|
Requires: ghc-filesystem
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package provides the Haskell %{pkg_name} library documentation.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n digits-%{version}
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%doc CHANGELOG.markdown README.markdown
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%files doc -f %{name}-doc.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sun Dec 03 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.3.1-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user