ghc-digest/ghc-digest.spec

86 lines
2.5 KiB
RPMSpec

%define ghc_ver %(ghc --version | sed "s|.*version ||")
%define pkg_name %(echo %name | sed "s|^ghc-||")
Name: ghc-digest
Version: 0.0.1.7
Release: 1mamba
Summary: Provides efficient cryptographic hash implementations for strict and lazy bytestrings
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: https://hackage.haskell.org/package/digest
Source: http://hackage.haskell.org/packages/archive/digest/%{version}/digest-%{version}.tar.gz
License: BSD
## AUTOBUILDREQ-BEGIN
#ghc-devel(base-4.17.2.1): unidentified build requirement
#ghc-devel(bytestring-0.11.5.3): unidentified build requirement
BuildRequires: ghc
BuildRequires: glibc-devel
BuildRequires: libgmp-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRequires: ghc
Requires: ghc = %{ghc_ver}
%description
This package provides efficient cryptographic hash implementations for strict and lazy bytestrings. For now, CRC32 and Adler32 are supported; they are implemented as FFI bindings to efficient code from zlib.
%package devel
Summary: Haskell %{pkg_name} library development files
Provides: %{name}-static = %{version}-%{release}
Provides: %{name}-static%{?_isa} = %{version}-%{release}
%if %{defined ghc_version}
Requires: ghc = %{ghc_version}
%endif
Requires: %{name}%{?_isa} = %{version}-%{release}
%description devel
This package provides the Haskell %{pkg_name} library development files.
%if %{with haddock}
%package doc
Summary: Haskell %{pkg_name} library documentation
Requires: ghc-filesystem
%description doc
This package provides the Haskell %{pkg_name} library documentation.
%endif
%prep
%setup -q -n digest-%{version}
%build
%ghc_lib_build
%install
%ghc_lib_install
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f %{name}.files
%defattr(-,root,root)
%license LICENSE
%files devel -f %{name}-devel.files
%defattr(-,root,root)
%doc CHANGELOG.md
%if %{with haddock}
%files doc -f %{name}-doc.files
%defattr(-,root,root)
%license LICENSE
%endif
%changelog
* Mon Nov 13 2023 Automatic Build System <autodist@mambasoft.it> 0.0.1.7-1mamba
- automatic version update by autodist
* Fri Jul 09 2021 Automatic Build System <autodist@mambasoft.it> 0.0.1.3-1mamba
- automatic version update by autodist
* Sun Sep 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.1.2-1mamba
- package created by silvan using the webbuild interface