58 lines
1.8 KiB
RPMSpec
58 lines
1.8 KiB
RPMSpec
%define ghc_ver %(ghc --version | sed "s|.*version ||")
|
|
%define pkgname %(echo %name | sed "s|^ghc-||")
|
|
Name: ghc-data-default-class
|
|
Version: 0.0.1
|
|
Release: 1mamba
|
|
Summary: A class for types with a default value
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://hackage.haskell.org/package/%{pkgname}
|
|
Source: http://hackage.haskell.org/packages/archive/data-default-class/%{version}/data-default-class-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ghc
|
|
Requires: ghc = %{ghc_ver}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
A class for types with a default value.
|
|
|
|
%prep
|
|
%setup -q -n data-default-class-%{version}
|
|
|
|
%build
|
|
runghc Setup.lhs configure \
|
|
--prefix=%{_prefix} --libdir=%{_libdir}
|
|
|
|
runghc Setup.lhs build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
runghc Setup.lhs copy --destdir=%{buildroot}
|
|
runghc Setup.lhs register \
|
|
--gen-pkg-config="%{buildroot}%{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf"
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
ghc-pkg register %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf &>/dev/null || true
|
|
:
|
|
|
|
%preun
|
|
ghc-pkg unregister %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/%{pkgname}-%{version}.conf &>/dev/null || true
|
|
:
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%dir %{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}
|
|
%{_libdir}/ghc-%{ghc_ver}/%{pkgname}-%{version}/*
|
|
%{_datadir}/doc/%{pkgname}-%{version}/LICENSE
|
|
|
|
%changelog
|
|
* Sun Sep 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.0.1-1mamba
|
|
- package created by silvan using the webbuild interface
|