package created using the webbuild interface [release 0.4.2.4-1mamba;Sat Dec 02 2023]
This commit is contained in:
parent
b11fa4214c
commit
1392feced4
@ -1,2 +1,4 @@
|
|||||||
# ghc-base64
|
# ghc-base64
|
||||||
|
|
||||||
|
GHC base64: A modern RFC 4648-compliant Base64 library.
|
||||||
|
|
||||||
|
15
ghc-base64-0.4.2.4-ghc-9.4.8.patch
Normal file
15
ghc-base64-0.4.2.4-ghc-9.4.8.patch
Normal file
@ -0,0 +1,15 @@
|
|||||||
|
--- base64-0.4.2.4/base64.cabal.orig 2023-12-02 19:42:30.464387312 +0100
|
||||||
|
+++ base64-0.4.2.4/base64.cabal 2023-12-02 19:43:03.682351660 +0100
|
||||||
|
@@ -51,10 +51,10 @@
|
||||||
|
Data.ByteString.Base64.Internal.W64.Loop
|
||||||
|
|
||||||
|
build-depends:
|
||||||
|
- base >=4.14 && <4.17
|
||||||
|
+ base >=4.14 && <4.18
|
||||||
|
, bytestring >=0.10 && <0.12
|
||||||
|
, deepseq >=1.4.3.0 && <1.5
|
||||||
|
- , text ^>=1.2
|
||||||
|
+ , text >=1.2
|
||||||
|
, text-short ^>=0.1
|
||||||
|
|
||||||
|
hs-source-dirs: src
|
82
ghc-base64.spec
Normal file
82
ghc-base64.spec
Normal file
@ -0,0 +1,82 @@
|
|||||||
|
%define ghc_ver %(ghc --numeric-version)
|
||||||
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
||||||
|
|
||||||
|
Name: ghc-base64
|
||||||
|
Version: 0.4.2.4
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: GHC base64: A modern RFC 4648-compliant Base64 library
|
||||||
|
Group: Development/Libraries
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://hackage.haskell.org/package/%{pkg_name}
|
||||||
|
Source: https://hackage.haskell.org/package/base64-%{version}/base64-%{version}.tar.gz
|
||||||
|
Patch0: ghc-base64-0.4.2.4-ghc-9.4.8.patch
|
||||||
|
License: BSD
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghc-hashable-devel
|
||||||
|
BuildRequires: ghc-libs
|
||||||
|
BuildRequires: ghc-text-short-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libgmp-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: ghc
|
||||||
|
BuildRequires: ghc-rpm-macros
|
||||||
|
Requires: ghc = %{ghc_ver}
|
||||||
|
|
||||||
|
%description
|
||||||
|
%{summary}.
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Haskell %{pkg_name} library development files
|
||||||
|
Provides: %{name}-static = %{version}-%{release}
|
||||||
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
||||||
|
%if %{defined ghc_version}
|
||||||
|
Requires: ghc = %{ghc_version}
|
||||||
|
%endif
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
This package provides the Haskell %{pkg_name} library development files.
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%package doc
|
||||||
|
Summary: Haskell %{pkg_name} library documentation
|
||||||
|
Requires: ghc-filesystem
|
||||||
|
|
||||||
|
%description doc
|
||||||
|
This package provides the Haskell %{pkg_name} library documentation.
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n base64-%{version}
|
||||||
|
%patch 0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%ghc_lib_build
|
||||||
|
|
||||||
|
%install
|
||||||
|
%ghc_lib_install
|
||||||
|
|
||||||
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
|
||||||
|
%files devel -f %{name}-devel.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
#%doc CHANGELOG.markdown README.markdown
|
||||||
|
|
||||||
|
%if %{with haddock}
|
||||||
|
%files doc -f %{name}-doc.files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%license LICENSE
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Dec 02 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.4.2.4-1mamba
|
||||||
|
- package created using the webbuild interface
|
Loading…
Reference in New Issue
Block a user