61 lines
2.0 KiB
RPMSpec
61 lines
2.0 KiB
RPMSpec
%define ghc_ver %(ghc --version | sed "s|.*version ||")
|
|
Name: ghc-base64-bytestring
|
|
Version: 1.0.0.1
|
|
Release: 1mamba
|
|
Summary: A Haskell library for working with base64-encoded data quickly and efficiently
|
|
Group: System/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: https://github.com/bos/base64-bytestring
|
|
## GITSOURCE https://github.com/bos/base64-bytestring.git 1.0.0.1
|
|
Source: https://github.com/bos/base64-bytestring.git/%{version}/base64-bytestring-%{version}.tar.bz2
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ghc
|
|
Requires: ghc = %{ghc_ver}
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
|
|
%description
|
|
This package provides a Haskell library for working with base64-encoded data quickly and efficiently, using the ByteString type.
|
|
|
|
%prep
|
|
%setup -q -n base64-bytestring-%{version}
|
|
|
|
%build
|
|
runghc Setup.hs configure \
|
|
--prefix=%{_prefix} \
|
|
--bindir=%{_bindir} \
|
|
--libdir=%{_libdir} \
|
|
--datadir=%{_datadir}
|
|
|
|
runghc Setup.hs build
|
|
|
|
%install
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
runghc Setup.hs copy --destdir=%{buildroot}
|
|
runghc Setup.hs register \
|
|
--gen-pkg-config="%{buildroot}%{_libdir}/ghc-%{ghc_ver}/base64-bytestring-%{version}/base64-bytestring-%{version}.conf"
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%post
|
|
ghc-pkg register %{_libdir}/ghc-%{ghc_ver}/base64-bytestring-%{version}/base64-bytestring-%{version}.conf &>/dev/null || true
|
|
:
|
|
|
|
%postun
|
|
ghc-pkg unregister %{_libdir}/ghc-%{ghc_ver}/base64-bytestring-%{version}/base64-bytestring-%{version}.conf &>/dev/null || true
|
|
:
|
|
|
|
%files
|
|
%defattr(-,root,root)
|
|
%dir %{_libdir}/ghc-%{ghc_ver}/base64-bytestring-%{version}
|
|
%{_libdir}/ghc-%{ghc_ver}/base64-bytestring-%{version}/*
|
|
%{_datadir}/doc/base64-bytestring-%{version}/LICENSE
|
|
|
|
%changelog
|
|
* Sun Sep 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.0.1-1mamba
|
|
- package created by silvan using the webbuild interface
|