81 lines
2.4 KiB
RPMSpec
81 lines
2.4 KiB
RPMSpec
%define ghc_ver %(ghc --numeric-version)
|
|
%define pkg_name %(echo %name | sed "s|^ghc-||")
|
|
|
|
Name: ghc-SHA
|
|
Version: 1.6.4.4
|
|
Release: 1mamba
|
|
Summary: GHC library: Implementations of the SHA suite of message digest functions
|
|
Group: Development/Libraries
|
|
Vendor: openmamba
|
|
Distribution: openmamba
|
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|
URL: http://hackage.haskell.org/package/%{pkg_name}
|
|
Source: http://hackage.haskell.org/package/SHA-%{version}/SHA-%{version}.tar.gz
|
|
License: BSD
|
|
## AUTOBUILDREQ-BEGIN
|
|
BuildRequires: ghc-libs
|
|
BuildRequires: glibc-devel
|
|
BuildRequires: libgmp-devel
|
|
## AUTOBUILDREQ-END
|
|
BuildRequires: ghc >= 9
|
|
BuildRequires: hscolour
|
|
Requires: ghc = %{ghc_ver}
|
|
|
|
%description
|
|
This library implements the SHA suite of message digest functions, according to NIST FIPS 180-2 (with the SHA-224 addendum), as well as the SHA-based HMAC routines.
|
|
The functions have been tested against most of the NIST and RFC test vectors for the various functions.
|
|
While some attention has been paid to performance, these do not presently reach the speed of well-tuned libraries, like OpenSSL.
|
|
|
|
%package devel
|
|
Summary: Haskell %{pkg_name} library development files
|
|
Provides: %{name}-static = %{version}-%{release}
|
|
Provides: %{name}-static%{?_isa} = %{version}-%{release}
|
|
%if %{defined ghc_version}
|
|
Requires: ghc = %{ghc_version}
|
|
%endif
|
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
|
|
|
%description devel
|
|
This package provides the Haskell %{pkg_name} library development files.
|
|
|
|
%if %{with haddock}
|
|
%package doc
|
|
Summary: Haskell %{pkg_name} library documentation
|
|
Requires: ghc-filesystem
|
|
|
|
%description doc
|
|
This package provides the Haskell %{pkg_name} library documentation.
|
|
%endif
|
|
|
|
%prep
|
|
%setup -q -n SHA-%{version}
|
|
|
|
%build
|
|
%ghc_lib_build
|
|
|
|
%install
|
|
%ghc_lib_install
|
|
|
|
rm -f %{buildroot}%{_ghclicensedir}/%{name}/LICENSE
|
|
|
|
%clean
|
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
|
|
|
%files -f %{name}.files
|
|
%defattr(-,root,root)
|
|
%license LICENSE
|
|
|
|
%files devel -f %{name}-devel.files
|
|
|
|
%if %{with haddock}
|
|
%files doc -f %{name}-doc.files
|
|
%license LICENSE
|
|
%endif
|
|
|
|
%changelog
|
|
* Tue Nov 14 2023 Automatic Build System <autodist@mambasoft.it> 1.6.4.4-1mamba
|
|
- automatic version update by autodist
|
|
|
|
* Mon Apr 13 2015 Davide Madrisan <davide.madrisan@gmail.com> 1.6.4.1-1mamba
|
|
- package created by autospec
|